Bug 469268 - Xorg backtrace with r300 while enabling desktop effects
Xorg backtrace with r300 while enabling desktop effects
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 18:27 EDT by Artem
Modified: 2009-02-19 14:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 14:36:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (35.97 KB, text/plain)
2008-10-30 18:27 EDT, Artem
no flags Details
Xorg.0.log (98.70 KB, text/plain)
2009-02-19 14:02 EST, Artem
no flags Details
dmesg (35.50 KB, text/plain)
2009-02-19 14:03 EST, Artem
no flags Details
lspci -v (12.94 KB, text/plain)
2009-02-19 14:04 EST, Artem
no flags Details

  None (edit)
Description Artem 2008-10-30 18:27:02 EDT
Created attachment 321991 [details]
dmesg

Description of problem:
Trying to enable/disable desktop effects in kde control panel get X crash with backtrace:

0: /usr/bin/X(xorg_backtrace+0x26) [0x4e7706]
1: /usr/bin/X(xf86SigHandler+0x39) [0x47a3a9]
2: /lib64/libc.so.6 [0x3a56833100]
3: /usr/lib64/xorg/modules/extensions//libglx.so [0xa20be0]
4: /usr/lib64/dri/r300_dri.so(__driUtilUpdateDrawableInfo+0xdc) [0x4de27b8]
5: /usr/lib64/dri/r300_dri.so(radeonGetLock+0xd0) [0x4de777a]
6: /usr/lib64/dri/r300_dri.so(r300FlushCmdBuf+0x2d) [0x4df2762]
7: /usr/lib64/dri/r300_dri.so(r300DestroyContext+0xda) [0x4dec046]
8: /usr/lib64/dri/r300_dri.so [0x4de2687]
9: /usr/lib64/xorg/modules/extensions//libglx.so [0xa22579]
10: /usr/lib64/xorg/modules/extensions//libglx.so(__glXFreeContext+0x6c) [0xa185cc]
11: /usr/lib64/xorg/modules/extensions//libglx.so [0xa18613]
12: /usr/bin/X(FreeResourceByType+0x105) [0x42eae5]
13: /usr/lib64/xorg/modules/extensions//libglx.so [0xa14f1e]
14: /usr/lib64/xorg/modules/extensions//libglx.so [0xa188f2]
15: /usr/bin/X(Dispatch+0x364) [0x446894]
16: /usr/bin/X(main+0x45d) [0x42ccdd]
17: /lib64/libc.so.6(__libc_start_main+0xe6) [0x3a5681e546]
18: /usr/bin/X [0x42c0b9]

Fatal server error:
Caught signal 11.  Server aborting


Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.9.0-37.fc10.x86_64
kernel-2.6.27.4-58.fc10.x86_64
xorg-x11-server-Xorg-1.5.2-10.fc10.x86_64

Additional info:
ati xpress 1100 (rs485)
Comment 1 Bug Zapper 2008-11-25 23:31:21 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 François Cami 2009-02-09 18:22:29 EST
Artem,
Does that still happen with current F10 ?
Could you add full dmesg, lspci -v, and /var/log/Xorg.0.log as _uncompressed text_ attachments to this bug ?
Additionally, could you try booting with nomodeset and report the result too ?
Comment 3 Artem 2009-02-19 14:02:32 EST
Created attachment 332610 [details]
Xorg.0.log
Comment 4 Artem 2009-02-19 14:03:12 EST
Created attachment 332611 [details]
dmesg
Comment 5 Artem 2009-02-19 14:04:00 EST
Created attachment 332612 [details]
lspci -v
Comment 6 Artem 2009-02-19 14:05:11 EST
Well, looks like it is ok now (with and without) nomodeset. However effects are extremely slow.
Comment 7 François Cami 2009-02-19 14:36:22 EST
Closing as it is fixed in a published package available in updates.

Artem, could you please file a separate bug about performance, if you can't find a similar open bug beforehand ? Thank you.

Note You need to log in before you can comment on or make changes to this bug.