Bug 469321 - [fix available] base cannot open open new format TT_hsqldb.odb from from qatesttools
[fix available] base cannot open open new format TT_hsqldb.odb from from qate...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
5.2
i386 Linux
medium Severity medium
: rc
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-31 05:39 EDT by Yolkfull Chow
Modified: 2009-09-02 05:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:08:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
replacement .odb for test-case (18.48 KB, application/vnd.oasis.opendocument.database)
2008-10-31 11:53 EDT, Caolan McNamara
no flags Details
and the original that it cannot open (15.75 KB, application/vnd.oasis.opendocument.database)
2008-10-31 11:58 EDT, Caolan McNamara
no flags Details
patch to enable 2.3.0 to open those new .odbs (751 bytes, patch)
2008-11-03 07:00 EST, Caolan McNamara
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1248 normal SHIPPED_LIVE openoffice.org bug fix update 2009-09-01 12:29:20 EDT

  None (edit)
Description Yolkfull Chow 2008-10-31 05:39:29 EDT
Description of problem:
Use automation testtool to run "f_java_upgrade.bas" will get following segmentation fault error messages:
----------
/usr/lib/openoffice.org/program/soffice: line 147: 28361 段错误               "$sd_prog/$sd_binary" "$@"


Version-Release number of selected component (if applicable):
openoffice.org-core-2.3.0-6.5.4.el5_2

How reproducible:
Everytime

Steps to Reproduce:
1.  setup OOO automation test env
2.  run f_java_upgrade.bas script
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Caolan McNamara 2008-10-31 11:47:45 EDT
One of the problems I have here is that I don't know for sure what qatesttool contents you have. I'm been assuming that it is a head checkout e.g. the contents of cvs -d:pserver:anoncvs@anoncvs.services.openoffice.org:/cvs co qatesttool

Looking at the tests there I believe that the actual crash is the same crash as rhbz#468136 i.e. a modal dialog of "Filter Dialog" appeared unexpectedly and then shutting down OOo ran into the intractable problem of http://www.openoffice.org/issues/show_bug.cgi?id=95654

So the question is why did the unexpected dialog appear. I think it is because the version of OOo we are testing is too old for some of the tests. Maybe/Maybe not. But If you take the attachment I will put here and overwrite qatesttool/base/input/hsql_datasource/TT_hsqldb.odb with it then I believe that will workaround the problem.

The original TT_hsqldb.odb *can* be opened with 3.0.0 and with 2.4.1, but not apparently with 2.3.0
Comment 2 Caolan McNamara 2008-10-31 11:53:27 EDT
Created attachment 322100 [details]
replacement .odb for test-case
Comment 3 Caolan McNamara 2008-10-31 11:58:26 EDT
Created attachment 322102 [details]
and the original that it cannot open
Comment 4 Caolan McNamara 2008-10-31 11:59:21 EDT
So I believe the question becomes how come 2.3.0 cannot open the original TT_hsqldb.odb leading to the wrong dialog getting presented to the testtool.
Comment 5 Caolan McNamara 2008-11-03 07:00:45 EST
Created attachment 322295 [details]
patch to enable 2.3.0 to open those new .odbs
Comment 6 Caolan McNamara 2008-11-03 07:02:39 EST
We can patch it up to be able to open those new format .odbs. And we would get this for free on any rebase to >= 2.4.0
Comment 7 David Tardon 2008-11-03 07:36:51 EST
dtardon->yzhou: You _really_ should use ooo230 revision of qatesttool for testing OOo 2.3.0.; what's the logic in checking for features which simply aren't there?
Comment 8 Caolan McNamara 2009-03-12 06:16:30 EDT
committed to >= 2.3.0-6.11
Comment 12 errata-xmlrpc 2009-09-02 05:08:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1248.html

Note You need to log in before you can comment on or make changes to this bug.