Bug 469325 - Default font is too heavy in texttopaps
Default font is too heavy in texttopaps
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: paps (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-31 06:16 EDT by Tim Waugh
Modified: 2008-11-22 11:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-19 09:46:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2008-10-31 06:16:35 EDT
Description of problem:
When using texttopaps as the CUPS text/plain filter, text comes out much bolder than with the CUPS texttops filter.

Version-Release number of selected component (if applicable):
paps-0.6.8-6.fc9

How reproducible:
100%

Steps to Reproduce:
1. echo abcde | /usr/lib/cups/filter/texttops 1 x '' 1 '' > cups.ps
2. echo abcde | /usr/lib/cups/filter/texttopaps 1 x '' 1 '' > paps.ps
3. evince cups.ps & evince paps.ps
  
Actual results:
paps.ps is much heavier than cups.ps.

Expected results:
Comparable output.

Additional info:
This has come up frequently on the cups mailing list since we switched to texttopaps as the text/plain filter.
Comment 1 Akira TAGOH 2008-10-31 06:38:23 EDT
So which font would you prefer for default?
Comment 2 Tim Waugh 2008-10-31 07:01:06 EDT
"Courier" (which fontconfig maps to Nimbus Mono L) looks better I think.  It's closer in appearance to the font CUPS provides.

I don't mind which font paps uses by default, but it would be nice for 'texttopaps' (i.e. in CUPS mode) to use "Courier".
Comment 3 Tim Waugh 2008-11-03 05:58:33 EST
Actually it would be brilliant to be able to use the Postscript Type 1 font in /usr/share/cups/fonts/Courier* for this, but I'm not sure what is needed to make that happen.

Obviously it won't have a complete UTF-8 glyph set, but with correct fontconfig configuration I expect it will fall back to Nimbus Mono L/Liberation Mono for those glyphs.
Comment 4 Akira TAGOH 2008-11-07 08:55:05 EST
testing package available on http://tagoh.fedorapeople.org/tests/469325/

"Courier" as the font name is used for texttopaps in this testing package.
Comment 5 Tim Waugh 2008-11-14 09:59:28 EST
Yes, works fine in that package.
Comment 6 Akira TAGOH 2008-11-17 05:10:28 EST
Fixed in paps-0.6.8-8.fc{8,9,10,11}.
Comment 7 Fedora Update System 2008-11-17 05:12:39 EST
paps-0.6.8-8.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/paps-0.6.8-8.fc10
Comment 8 Fedora Update System 2008-11-17 05:13:16 EST
paps-0.6.8-8.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/paps-0.6.8-8.fc9
Comment 9 Fedora Update System 2008-11-17 05:13:57 EST
paps-0.6.8-8.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/paps-0.6.8-8.fc8
Comment 10 Fedora Update System 2008-11-19 09:46:51 EST
paps-0.6.8-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-11-19 09:47:07 EST
paps-0.6.8-8.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2008-11-22 11:58:13 EST
paps-0.6.8-8.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.