Bug 469330 - [fix available] "Euro Converter" always claims that calc files are not really calc files
[fix available] "Euro Converter" always claims that calc files are not really...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
5.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
:
: 469617 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-31 06:37 EDT by Golita Yue
Modified: 2009-09-02 05:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:08:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
punts.sxc (5.30 KB, application/vnd.sun.xml.calc)
2008-10-31 06:37 EDT, Golita Yue
no flags Details
patch to get this working (2.80 KB, patch)
2008-10-31 10:17 EDT, Caolan McNamara
no flags Details | Diff
Download the punts.sxc (5.30 KB, application/vnd.sun.xml.calc)
2009-06-01 21:32 EDT, Yewei Shao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 95702 None None None Never

  None (edit)
Description Golita Yue 2008-10-31 06:37:22 EDT
Created attachment 322037 [details]
punts.sxc

Description of problem:
cannot create new converted file

Version-Release number of selected component (if applicable):
openoffice.org-2.3.0-6.5.4.el5_2

How reproducible:
every time

Steps to Reproduce:
1. From the menu bar,  select File - Wizards - Euro Converter.
2. The Wizards Euro Convertr dialog should be launched.
3. In the Wizards Euro dialog select
          3.1 Extent - Complete directory
          3.2 Currencies - Irish Punt.
          3.3 Source Directory - the directory where punts.sxc is stored.
          3.4 Target Directory - directory where converted document is to be   stored.
          3.5  Ensure all other options are checked off.
4. Select "Convert" in the  Wizards Euro dialog.
5. The Euro Converter dialog should show the files which were converted.      6. Select Finish on the Euro Converter dialog.
  
Actual results:
New converted file be created.

Expected results:
There is not the new converted file. 

Additional info: the punts.sxc is in attachment
Comment 1 David Tardon 2008-10-31 08:25:59 EDT
dtardon->gyue: I suppose you swapped the actual and expected results sentences, because Euro Conversion does not work for me.

dtardon->caolanm: Does it work for you? For me, in single file mode it only shows a dialog with message "Please select a OpenOffice Calc document for editing!" after clicking on Convert. In whole directory mode it continues on next page, but it shows no file to convert. Moreover, I've got the same (unfunctional) results on DEV300_m33... On F-9 it works OK.
Comment 2 Caolan McNamara 2008-10-31 10:17:21 EDT
Created attachment 322066 [details]
patch to get this working
Comment 3 Caolan McNamara 2008-10-31 10:22:06 EDT
A: 
caolanm->dtardon: The DEV300 & 3.0.0 problems are now at http://www.openoffice.org/issues/show_bug.cgi?id=95702 A hideous mess of partial implementation and broken backwards compatibility.

B:
In RHEL-5 we have 2.3.0 which is *also* broken in a very similar way. The attached patch here fixes it to 2.4.1-level which works. so we can fix this as long as we are < 3.0.0. 

But in 3.0.0 it is again broken, with an additional problem that the api the code expects to use to work is now non-functional in a key area. So either the wizards should revert to the old api, and the old api fixed to work again. Or the wizards convert correctly to the new api. 3.0.0 is outside the scope of this issue. So we have a fix for RHEL-5 if desired, though if we resync to 3.0.0 at some stage we'll have to re-examine the issue.
Comment 4 David Tardon 2008-11-03 01:55:20 EST
*** Bug 469617 has been marked as a duplicate of this bug. ***
Comment 5 Caolan McNamara 2009-03-12 05:55:58 EDT
checked in for >= 2.3.0-6.11
Comment 7 Yewei Shao 2009-06-01 06:43:24 EDT
mshao-> caolanm, when I verify this bug in RHEL 5 and using version-Release: openoffice.org-core-2.3.0.6.11.el5, and following gyue's steps, the result is that there is no new converted file. Is this bug fixed in openoffice.org-core-2.3.0.6.11.el5?
Comment 8 David Tardon 2009-06-01 08:11:48 EDT
dtardon->mshao: Yes, it is. I've just re-checked it with 2.3.0-6.11 and it works without any problem for both whole directory and single file conversions. Does it show any error message? Are you sure the target directory is writeable?
Comment 9 Yewei Shao 2009-06-01 21:31:10 EDT
The problem is not exist now, the reason that I was failed yesterday is that I used a not very exactly punts.sxc file. When I download a new punts.sxc files from other place this morning, it works for me without any problem. Thanks for dtardon.
Comment 10 Yewei Shao 2009-06-01 21:32:07 EDT
Created attachment 346160 [details]
Download the punts.sxc
Comment 11 David Tardon 2009-06-02 01:01:36 EDT
dtardon->mshao: The file from comment 10 is exactly the same as that from attachment 1 [details] of this report. That one just had a wrong MIME type, thus a browser tried to display it instead of showing save dialog. I suppose that was your main concern?
Comment 14 errata-xmlrpc 2009-09-02 05:08:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1248.html

Note You need to log in before you can comment on or make changes to this bug.