Bug 46936 - A couple of xfs script and binary bugs in Redhat 7.0 (not xinitrc, sorry)
Summary: A couple of xfs script and binary bugs in Redhat 7.0 (not xinitrc, sorry)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-02 09:41 UTC by Stone Hared
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-02 09:41:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stone Hared 2001-07-02 09:41:04 UTC
There seems to be a bug in the script which starts X font server -
 /etc/init.d/xfs. The bug reveals itself when root's umask does not give 
other users read permission (i.e. 027). More specifically, after a 
function buildfontlist() makes font directory it should

chmod a+r fonts.dir
chmod a+r fonts.scale ( if present )

Alas, it only does chmod +r, which is not enough, since man chmod reads:

If none of the letters 'ugoa' are given, the effect is as if `a' were 
given, but bits that are set in the umask are not affected.

In effect, xfs in -droppriv mode is unable to access aforementioned files 
and does not start at all. What makes thing worse is that in -daemon mode 
it still returns success regardless of what happened. So the poor novice 
who tampered with root's umask sees:

	Starting X Font Server:                               [  OK  ]

The only symptom is that X refuses to start:

	(...)
	Could not init font path element unix/:7100, removing from list!

	Fatal server error:
	could not open default font 'fixed'
	(...)

Ouch! But there is more to come.

	# xfs -droppriv
	FontCacheInitialize: hi=1048576, lo=786432, bal=70
	xfs error: Element #1 (starting at 0) of font path is bad or has a 
bad font:
	"/usr/X11R6/lib/X11/fonts/misc/"

Nothing strange, except that /usr/X11R6/lib/X11/fonts/misc/ is OK in this 
case. It's just the message that always points to element #1. Needless to 
say, this makes debugging a bit more frustrating.

In case these bugs were unreported up to date, you owe me a T-shirt.

How reproducible:
Always

Steps to Reproduce:
see description.
1. set root's umask to 027
2. add a new font file or whatever so that buildfontlist() is needed
3. run service start xfs
	

Actual Results:  see description

Expected Results:  see description

Additional info:

gosh, it is supposed to be EASY bug form. Instead of sending one email I 
had to create new account, and wade through a plethora of webpages. I know 
it is all supposed to make developers' life easier, but for god's sake, 
hadn't I been determined to report a bug I would give up ages ago.
Update: and all that to fill in simple form...

Comment 1 Mike A. Harris 2001-07-02 23:10:41 UTC
This has been fixed long ago, sorry no tee shirt.  ;o)



Note You need to log in before you can comment on or make changes to this bug.