This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 469379 - Evince 'Find' can get stuck on a page
Evince 'Find' can get stuck on a page
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evince (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Marek Kašík
desktop-bugs@redhat.com
:
Depends On:
Blocks: 499522
  Show dependency treegraph
 
Reported: 2008-10-31 11:17 EDT by Alan Matsuoka
Modified: 2010-10-23 01:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When searching for a string in a document, evince may have miscalculated the scope of the search if a string appeared more than once on a single page. Consequently, if a user was stepping though the search results using the "Find Next" button, evince would not step past the page with multiple matches. With this update, evince now correctly searches the whole document, resolving this issue. (BZ#469379)
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:03:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix find problem (2.55 KB, patch)
2008-10-31 11:17 EDT, Alan Matsuoka
no flags Details | Diff

  None (edit)
Description Alan Matsuoka 2008-10-31 11:17:18 EDT
Created attachment 322091 [details]
patch to fix find problem

Description of problem:
Evince's search function gets stuck on one particular page unless you scroll the buffer.

How reproducible:
Always

Steps to Reproduce:
Open up a document such as: http://download.intel.com/design/chipsets/datashts/318610.pdf
Search for something like NERR_FAT_FB and repeatedly hit the find next button. When you get to the instance on page 220 3.9.22.10 it will get stuck until you scroll the page down a bit.

Actual results:
it gets stuck

Expected results:
it moves to the next instance even if it isn't on the same page

Additional info:
It seems to happen when there are multiple instances of the search string on the same page. It seems to work properly when there is only one instance on the page.

Looks like:

2006-10-08  Nickolay V. Shmyrev  <nshmyrev@yandex.ru>

       * shell/ev-view-private.h:
       * shell/ev-view.c: (view_set_adjustment_values),
       (view_update_range_and_current_page),
       (ensure_rectangle_is_visible), (ev_view_size_allocate):

       Fixes bug #343199, current page now follows find page.

might fix it.

Seems to work for me. 

Attached a patch
Comment 1 RHEL Product and Program Management 2009-03-26 13:06:53 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 2 Alan Matsuoka 2009-03-26 13:24:08 EDT
setting for 5.5
Comment 3 Marek Kašík 2009-11-12 08:53:40 EST
Hi,

I committed the backported patch from upstream.

Marek
Comment 7 Ryan Lerch 2010-03-10 19:45:44 EST
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
When searching for a string in a document, evince may have miscalculated the scope of the search if a string appeared more than once on a single page. Consequently, if a user was stepping though the search results using the "Find Next" button, evince would not step past the page with multiple matches. With this update, evince now correctly searches the whole document, resolving this issue. (BZ#469379)
Comment 8 errata-xmlrpc 2010-03-30 04:03:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0195.html

Note You need to log in before you can comment on or make changes to this bug.