Bug 469383 - beagle-search crashes (System.DllNotFoundException: libgnome-desktop-2.so.2)
beagle-search crashes (System.DllNotFoundException: libgnome-desktop-2.so.2)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
10
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-31 11:32 EDT by sangu
Modified: 2008-11-29 10:47 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.3.8-13.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-29 10:47:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
click tree item in beagle-search (97.91 KB, image/png)
2008-10-31 11:32 EDT, sangu
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 556243 None None None Never

  None (edit)
Description sangu 2008-10-31 11:32:28 EDT
Created attachment 322094 [details]
click tree item in beagle-search

Description of problem:
$ cat ~/.xsession-errors
[...]
*** Using mono runtime at mono ***
Warn: Inotify watches may be too low (8192) for some users!  Increase it to at least 65535 by setting fs.inotify.max_user_watches in /etc/sysctl.conf
Debug: Using utf8 encoding for filenames
Error instantiating tile:
System.DllNotFoundException: libgnome-desktop-2.so.2
  at (wrapper managed-to-native) Beagle.Search.Tiles.ApplicationActivator:gnome_desktop_item_new_from_uri (string,int,intptr)
  at Beagle.Search.Tiles.ApplicationActivator.Validate (Beagle.Hit hit) [0x00000] 
  at Beagle.Search.Tiles.TileActivatorOrg.MakeTile (Beagle.Hit hit, Beagle.Query query) [0x00000] 
No tile found for: file:///usr/share/applications/gnome-bug-buddy.desktop (File)
Error instantiating tile:
System.DllNotFoundException: libgnome-desktop-2.so.2
  at (wrapper managed-to-native) Beagle.Search.Tiles.ApplicationActivator:gnome_desktop_item_new_from_uri (string,int,intptr)
  at Beagle.Search.Tiles.ApplicationActivator.Validate (Beagle.Hit hit) [0x00000] 
  at Beagle.Search.Tiles.TileActivatorOrg.MakeTile (Beagle.Hit hit, Beagle.Query query) [0x00000] 
No tile found for: file:///usr/share/applications/emacs.desktop (File)
Error instantiating tile:
System.DllNotFoundException: libgnome-desktop-2.so.2
  at (wrapper managed-to-native) Beagle.Search.Tiles.ApplicationActivator:gnome_desktop_item_new_from_uri (string,int,intptr)
  at Beagle.Search.Tiles.ApplicationActivator.Validate (Beagle.Hit hit) [0x00000] 
  at Beagle.Search.Tiles.TileActivatorOrg.MakeTile (Beagle.Hit hit, Beagle.Query query) [0x00000] 
No tile found for: file:///usr/share/applications/emacs.desktop (File)
Debug: Scope changed: 프로그램 maps to 'filetype:application OR source:applications'
Error instantiating tile:
System.DllNotFoundException: libgnome-desktop-2.so.2
  at (wrapper managed-to-native) Beagle.Search.Tiles.ApplicationActivator:gnome_desktop_item_new_from_uri (string,int,intptr)
  at Beagle.Search.Tiles.ApplicationActivator.Validate (Beagle.Hit hit) [0x00000] 
  at Beagle.Search.Tiles.TileActivatorOrg.MakeTile (Beagle.Hit hit, Beagle.Query query) [0x00000] 
No tile found for: file:///home/sangu/rpmbuild/BUILD/emacs-23.0.60/etc/emacs.desktop (File)
Error instantiating tile:
System.DllNotFoundException: libgnome-desktop-2.so.2
  at (wrapper managed-to-native) Beagle.Search.Tiles.ApplicationActivator:gnome_desktop_item_new_from_uri (string,int,intptr)
  at Beagle.Search.Tiles.ApplicationActivator.Validate (Beagle.Hit hit) [0x00000] 
  at Beagle.Search.Tiles.TileActivatorOrg.MakeTile (Beagle.Hit hit, Beagle.Query query) [0x00000] 
No tile found for: file:///home/sangu/Work/cvs/emacs/nextstep/GNUstep/Emacs.base/Resources/Emacs.desktop (File)
Error instantiating tile:
System.DllNotFoundException: libgnome-desktop-2.so.2
  at (wrapper managed-to-native) Beagle.Search.Tiles.ApplicationActivator:gnome_desktop_item_new_from_uri (string,int,intptr)
  at Beagle.Search.Tiles.ApplicationActivator.Validate (Beagle.Hit hit) [0x00000] 
  at Beagle.Search.Tiles.TileActivatorOrg.MakeTile (Beagle.Hit hit, Beagle.Query query) [0x00000] 
No tile found for: file:///home/sangu/rpmbuild/BUILD/emacs-23.0.60/nextstep/GNUstep/Emacs.base/Resources/Emacs.desktop (File)
Error instantiating tile:
System.DllNotFoundException: libgnome-desktop-2.so.2
  at (wrapper managed-to-native) Beagle.Search.Tiles.ApplicationActivator:gnome_desktop_item_new_from_uri (string,int,intptr)
  at Beagle.Search.Tiles.ApplicationActivator.Validate (Beagle.Hit hit) [0x00000] 
  at Beagle.Search.Tiles.TileActivatorOrg.MakeTile (Beagle.Hit hit, Beagle.Query query) [0x00000] 
No tile found for: file:///home/sangu/Work/cvs/emacs/etc/emacs.desktop (File)
Error instantiating tile:
System.DllNotFoundException: libgnome-desktop-2.so.2
  at (wrapper managed-to-native) Beagle.Search.Tiles.ApplicationActivator:gnome_desktop_item_new_from_uri (string,int,intptr)
  at Beagle.Search.Tiles.ApplicationActivator.Validate (Beagle.Hit hit) [0x00000] 
  at Beagle.Search.Tiles.TileActivatorOrg.MakeTile (Beagle.Hit hit, Beagle.Query query) [0x00000] 
No tile found for: file:///usr/share/applications/emacs.desktop (File)
Marshaling activate signal
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.NullReferenceException: Object reference not set to an instance of an object
  at Beagle.Search.GroupView.OnCategoryToggle (ScopeType catScope) [0x00000] 
  at Beagle.Search.Category.OnActivated (System.Object obj, System.EventArgs args) [0x00000] 
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] 
  --- End of inner exception stack trace ---
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] 
  at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] 
  at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x00000] 
  at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00000] 
  at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000] 
  at GLib.Signal.ClosureInvokedCB (System.Object o, GLib.ClosureInvokedArgs args) [0x00000] 
  at GLib.SignalClosure.Invoke (GLib.ClosureInvokedArgs args) [0x00000] 
  at GLib.SignalClosure.MarshalCallback (IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data) [0x00000] 
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at GLib.SignalClosure.MarshalCallback(IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Gnome.Program.Run()
   at Beagle.Search.Driver.Main(System.String[] args)


Version-Release number of selected component (if applicable):
0.3.8-9.fc10

How reproducible:
always

Steps to Reproduce:
1. launch beagle-search
2. search GNOME
3. Click Images (Tree  Item)
  
Actual results:


Expected results:


Additional info:
gnome-desktop-sharp-2.24.0-3.fc10.i386
gnome-sharp-2.24.0-1.fc10.i386
Comment 1 sangu 2008-10-31 11:39:52 EDT
BR gnome-desktop-sharp ?
Comment 2 Adel Gadllah 2008-11-02 09:10:27 EST
Thanks for the report.

Adding BR won't solve the issue.

The problem is that beagle-search has a hardcoded dll import for libgnome-desktop-2.so.7. I have added a patch which bumps this to libgnome-desktop-2.so.7. (And a requires for gnome-desktop >= 2.24.0)

Please test this scratch build once its done: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=914713
Comment 3 sangu 2008-11-03 03:47:01 EST
in beagle-gnome-0.3.8-11.fc10

$ beagle-search 
Debug: Scope changed: Documents maps to 'filetype:document'
Debug: Scope changed: Applications maps to 'filetype:application OR source:applications'
Marshaling activate signal
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.NullReferenceException: Object reference not set to an instance of an object
  at Beagle.Search.GroupView.OnCategoryToggle (ScopeType catScope) [0x00000] 
  at Beagle.Search.Category.OnActivated (System.Object obj, System.EventArgs args) [0x00000] 
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] 
  --- End of inner exception stack trace ---
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] 
  at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] 
  at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x00000] 
  at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00000] 
  at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000] 
  at GLib.Signal.ClosureInvokedCB (System.Object o, GLib.ClosureInvokedArgs args) [0x00000] 
  at GLib.SignalClosure.Invoke (GLib.ClosureInvokedArgs args) [0x00000] 
  at GLib.SignalClosure.MarshalCallback (IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data) [0x00000] 
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at GLib.SignalClosure.MarshalCallback(IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Gnome.Program.Run()
   at Beagle.Search.Driver.Main(System.String[] args)
Comment 4 Adel Gadllah 2008-11-08 13:54:23 EST
OK the dll not found error seems to be unrelated to the crash.
The crash was fixed upstream in August. I have backported the fix and fixed the dll issue too.

Please test http://koji.fedoraproject.org/koji/buildinfo?buildID=68878
Comment 5 Bug Zapper 2008-11-25 23:33:31 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.