Bug 469544 - Firefox crashes with Bus-Error
Firefox crashes with Bus-Error
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-02 03:40 EST by Alwin
Modified: 2009-07-26 05:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-03 16:08:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pluginslist (932 bytes, text/plain)
2008-11-03 14:19 EST, Alwin
no flags Details
Firexox debug output (2.17 KB, text/plain)
2008-11-03 14:21 EST, Alwin
no flags Details

  None (edit)
Description Alwin 2008-11-02 03:40:14 EST
Description of problem:
Since latest update a few days ago firefox won't start anymore but crashes with bus error.

Version-Release number of selected component (if applicable):

Firefox: 3.0.2
nspluginwrapper: 1.1.2 (i386 and x86_64)

How reproducible:
starting firefox from xterm and just see 


/usr/bin/mozilla-plugin-config: line 73:  4863 Bus-Zugriffsfehler      $WRAPPER_LIB_DIR/nspluginwrapper/plugin-config -f > /dev/null 2>&1
/usr/lib64/firefox-3.0.2/run-mozilla.sh: line 131:  4876 Bus-Zugriffsfehler      "$prog" ${1+"$@"}

calling plugin-config results in

/usr/lib64/nspluginwrapper/plugin-config -f
Bus-Zugriffsfehler


cu
Comment 1 Matěj Cepl 2008-11-03 06:17:01 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

Please also install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of gdb debugger. Then use command run and do whatever you did to make firefox crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Alwin 2008-11-03 14:19:22 EST
Created attachment 322356 [details]
Pluginslist

output of

 rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*
Comment 3 Alwin 2008-11-03 14:21:24 EST
Created attachment 322357 [details]
Firexox debug output

Debugger output, firefox -g started always ddd

I made 

  debuginfo-install firefox

and 
  
  debuginfo-install xulrunner 

before this output.
Comment 4 Alwin 2008-11-03 14:50:38 EST
I'm sorry....

I heard just this moment about a small power blackout. So I checked again and yes - a simple removing of xulrunner, nspluginwrapper and firefox and re-installing fixed the problem.

So it looks like a damaged filesystem.

Real sorry about wasting your time.
Comment 5 Christopher Aillon 2008-11-03 16:07:47 EST
No worries, glad it works.
Comment 6 coolnezz 2009-07-26 05:45:35 EDT
(In reply to comment #4)
> I'm sorry....
> 
> I heard just this moment about a small power blackout. So I checked again and
> yes - a simple removing of xulrunner, nspluginwrapper and firefox and
> re-installing fixed the problem.
> 
> So it looks like a damaged filesystem.
> 
> Real sorry about wasting your time.  




yes!  this worked for me also!
Thanks!

Note You need to log in before you can comment on or make changes to this bug.