Bug 469550 - System-Config-Samba
System-Config-Samba
Status: CLOSED DUPLICATE of bug 466481
Product: Fedora
Classification: Fedora
Component: system-config-samba (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-02 06:48 EST by Frank Murphy
Modified: 2008-11-03 09:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-03 09:40:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Murphy 2008-11-02 06:48:26 EST
Description of problem: Clicking on "System > Administration > Samba"
exits with "Unknown Error"


Version-Release number of selected component (if applicable):
system-config-samba-1.2.64-1.fc10.noarch

How reproducible:
Always

Steps to Reproduce:
1. As description
2. 
3.
  
Actual results:
As description

Expected results:
Ability to add users\shares

Additional info:
[root@server-01 ~]# /usr/share/system-config-samba/system-config-samba.py
Traceback (most recent call last):
  File "/usr/share/system-config-samba/system-config-samba.py", line 44, in <module>
    mainWindow.MainWindow (debug_flag = debug_flag, use_dbus = use_dbus)
  File "/usr/share/system-config-samba/mainWindow.py", line 89, in __init__
    self.samba_backend = sambaBackend.SambaBackend (bus = self._bus)
  File "/usr/lib/python2.5/site-packages/scsamba/dbus/proxy/sambaBackend.py", line 31, in __init__
    self.dbus_object = bus.get_object (dbus_service_name, self.dbus_service_path)
  File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 241, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 183, in activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 281, in start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ExecFailed: Cannot launch daemon, file not found or permissions invalid
Comment 1 antonio montagnani 2008-11-03 03:54:44 EST
another cyclic bug... :-(
Comment 2 Nils Philippsen 2008-11-03 09:40:40 EST
(In reply to comment #1)
> another cyclic bug... :-(

I don't get it. Anyway, this would be a duplicate of bug #466481.

*** This bug has been marked as a duplicate of bug 466481 ***
Comment 3 antonio montagnani 2008-11-03 09:52:01 EST
I didn't realize that it was component system-config-samba-1.2.64-1.fc10.noarch, and I had already solved grabbing from koij following I think your suggestion, while on a freshly installed machine I incurred in this bug.
Anyway now it has been solved with latest upgrade from official repo.

Tnx

Note You need to log in before you can comment on or make changes to this bug.