Bug 469601 - My wireless card will not activate on boot. the card needs to be remove and reinstalled for the crad to work
My wireless card will not activate on boot. the card needs to be remove and r...
Status: CLOSED DUPLICATE of bug 468938
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-02 22:35 EST by Tom Barkey
Modified: 2008-12-04 14:51 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 14:51:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Barkey 2008-11-02 22:35:56 EST
Summary:

SELinux is preventing consoletype (consoletype_t) "read" to
/var/lib/dhclient/dhclient-wlan0.leases (dhcpc_state_t).

Detailed Description:

SELinux denied access requested by consoletype. It is not expected that this
access is required by consoletype and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

Sometimes labeling problems can cause SELinux denials. You could try to restore
the default system file context for /var/lib/dhclient/dhclient-wlan0.leases,

restorecon -v '/var/lib/dhclient/dhclient-wlan0.leases'

If this does not work, there is currently no automatic way to allow this access.
Instead, you can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                unconfined_u:system_r:consoletype_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:dhcpc_state_t:s0
Target Objects                /var/lib/dhclient/dhclient-wlan0.leases [ file ]
Source                        consoletype
Source Path                   /sbin/consoletype
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           initscripts-8.76.4-1
Target RPM Packages           
Policy RPM                    selinux-policy-3.3.1-103.fc9
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall_file
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain 2.6.26.6-79.fc9.i686
                              #1 SMP Fri Oct 17 14:52:14 EDT 2008 i686 i686
Alert Count                   5
First Seen                    Mon 25 Aug 2008 08:41:44 PM EDT
Last Seen                     Sun 02 Nov 2008 10:15:07 PM EST
Local ID                      3430f450-d35d-4538-922f-77c6e657ed6f
Line Numbers                  

Raw Audit Messages            

host=localhost.localdomain type=AVC msg=audit(1225682107.342:32): avc:  denied  { read } for  pid=2900 comm="consoletype" path="/var/lib/dhclient/dhclient-wlan0.leases" dev=dm-0 ino=319998 scontext=unconfined_u:system_r:consoletype_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:dhcpc_state_t:s0 tclass=file

host=localhost.localdomain type=SYSCALL msg=audit(1225682107.342:32): arch=40000003 syscall=11 success=yes exit=0 a0=8f8f598 a1=8f8f030 a2=8f8f250 a3=0 items=0 ppid=2899 pid=2900 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="consoletype" exe="/sbin/consoletype" subj=unconfined_u:system_r:consoletype_t:s0-s0:c0.c1023 key=(null)
Comment 1 Daniel Walsh 2008-12-04 08:39:16 EST
This AVC has nothing to do with the card not being able to start at boot, it is a leaked file descriptor from dhclient and would prevent nothing from working.
Comment 2 David Cantrell 2008-12-04 14:51:33 EST

*** This bug has been marked as a duplicate of bug 468938 ***

Note You need to log in before you can comment on or make changes to this bug.