Bug 469610 - Conversation window does not scroll to bottom automatically when new message is received if "Close IMs immediately when the tab is closed" preference is not checked.
Conversation window does not scroll to bottom automatically when new message ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
9
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-03 01:03 EST by Denny Crane
Modified: 2008-11-07 14:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 14:50:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denny Crane 2008-11-03 01:03:01 EST
Description of problem:
Conversation window does not scroll to bottom automatically when new message is received if "Close IMs immediately when the tab is closed" preference is not checked. (Also occurs if you reopen the conversation yourself.)

If you are having a conversation, then close the window, then your buddy IMs you again within a few minutes, the previous conversation re-opens with this feature enabled (it is "enabled" when the checkbox is off). In Fedora, there is an annoying bug wherein you have to scroll to the bottom of the IM "log" to see the newest message.

I was assuming for a long time that this was a Pidgin bug, and guessed it would be an easy fix and there'd be plenty of complaints, so I never bothered reporting it. However, it appears that the problem is specific to Pidgin on Fedora. I tried in Ubuntu 8.10 and it worked fine.

Version-Release number of selected component (if applicable):
2.5.1 as well as 2.5.2 (from updates-testing)

How reproducible:
100%


Steps to Reproduce:
1. Uncheck "Close IMs immediately when the tab is closed" preference.
2. Start conversation that is long enough to have a scrollbar.
3. Close conversation.
4. Re-open conversation by double-clicking on the same s/n from your buddy list, or wait for buddy to send next message (tell them to IM after 10 seconds or something).
  
Actual results:
Conversation window re-appears but is not scrolled to bottom

Expected results:
Conversation window should re-appear, and you should be scrolled to bottom of content.


Additional info:
I like french fries.
Comment 1 Denny Crane 2008-11-07 14:51:35 EST
Actually, this bug is not specific to Fedora -- it only occurs when the option mentioned above is checked AND the History plugin is enabled (which, I believe, it is by default in Fedora).

Note You need to log in before you can comment on or make changes to this bug.