Bug 469658 - OOo will crash during running test script "w_undo.bas" when using "gtk" vclplug, but not with "gen" vclplug
OOo will crash during running test script "w_undo.bas" when using "gtk" vclpl...
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-03 05:03 EST by Yolkfull Chow
Modified: 2008-11-03 20:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-03 12:00:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 56552 None None None Never

  None (edit)
Description Yolkfull Chow 2008-11-03 05:03:52 EST
Description of problem:
Running automation test script "w_undo.bas", OOO will crash at least two times.
Following is backtrace output:
-------------
(I)    x.org loaded video driver of...
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.2-42.el5-i386
(V)    kernel is: Linux 2.6.18-92.el5 #1 SMP Tue Apr 29 13:16:12 EDT 2008 i686 i686 i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.3.0-6.5.4.el5_2-i386
(VII)  depth of root window:    16 planes
(VIII) accessibility is: false
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start stackreport details ...
0x02021338: 0x001cd374: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x21338
0x02021cf7: 0x001cd374: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x21cf7
0x00f44420: 0x00000000:  + 0x420 (__kernel_sigreturn + 0x0)
0x02eaf2b5: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x2222b5 (Window::GetParent() const + 0xd)
0x02e93fb6: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x206fb6
0x02ea2c30: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x215c30 (Window::SetParent(Window*) + 0x84)
0x0433ebb2: 0x0027febc: /usr/lib/openoffice.org/program/libfwk680li.so + 0xa1bb2
0x04347789: 0x0027febc: /usr/lib/openoffice.org/program/libfwk680li.so + 0xaa789
0x0434eb15: 0x0027febc: /usr/lib/openoffice.org/program/libfwk680li.so + 0xb1b15
0x042f20b7: 0x0027febc: /usr/lib/openoffice.org/program/libfwk680li.so + 0x550b7
0x042f7915: 0x0027febc: /usr/lib/openoffice.org/program/libfwk680li.so + 0x5a915
0x04317222: 0x0027febc: /usr/lib/openoffice.org/program/libfwk680li.so + 0x7a222
0x043179a1: 0x0027febc: /usr/lib/openoffice.org/program/libfwk680li.so + 0x7a9a1
0x04317bfd: 0x0027febc: /usr/lib/openoffice.org/program/libfwk680li.so + 0x7abfd
0x02d1d5f3: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x905f3
0x02efe095: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x271095
0x02efdfc5: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x270fc5
0x02d1d5f3: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x905f3
0x02eae196: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x221196
0x00e38261: 0x00082b5c: /usr/lib/openoffice.org/program/libvclplug_gen680li.so + 0x1f261
0x00e60fc8: 0x00082b5c: /usr/lib/openoffice.org/program/libvclplug_gen680li.so + 0x47fc8 (SalDisplay::DispatchInternalEvent() + 0x78)
0x00ef9969: 0x00058ed0: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so + 0x14969
0x00ef9998: 0x00058ed0: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so + 0x14998
0x07ac35e1: 0x0009c63c: /lib/libglib-2.0.so.0 + 0x295e1
0x07ac5342: 0x0009c63c: /lib/libglib-2.0.so.0 + 0x2b342 (g_main_context_dispatch + 0x182)
0x07ac831f: 0x0009c63c: /lib/libglib-2.0.so.0 + 0x2e31f
0x07ac8885: 0x0009c63c: /lib/libglib-2.0.so.0 + 0x2e885 (g_main_context_iteration + 0x65)
0x00ef9798: 0x00058ed0: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so + 0x14798
0x00e671f1: 0x00082b5c: /usr/lib/openoffice.org/program/libvclplug_gen680li.so + 0x4e1f1 (X11SalInstance::Yield(bool, bool) + 0x2f)
0x02d2583f: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x9883f (Application::Yield(bool) + 0x57)
0x02d258fd: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x988fd (Application::Execute() + 0x2b)
0x041f6600: 0x0006224c: /usr/lib/openoffice.org/program/libsoffice.so + 0x24600 (desktop::Desktop::Main() + 0x1600)
0x02d2a3d3: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x9d3d3
0x02d2a4e9: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x9d4e9 (SVMain() + 0x2d)
0x041efc5e: 0x0006224c: /usr/lib/openoffice.org/program/libsoffice.so + 0x1dc5e (main + 0xe2)
0x00bd0dec: 0x0013ed9c: /lib/libc.so.6 + 0x15dec (__libc_start_main + 0xdc)
0x08048481: 0x00000628: /usr/lib/openoffice.org/program/soffice.bin + 0x481 (main + 0x5d)
...end stackreport details ...
...start sample ldd details ...
        linux-gate.so.1 =>  (0x00696000)
        libuno_sal.so.3 => /usr/lib/openoffice.org/program/libuno_sal.so.3 (0x009d7000)
        libuno_salhelpergcc3.so.3 => /usr/lib/openoffice.org/program/libuno_salhelpergcc3.so.3 (0x00e6f000)
        libstore.so.3 => /usr/lib/openoffice.org/program/libstore.so.3 (0x007f4000)
        libdl.so.2 => /lib/libdl.so.2 (0x00e16000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x005d8000)
        libstlport_gcc.so => /usr/lib/openoffice.org/program/libstlport_gcc.so (0x00110000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00207000)
        libm.so.6 => /lib/libm.so.6 (0x002f2000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x001df000)
        libc.so.6 => /lib/libc.so.6 (0x00319000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x00f56000)
        /lib/ld-linux.so.2 (0x001eb000)
...end sample ldd details ...
---end copy and paste here---
paste the above into your bug report
/usr/lib/openoffice.org/program/crash_report: line 44:  5912 Killed                  zenity --width=800 --height=600 --title="OOo has crashed!: Paste this text into your bugreport" --text-info --filename=$filename

---start copy and paste here---
(I)    x.org loaded video driver of...
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.2-42.el5-i386
(V)    kernel is: Linux 2.6.18-92.el5 #1 SMP Tue Apr 29 13:16:12 EDT 2008 i686 i686 i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.3.0-6.5.4.el5_2-i386
(VII)  depth of root window:    16 planes
(VIII) accessibility is: false
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start stackreport details ...
0x02021338: 0x001cd374: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x21338
0x02021cf7: 0x001cd374: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x21cf7
0x00815420: 0x00000000:  + 0x420 (__kernel_sigreturn + 0x0)
0x02eaf2b5: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x2222b5 (Window::GetParent() const + 0xd)
0x02e93fb6: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x206fb6
0x02ea2c30: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x215c30 (Window::SetParent(Window*) + 0x84)
0x0433ebb2: 0x0027febc: /usr/lib/openoffice.org/program/libfwk680li.so + 0xa1bb2
0x04347789: 0x0027febc: /usr/lib/openoffice.org/program/libfwk680li.so + 0xaa789
0x0434eb15: 0x0027febc: /usr/lib/openoffice.org/program/libfwk680li.so + 0xb1b15
0x042f20b7: 0x0027febc: /usr/lib/openoffice.org/program/libfwk680li.so + 0x550b7
0x042f7915: 0x0027febc: /usr/lib/openoffice.org/program/libfwk680li.so + 0x5a915
0x04317222: 0x0027febc: /usr/lib/openoffice.org/program/libfwk680li.so + 0x7a222
0x043179a1: 0x0027febc: /usr/lib/openoffice.org/program/libfwk680li.so + 0x7a9a1
0x04317bfd: 0x0027febc: /usr/lib/openoffice.org/program/libfwk680li.so + 0x7abfd
0x02d1d5f3: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x905f3
0x02efe095: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x271095
0x02efdfc5: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x270fc5
0x02d1d5f3: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x905f3
0x02eae196: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x221196
0x003be261: 0x00082b5c: /usr/lib/openoffice.org/program/libvclplug_gen680li.so + 0x1f261
0x003e6fc8: 0x00082b5c: /usr/lib/openoffice.org/program/libvclplug_gen680li.so + 0x47fc8 (SalDisplay::DispatchInternalEvent() + 0x78)
0x0021b969: 0x00058ed0: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so + 0x14969
0x0021b998: 0x00058ed0: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so + 0x14998
0x07ac35e1: 0x0009c63c: /lib/libglib-2.0.so.0 + 0x295e1
0x07ac5342: 0x0009c63c: /lib/libglib-2.0.so.0 + 0x2b342 (g_main_context_dispatch + 0x182)
0x07ac831f: 0x0009c63c: /lib/libglib-2.0.so.0 + 0x2e31f
0x07ac8885: 0x0009c63c: /lib/libglib-2.0.so.0 + 0x2e885 (g_main_context_iteration + 0x65)
0x0021b798: 0x00058ed0: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so + 0x14798
0x003ed1f1: 0x00082b5c: /usr/lib/openoffice.org/program/libvclplug_gen680li.so + 0x4e1f1 (X11SalInstance::Yield(bool, bool) + 0x2f)
0x02d2583f: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x9883f (Application::Yield(bool) + 0x57)
0x02d258fd: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x988fd (Application::Execute() + 0x2b)
0x041f6600: 0x0006224c: /usr/lib/openoffice.org/program/libsoffice.so + 0x24600 (desktop::Desktop::Main() + 0x1600)
0x02d2a3d3: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x9d3d3
0x02d2a4e9: 0x003d84fc: /usr/lib/openoffice.org/program/libvcl680li.so + 0x9d4e9 (SVMain() + 0x2d)
0x041efc5e: 0x0006224c: /usr/lib/openoffice.org/program/libsoffice.so + 0x1dc5e (main + 0xe2)
0x00bd0dec: 0x0013ed9c: /lib/libc.so.6 + 0x15dec (__libc_start_main + 0xdc)
0x08048481: 0x00000628: /usr/lib/openoffice.org/program/soffice.bin + 0x481 (main + 0x5d)
...end stackreport details ...
...start sample ldd details ...
        linux-gate.so.1 =>  (0x0045a000)
        libuno_sal.so.3 => /usr/lib/openoffice.org/program/libuno_sal.so.3 (0x00207000)
        libuno_salhelpergcc3.so.3 => /usr/lib/openoffice.org/program/libuno_salhelpergcc3.so.3 (0x004b6000)
        libstore.so.3 => /usr/lib/openoffice.org/program/libstore.so.3 (0x006de000)
        libdl.so.2 => /lib/libdl.so.2 (0x0049f000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x00654000)
        libstlport_gcc.so => /usr/lib/openoffice.org/program/libstlport_gcc.so (0x008bb000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00b5b000)
        libm.so.6 => /lib/libm.so.6 (0x00110000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00557000)
        libc.so.6 => /lib/libc.so.6 (0x0098a000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x00137000)
        /lib/ld-linux.so.2 (0x001eb000)
...end sample ldd details ...
---end copy and paste here---


Version-Release number of selected component (if applicable):
openoffice.org-2.3.0-6.5.4.el5_2

How reproducible:
Everytime

Steps to Reproduce:
1. setup OOO automation testtool
2. run "w_undo.bas"
3. 
  
Actual results:


Expected results:


Additional info:
Comment 1 Caolan McNamara 2008-11-03 12:00:50 EST
Confirmed.

But what we have here is another manifestation the basically-unfixable-problem of having popups open when shutting down OpenOffice.org through the API. Where the popup in question this time is the undo list from the undo icon.

The popups behave unexpectedly for the testtool because the testtool seems to basically expect that OpenOffice.org is being run with the "Generic" UI vclplug, not the GTK one. 

But there is a workaround, and one I recommend for testing using the testtool. To be able to test the undo functionality, and possibly many other tests, we need to run in "gen" mode.

To run OOo in gen mode do...

> export SAL_USE_VCLPLUGIN=gen
> /path/to/testtool.bin

and now OOo will be run in "gen" mode and when you run the undo tests they should complete without crashes.
Comment 2 Yolkfull Chow 2008-11-03 20:22:39 EST
Ok, Caolan, I will verify this workaround, thank you very much for your looking into this. 
Best Regards,

Note You need to log in before you can comment on or make changes to this bug.