Bug 469677 - Failed to load module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0 tsched=1"): initialization failed.
Failed to load module "module-alsa-sink" (argument: "device_id=0 sink_name=a...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-03 08:49 EST by Jan Hutař
Modified: 2008-11-03 12:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-03 12:00:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pulseaudio -vv > ~/Desktop/pulseaudio-vv.log 2>&1 ... and after +-5 seconds Ctrl+C (12.81 KB, application/octet-stream)
2008-11-03 08:52 EST, Jan Hutař
no flags Details

  None (edit)
Description Jan Hutař 2008-11-03 08:49:08 EST
Description of problem:
From update to update I have/do not have sound. I guess this is not correct component, but I have to start somewhere.


Version-Release number of selected component (if applicable):
pulseaudio-0.9.13-4.fc10.x86_64
kernel-2.6.27.4-68.fc10.x86_64
selinux-policy-3.5.13-11.fc10.noarch
hal-0.5.12-9.20081027git.fc10.x86_64
xorg-x11-xinit-1.0.9-4.fc10.x86_64


How reproducible:
depends on an update


Steps to Reproduce:
1. try to use sound


Actual results:
no sound, can not start pulseaudio


Expected results:
sound works


Additional info:
I will attache:
# pulseaudio
# pulseaudio -vv
# ls -al /dev/snd/*
# ck-list-sessions
# lsmod | grep snd

I have `service haldaemon restart` and `chmod o+rwx /dev/snd/*` but it did not helped
Comment 1 Jan Hutař 2008-11-03 08:50:10 EST
$ pulseaudio
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
N: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us privileges. Dropping SUID again.
N: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
W: main.c: High-priority scheduling enabled in configuration but not allowed by policy.
W: core-util.c: setpriority(): Permission denied
E: alsa-util.c: Error opening PCM device hw:0: Device or resource busy
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0 tsched=1"): initialization failed.
Comment 2 Jan Hutař 2008-11-03 08:52:00 EST
Created attachment 322300 [details]
pulseaudio -vv > ~/Desktop/pulseaudio-vv.log 2>&1   ... and after +-5 seconds Ctrl+C
Comment 3 Jan Hutař 2008-11-03 08:52:22 EST
Neither works:

# ls -al /dev/snd/*
crw-rw----+ 1 root root 116, 8 2008-11-03 10:23 /dev/snd/controlC0
crw-rw----+ 1 root root 116, 7 2008-11-03 10:23 /dev/snd/hwC0D0
crw-rw----+ 1 root root 116, 6 2008-11-03 13:30 /dev/snd/pcmC0D0c
crw-rw----+ 1 root root 116, 5 2008-11-03 10:39 /dev/snd/pcmC0D0p
crw-rw----+ 1 root root 116, 4 2008-11-03 10:23 /dev/snd/pcmC0D1p
crw-rw----+ 1 root root 116, 3 2008-11-03 10:23 /dev/snd/seq
crw-rw----+ 1 root root 116, 2 2008-11-03 11:23 /dev/snd/timer
# chmod o+rw /dev/snd/*
# ls -al /dev/snd/*
crw-rw-rw-+ 1 root root 116, 8 2008-11-03 10:23 /dev/snd/controlC0
crw-rw-rw-+ 1 root root 116, 7 2008-11-03 10:23 /dev/snd/hwC0D0
crw-rw-rw-+ 1 root root 116, 6 2008-11-03 13:30 /dev/snd/pcmC0D0c
crw-rw-rw-+ 1 root root 116, 5 2008-11-03 10:39 /dev/snd/pcmC0D0p
crw-rw-rw-+ 1 root root 116, 4 2008-11-03 10:23 /dev/snd/pcmC0D1p
crw-rw-rw-+ 1 root root 116, 3 2008-11-03 10:23 /dev/snd/seq
crw-rw-rw-+ 1 root root 116, 2 2008-11-03 11:23 /dev/snd/timer
Comment 4 Jan Hutař 2008-11-03 08:53:01 EST
# ck-list-sessions
Session4:
	unix-user = '500'
	realname = 'Jan Hutar'
	seat = 'Seat1'
	session-type = ''
	active = TRUE
	x11-display = ':0'
	x11-display-device = '/dev/tty1'
	display-device = ''
	remote-host-name = ''
	is-local = TRUE
	on-since = '2008-11-03T09:39:26.780745Z'
	login-session-id = '3'
Comment 5 Jan Hutař 2008-11-03 08:53:12 EST
# lsmod | grep snd
snd_hda_intel         476320  3 
snd_seq_dummy          11396  0 
snd_seq_oss            39104  0 
snd_seq_midi_event     14848  1 snd_seq_oss
snd_seq                61968  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         15380  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            52224  2 
snd_mixer_oss          23168  1 snd_pcm_oss
snd_pcm                85512  2 snd_hda_intel,snd_pcm_oss
snd_timer              30352  2 snd_seq,snd_pcm
snd_page_alloc         16656  2 snd_hda_intel,snd_pcm
snd_hwdep              16392  1 snd_hda_intel
snd                    68984  12 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore              14992  3 snd
Comment 6 Jan Hutař 2008-11-03 08:54:21 EST
# ps ax | grep ' ck-'
 6897 pts/2    S+     0:00 grep  ck-
# ps ax | grep 'hal'
 6573 ?        Ss     0:00 hald
 6574 ?        S      0:00 hald-runner
 6666 ?        S      0:00 /usr/libexec/hald-addon-generic-backlight
 6667 ?        S      0:00 /usr/libexec/hald-addon-generic-backlight
 6706 ?        S      0:00 hald-addon-input: Listening on /dev/input/event1 /dev/input/event0 /dev/input/event9 /dev/input/event2 /dev/input/event5 /dev/input/event10 /dev/input/event4 /dev/input/event12
 6714 ?        S      0:00 hald-addon-storage: polling /dev/sr0 (every 2 sec)
 6717 ?        S      0:00 /usr/libexec/hald-addon-cpufreq
 6718 ?        S      0:00 hald-addon-acpi: listening on acpi kernel interface /proc/acpi/event
 6891 ?        S      0:00 /usr/libexec/gvfs-hal-volume-monitor
Comment 7 Jan Hutař 2008-11-03 08:58:47 EST
When I run ck-xinit-session by hand (I do not know if it should be running), I get these 2 AVCs (but running in permissive mode do not help):

node=pok.englab.brq.redhat.com type=AVC msg=audit(1225720537.821:234): avc: denied { getattr } for pid=6943 comm="ck-get-x11-serv" path="/var/run/gdm/auth-for-pok-8oF9TH/database" dev=dm-0 ino=490624 scontext=system_u:system_r:consolekit_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_var_run_t:s0 tclass=file node=pok.englab.brq.redhat.com type=SYSCALL msg=audit(1225720537.821:234): arch=c000003e syscall=5 success=yes exit=0 a0=4 a1=7fffe12cca20 a2=7fffe12cca20 a3=1221c10 items=0 ppid=6942 pid=6943 auid=4294967295 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=4294967295 comm="ck-get-x11-serv" exe="/usr/libexec/ck-get-x11-server-pid" subj=system_u:system_r:consolekit_t:s0-s0:c0.c1023 key=(null) 

node=pok.englab.brq.redhat.com type=AVC msg=audit(1225720537.818:233): avc: denied { search } for pid=6943 comm="ck-get-x11-serv" name="gdm" dev=dm-0 ino=491584 scontext=system_u:system_r:consolekit_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_var_run_t:s0 tclass=dir node=pok.englab.brq.redhat.com type=AVC msg=audit(1225720537.818:233): avc: denied { read } for pid=6943 comm="ck-get-x11-serv" name="database" dev=dm-0 ino=490624 scontext=system_u:system_r:consolekit_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_var_run_t:s0 tclass=file node=pok.englab.brq.redhat.com type=SYSCALL msg=audit(1225720537.818:233): arch=c000003e syscall=21 success=yes exit=0 a0=7fffe12cef9c a1=4 a2=0 a3=7fffe12cc930 items=0 ppid=6942 pid=6943 auid=4294967295 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=4294967295 comm="ck-get-x11-serv" exe="/usr/libexec/ck-get-x11-server-pid" subj=system_u:system_r:consolekit_t:s0-s0:c0.c1023 key=(null)
Comment 8 Lennart Poettering 2008-11-03 12:00:35 EST
"Error opening PCM device hw:0: Device or resource busy" tells you that some other application is blocking the audio device. Use "fuser -v /dev/snd/* /dev/dsp*" to find out which one.

Note You need to log in before you can comment on or make changes to this bug.