Bug 469678 - preupgrade doesn't know about new metadata filename format
preupgrade doesn't know about new metadata filename format
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-03 08:57 EST by Bradley
Modified: 2014-01-21 18:06 EST (History)
1 user (show)

See Also:
Fixed In Version: preupgrade-1.0.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 10:44:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bradley 2008-11-03 08:57:19 EST
Description of problem:

Severity: extremely-trivial

when upgrading from F9 to rawhide using preupgrade, some warning messages are displayed to stdout:

unknown metadata being downloaded: fa27d38a40a11264202445b163e05d1bf2d1574c-primary.sqlite.bz2
No Presto metadata available for preupgrade
unknown metadata being downloaded: 63797887e33f9e3df1456c1266efa593faca8d73-comps-rawhide.xml
Setting up and reading Presto delta metadata
No Presto metadata available for preupgrade
Setting up and reading Presto delta metadata
No Presto metadata available for preupgrade
unknown metadata being downloaded: fd15a8ee67f0503eccf98eda356afe9f02048acd-comps-rawhide.xml.gz
unknown metadata being downloaded: d238f4f4e50a4984ec2c7b2158ca8a52f03c0011-filelists.sqlite.bz2

Version-Release number of selected component (if applicable):

preupgrade-0.9.8-2.fc9.noarch

How reproducible:

Always

Steps to Reproduce:
1. Try to use preupgrade to upgrade F9 to rawhide
 
Actual results:

Warning messages displayed on stdout

Expected results:

No warning messages displayed

Additional info:

Looks like it doesn't know about the new metadata filename format being used by createrepo.

Also, MetaDataMap has an entry for Fedora-9-comps.xml{,.gz} but not comps-rawhide (or, presumably, Fedora-10-comps)
Comment 1 Will Woods 2008-11-03 11:56:09 EST
> Severity: extremely-trivial
Ha!

Luckily, the fix was near-trivial as well - we now do pattern matching against the filenames. So "*comps*.xml*" is treated as "group metadata". 

Fixed in bzr rev. 225. This will be in the next preupgrade build after 0.9.8-2.
Comment 2 Bug Zapper 2008-11-25 23:41:14 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.