Bug 469679 - snmp-perl and net-snmp-devel does not require the right packages.
snmp-perl and net-snmp-devel does not require the right packages.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp (Show other bugs)
4.7
All Linux
low Severity low
: rc
: ---
Assigned To: Jan Safranek
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-03 09:00 EST by Jan Safranek
Modified: 2009-05-18 16:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
* the net-snmp-perl and net-snmp-devel subpackages only required matching versions of net-snmp and net-snmp-lib, not matching releases. This meant that an update of either subpackage would not result in updates to the current releases of net-snmp (to get correct MIB files) or net-snmp-libs (to get correct libraries). These subpackages now require the same release for net-snmp-perl and net-snmp-devel, ensuring that the MIB files and libraries are brought up to date.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:19:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Safranek 2008-11-03 09:00:53 EST
Description of problem:
net-snmp-perl and net-snmp-devel requires only %{name} = %{version}. This should be %{name} = %{version}-%{release} to ensure that update of -perl and/or -devel subpackage pull updated versions of net-snmp (to get correct MIB files) and net-snmp-libs (to get correct libraries).

Version-Release number of selected component (if applicable):
net-snmp-5.1.2-15
Comment 3 Ruediger Landmann 2009-01-22 01:27:39 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
* the net-snmp-perl and net-snmp-devel subpackages only required matching versions of net-snmp and net-snmp-lib, not matching releases. This meant that an update of either subpackage would not result in updates to the current releases of net-snmp (to get correct MIB files) or net-snmp-libs (to get correct libraries). These subpackages now require the same release for net-snmp-perl and net-snmp-devel, ensuring that the MIB files and libraries are brought up to date.
Comment 6 errata-xmlrpc 2009-05-18 16:19:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0984.html

Note You need to log in before you can comment on or make changes to this bug.