Bug 469683 - Intel WiFi 4965 loses network connection after some time running
Intel WiFi 4965 loses network connection after some time running
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-03 09:28 EST by Horst H. von Brand
Modified: 2008-12-09 11:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 11:23:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2008-11-03 09:28:06 EST
Description of problem:
After a while (a few hours, normally) NetworkManager tells me there is no WiFI network. The NM applet shows the networks just fine, the signal is strong enough, but it is unable to get it.

This has happened noticeably with 2.6.27-series kernels, a bit less often lately.

I tried by hand:

  iwconfig wlan0 essid xxyyzz
  dhclient wlan0

and get no problem associating, but no answer from dhclient. Removing and reloading the modules, or even rebooting the machine does have no effect. After a random time sometimes the network comes back. Meanwhile, others can use the WiFi network just fine.

I'm using a Linksys WRT54g, model 2.2 with latest Linksys firmware

Version-Release number of selected component (if applicable):
kernel-2.6.27.4-68.fc10.x86_64
iwl4965-firmware-228.57.2.21-3.noarch
NetworkManager-0.7.0-0.11.svn4229.fc10.x86_64

How reproducible:
Almost every time, after a number of hours using the network (some 2 to 8 hours lately)

Steps to Reproduce:
1. Connect to WiFi
2.
3.
  
Actual results:
Lost network after a while

Expected results:
Not losing the network

Additional info:
Comment 1 Horst H. von Brand 2008-11-23 21:52:17 EST
Now (2.6.27.5-117.fc10.x86_64) at least I can get the network going again via NetworkManager, no need to reboot anymore.
Comment 2 John W. Linville 2008-11-24 12:43:05 EST
Does that address the issue?  Or is this still a problem?
Comment 3 Bug Zapper 2008-11-25 23:41:28 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Horst H. von Brand 2008-11-27 11:38:42 EST
Re #2: It isn't so nice that the network goes down at random, now most of the time it comes up on its own again and only sometimes do I have to restart it by hand via NM. It is bearable (for me; but then I've got a reasonably tough hide ;-)

Re #3: Dunno if this is the right thing to do, I'm still rawhide.
Comment 5 Horst H. von Brand 2008-12-08 20:44:02 EST
Still the same, but now NM seems to get the network again automatically almost all the time.

Culprit could be a suspected flaky Linksys router here...
Comment 6 John W. Linville 2008-12-09 11:23:01 EST
Connections will drop from time to time, for any number of reasons.  If things are recovering quickly then I'm not sure what else we can do.

Note You need to log in before you can comment on or make changes to this bug.