Bug 469685 - Potential data loss when zipping large amounts of data
Potential data loss when zipping large amounts of data
Product: Fedora
Classification: Fedora
Component: zip (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-11-03 09:44 EST by Christopher Beland
Modified: 2012-07-25 06:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-07-14 13:24:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2008-11-03 09:44:05 EST
I ran "zip -ry9" on a directory containing 8.5GB worth of data.  The archiving process completed without any obvious errors.  The resulting archive was 5,170,954,862 bytes. However, when I ran "unzip -l" on it, I got the following error:

error:  Zip file too big (greater than 4294959102 bytes)
Archive:  fs-live-last-fedora9.zip
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of fs-live-last-fedora9.zip or
        fs-live-last-fedora9.zip.zip, and cannot find fs-live-last-fedora9.zip.ZIP, period.

If I had not retained the original directory, all of my data would have been lost to me.

At the very least, the archiving process should terminate with an error if any data limits (size of individual files, number of files, overall size of archive) are breached.  At best, zip and unzip would simply support files up to the limits of the underlying file system. 

I am running zip-2.31-6.fc9.i386 and unzip-5.52-9.fc9.i386. Reportedly large(r) file support is available in Zip 3.0 and Unzip 6.0.  As reported in Bug 457305, Zip 3.0 has already been released. Unzip 6.0 has been in beta for the past 3 years, but the "d" release is reportedly safe and available at:

Comment 1 Bug Zapper 2009-06-09 23:09:56 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 2 Ivana Varekova 2009-06-10 04:53:19 EDT
I just try to reproduce this bug - but I was unsuccesful:
 zip -ry9 big_file
does not create the archive and return error :(
I try several files.
Comment 3 Bug Zapper 2009-07-14 13:24:33 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.