Bug 4697 - Bug in ETA-DMA module for 2.2.5-15SMP and 2.2.5.22SMP Kernels
Bug in ETA-DMA module for 2.2.5-15SMP and 2.2.5.22SMP Kernels
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-24 22:57 EDT by bobl
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bobl 1999-08-24 22:57:59 EDT
I am not sure the 'kernel' is the correct component and I
applogize for any error in this report as I am new to Linux
and this bug system.

I was directed here from the Red Hat support site and a
transcript of that follows:
-----------------------------------------------------------
Recently you requested personal assistance from our on-line
support center. Below is a summary of your request and our
response.

If we do not hear from you within 48 hours we will assume
your
issue has been resolved.

Thank you for allowing us to be of service to you.
------------------------------------------------------------
-

SUMMARY:  SMP new 2.2.5-22SMP kernel
SUGGESTED SOLUTION:
At 8/24/99 4:51 PM we wrote -

Hi!
We have had some problems with our ticket system, and have
found that some of the trouble tickets have not been
responded to.  We apologize sincerely and hope that this
does not happen again.  If you are still having the problem
you reported in this incident, please respond and we will
help you as best we can.
Looking forward to your response,

- Red Hat Support




Hi,

Not sure if you have received a responce or not on this
ticket but from what I can currently see; what you'll need
to do is to submit a bug at
http://developer.redhat.com/bugzilla and then developement
will see if what can be done to resolve this.

Sorry I can't offer more but it appears to me that you have
located an SMP bug with the driver and the bugs are tracked
through bugzilla!

-Rob

INCIDENT DETAILS:
         Reference #:  990806-0000
             Product:  Red Hat Linux/Intel 6.0
            Category:  Installation
        Contact info:  bobl@halcyon.com
        Time created:  8/6/99 0:07 AM
        Last updated:  8/24/99 5:13 PM
        Elapsed time:  18 Days, 17 Hours
              Status:  Unresolved
        Registration:  1206d548a713710f

DESCRIPTION:
This references incident # 990731-0001.

I downloaded the latest kernel
"kernel-smp-2.2.5-22.i686.rpm" and installed via gno-rpm.
All went well and the new kernel showed up on my lilo boot
list but when I booted the new kernel the boot log showed no
scsi hosts as before.  The new wrinkel is that there was
no indication it was loading an ETA-DMA module to talk to my
DPT card ( single scsi disk, no raid hardware installed).
Right after loading the md driver the boot log indicated it
was measuriong raid5 checksumming speed.  after a couple of
lines relative to that the lines read:
scsi : 0 hosts
scsi : detected total

a couple of lines later the familiar kernel panic line and
the system stopped ( not locked as I can ctrl-atl-del to
shut down).

As I am relatively new to Linux, I may have missed some
important point.  Your earlier suggestion was that I
download the latest kernel and boot images.  I did not
download a boot image as I'm not sure what that is and I
only saw one item on the FTP site (with the kernel I
downloaded) that had boot in it and that was another
kernel.

My current guess is that I somewhow have to inform the new
kernel about the ETA-DMA module but I don't know how to do
that.
thanks for the help...

PS: I have previously installed RH5.1 and got it up and
running with my network card and ADSL line without any
problem. I since wiped that off my disk infor a clean
install of RH6.0.
At 8/7/99 1:29 AM you wrote - I discovered in the RH
installation manual, nder kernel discussions, that I must
build a new initrd for the new kernel to add modules such as
a scsi interface driver.  I successfully completed this
build, as eveidence of no error messages and I saw the file
appear in the /boot directory.  The result is still the
same... the boot loader did not indicate the load of the
eta-dma module.

thanks..  Bob L.
At 8/15/99 5:46 PM you wrote - I have finally
resolved the issue reported 8/7/99 of the new 2.2.5-22smp
kernel not loading the eta-dma module.  I discovered that
when I add a kernel to lilo (using the linux config tool)
that I also have to specify the (optional)
initrd-newkernel.img file location (usually /boot).

Now when I boot the 2.2.5-22smp kernel it does load the
eta-dma module after checking for raid devices.
Unfortunately the results are the same.  After loading the
eta-dma module the first message says 'tryting to clear
possible blink state" then something like "HBA adaptor at
0xfcb0 not responding to inquiry, sorry" My next step is to
get a different scsi adaptor from work and see if the smp
problem is with this particular card driver (DPT PM2144UW;
ETA-DMA) or if the problem is perhaps in the kernel. As I
already indicated, I have run NT4.0 and NT Warp server in
SMP mode on this system so I am confident the hardware is
OK.

At 8/17/99 0:57 AM you wrote -
As I entered on 8/15/99, I have changed my SCSI card FROM
the DPT PM2144UW  to an Adaptec AHA-2940 Ultra Wide
controller.  I also reloaded Linux 6.0 from the original CD
ROM and successfully booted into SMP mode.  This seems to
indicate a problem with the driver (ETA-DMA) for the DPT
SCSI controller in SMP mode as it seemed to work just fine
in uni-processor mode.  If you would like additional
information on the ETA-DMA problem I am willing to
reconfigure my system to assist in that effort.  AS I have
borrowed the Adaptec card, I will have to eventually return
to the DPT configuration unless I buy a new controller card
(not likely).

Please let me know how I can be of further assistance and I
await a fix for this problem.
8/16/99 @ 10:02PM



If your issue remains unresolved, please update your
incident at
http://www.redhat.com/cgi-bin/support?r&11-990806-0000&100-9
33912431


------------------------------------------------------------
---

Note You need to log in before you can comment on or make changes to this bug.