This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 469702 - faillog -p takes forever if /var/log/faillog has gone huge sparse.
faillog -p takes forever if /var/log/faillog has gone huge sparse.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: shadow-utils (Show other bugs)
4.7
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Peter Vrabec
BaseOS QE
: ZStream
Depends On:
Blocks: 485811 517816 577201
  Show dependency treegraph
 
Reported: 2008-11-03 11:06 EST by Issue Tracker
Modified: 2012-06-14 16:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 517816 (view as bug list)
Environment:
Last Closed: 2012-06-14 16:47:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch reworking entry read/writes and avoid filling in holes. also optimal print (6.55 KB, patch)
2008-11-03 11:15 EST, Martin Poole
no flags Details | Diff
patch backported from RHEL5 (6.48 KB, patch)
2010-03-26 06:57 EDT, Peter Vrabec
no flags Details | Diff

  None (edit)
Description Issue Tracker 2008-11-03 11:06:08 EST
Escalated to Bugzilla from IssueTracker
Comment 1 Martin Poole 2008-11-03 11:13:31 EST
There is a bug with the print code in that is simply reads the whole file sequentially to meet the man page of printing in UID order. Since the output does not actually include the UID it is a little redundant stating or assuming UID order which therefore gives an optimal way of reworking the code.
Comment 2 Martin Poole 2008-11-03 11:15:23 EST
Created attachment 322334 [details]
patch reworking entry read/writes and avoid filling in holes. also optimal print
Comment 8 Peter Vrabec 2010-03-26 06:57:24 EDT
Created attachment 402793 [details]
patch backported from RHEL5

Note You need to log in before you can comment on or make changes to this bug.