Bug 469718 - Description of problem: The symbolic link /usr/lib/libltdl.so to /usr/lib/libltdl.so.3 is not present
Description of problem: The symbolic link /usr/lib/libltdl.so to /usr/lib/lib...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libtool (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-03 12:49 EST by Bruce Orchard
Modified: 2008-11-03 13:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-03 13:20:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Orchard 2008-11-03 12:49:09 EST
Description of problem:
The symbolic link /usr/lib/libltdl.so to /usr/lib/libltdl.so.3 is not present

Version-Release number of selected component (if applicable):


How reproducible:
every time


Steps to Reproduce:
1.  ls /usr/lib/libltdl*
2.
3.
  
Actual results:
lrwxrwxrwx 1 root root    16 2008-10-22 11:37 /usr/lib/libltdl.so.3 -> libltdl.so.3.1.5
-rwxr-xr-x 1 root root 28044 2008-01-30 14:26 /usr/lib/libltdl.so.3.1.5


Expected results:

lrwxrwxrwx 1 root root    12 2008-10-28 12:28 /usr/lib/libltdl.so -> libltdl.so.3
lrwxrwxrwx 1 root root    16 2008-10-22 11:37 /usr/lib/libltdl.so.3 -> libltdl.so.3.1.5
-rwxr-xr-x 1 root root 28044 2008-01-30 14:26 /us
Additional info:

I ran into this while I was building php.  I got this message:

/usr/bin/ld: cannot find -lltdl

When I created the link for /usr/lib/libltdl.so, the error went away and php linked OK.
Comment 1 Karsten Hopp 2008-11-03 13:20:14 EST
This is not a bug, /usr/lib/libltdl.so is provided by libtool-ltdl-devel as it is only needed during compilation.

Note You need to log in before you can comment on or make changes to this bug.