Bug 46976 - Illegal instruction while compiling kernel!
Summary: Illegal instruction while compiling kernel!
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-02 14:50 UTC by Dick Loser
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-02 17:55:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dick Loser 2001-07-02 14:50:20 UTC
Description of Problem:

When tying to compile kernel (2.4.5) gcc gives internal error due to a illegal instruction...



How Reproducible:

make *



Steps to Reproduce:

1. cd /usr/src/linux

2. make <whatever>

3. 



Actual Results:

None



Expected Results:

Kernel image + modules



Additional Information:

Redhat 7.1

Processor: Cyrix 6x86MX

Standard kernel source (not from RPM)

Comment 1 Jakub Jelinek 2001-07-02 14:53:25 UTC
Is it reproduceable and always on exactly the same file with exactly the
same message?

Comment 2 Dick Loser 2001-07-02 17:49:40 UTC
No... the place is sometimes different, but most of the time with the first file that gets passed through gcc.
It is always the same error, however.

Comment 3 Dick Loser 2001-07-02 17:55:16 UTC
No... the place is sometimes different, but most of the time with the first file that gets passed through gcc.
It is always the same error, however.

Comment 4 Jakub Jelinek 2001-07-25 14:58:01 UTC
Then you should check your hardware (RAM, CPU) because these are typical
symptoms of defective hardware.


Note You need to log in before you can comment on or make changes to this bug.