Bug 469803 - Backlight control does not work on MacBook Pro 3.1
Backlight control does not work on MacBook Pro 3.1
Status: CLOSED DUPLICATE of bug 462409
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-03 23:13 EST by Garrett Holmstrom
Modified: 2013-01-10 02:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-11 12:38:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Garrett Holmstrom 2008-11-03 23:13:30 EST
Description of problem:
The Linux module mbp_nvidia_bl needs to be autoloaded to provide the backlight device for the NVidia card in 3.1 and 4.1.  This driver is included with the standard kernel package; it just needs loading.

Version-Release number of selected component (if applicable):
hal-0.5.12-9.20081027git.fc10.i386
kernel-PAE-2.6.27.4-68.fc10.i686

How reproducible:
Attempt to use display backlight controls on a MacBook Pro 3.1 or 4.1.

Steps to Reproduce:
1.  Log into GNOME on such a MacBook Pro.
2.  Use F1 and F2 to attempt to change the backlight brightness.

Actual results:
Using the keyboard's backlight keys causes the usual brightness graphic to show up, but no bar fills it and the display brightness does not change.

Expected results:
Using the keyboard's backlight keys causes the usual brightness graphic to show up, with a bar indicating the current brightness level and the display brightness to change.

Additional info:
Running ``modprobe mbp_nvidia_bl'' and restarting X corrects this problem.

Pommed works, but the driver it uses causes wireless provided by ath9k to stop working, so installing pommed like recommended in bug 331161 is not an acceptable fix.
Comment 1 Richard Hughes 2008-11-04 07:59:19 EST
HAL doesn't autoload modules. The kernel needs to autoload this before HAL will work correctly.
Comment 2 Stewart Adam 2008-11-05 08:12:15 EST
I've reported the kernel autoload problem in bug 462409.
Comment 3 Matthew Garrett 2008-11-11 12:38:26 EST

*** This bug has been marked as a duplicate of bug 462409 ***

Note You need to log in before you can comment on or make changes to this bug.