This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 469805 - RFE: apt-get support for repomd metadata with checksums in name
RFE: apt-get support for repomd metadata with checksums in name
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: apt (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 00:10 EST by Eli Wapniarski
Modified: 2009-01-14 22:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 22:11:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eli Wapniarski 2008-11-04 00:10:17 EST
As you are probably aware, rpmfusion came online. After configuring apt-get to get metadata and packages from rpmfusion and running apt-get update I get the output included below.

I have filed a bug report at rpmfusion and it was suggested that there is the possibility that apt-get does not like the metadata format that rpmfusion is using. The bug report at rpmfusion can be found at

https://bugzilla.rpmfusion.org/show_bug.cgi?id=112

This one is kind of urgent, as I can't get apt-get to get updates from freshrpms and livna as they have been fused into rpmfusion and has taken over for both repositories.

The outut that I'm getting from apt-get is

Reading Package Lists... Error!                                                 
E: Error occured while processing iscsitarget (CollectFileProvides)             
E: Problem with MergeFileProvides
/var/lib/apt/lists/download1.rpmfusion.org_free_fedora_updates_9_x86%5f64_repodata_2398a67a6efb5f7fec62fa7f3a2c9b372fc78dbf-primary.sqlite
E: The package lists or status file could not be parsed or opened.
Comment 1 Panu Matilainen 2008-11-09 06:58:14 EST
Yup, the new checksum-in-filenames metadata breaks apt pretty badly. I'll see what I can do about it. Not only rpmfusion is affected but all of F10 too, but then apt is completely broken in F10 anyway...
Comment 2 Eli Wapniarski 2008-11-09 12:01:36 EST
Just great....

Thanks for the update.... I guess that I will leave this in you're most capable hands.

Despite all the advances in yum. Yum still doesn't beat apt for ease and flexibility and accuracy when it comes to prioritization.
Comment 3 Panu Matilainen 2008-12-16 10:14:44 EST
This should be fixed upstream now...
Comment 4 Eli Wapniarski 2008-12-16 12:12:17 EST
Will try this soonest.
Comment 5 Panu Matilainen 2008-12-22 17:51:04 EST
Seems like the mass "opening" of Fedora CVS ACL's actually removed my permissions to touch apt at all, until that gets corrected here's an src.rpm of upstream snapshot that should make apt reasonably functional again:
http://laiskiainen.org/tmp/apt-0.5.15lorg3.95-0.git416.1.fc11.src.rpm
Comment 6 Eli Wapniarski 2008-12-23 00:09:57 EST
Sorry, but I'm getting the following when trying to rebuild

In file included from /usr/include/rpm/rpmmacro.h:12,
                 from ../include/rpmhandler.h:25,
                 from ../include/rpmindexfile.h:22,
                 from ../include/rpmsystem.h:16,
                 from init.cc:112:
/usr/include/rpm/rpmfileutil.h:41: error: expected ',' or '...' before 'template'
make[1]: *** [init.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/root/rpmbuild/BUILD/apt-0.5.15lorg3.95.git416/apt-pkg'
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.4kVrKE (%build)
Comment 7 Panu Matilainen 2008-12-23 01:29:39 EST
Oh, that. I'd already forgotten... you'll want to pull rpm-4.6.0-0.rc3.1 from updates-testing.
Comment 8 Eli Wapniarski 2008-12-23 03:36:27 EST
OK Panu... This bug seems to be fixed.

However, after moving to Fedora 10. It has come to my very sad attention that the organization of the various repositories and packages has left apt-get for rpms far behind.

The situation that is forcing my hand is the current instability regarding KDE, the superiority of packaging of OpenOffice by OpenOffice and the heavy use of mirror sites by Fedora, and rpmfusion and others. Yum did manage to successfully update 3 computers to Fedora 9 to 10 and 1 from 8 to 9.

Unfortunately apt-get / synaptice combinations, is still, in my opinion, a much more nimble package manager than yum -- once configured correctly. However, configuring it has become cumbersome due the lack of ability to use wild cards in apt.conf or preferences.

Another feature that is clearly lacking is an equivalent to yum-complete-transaction.

If apt-get would make better use of mirrors, make more extensive use of wild cards, and get a yum-complete-transaction feature I would very very happily return.

Please please please... I always feel like I'm waiting for the dentists drill to start everytime I run yum update.

Thank you for your very hard and excellent work.

Eli
Comment 9 Fedora Update System 2009-01-07 03:05:22 EST
apt-0.5.15lorg3.95-0.git416.3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/apt-0.5.15lorg3.95-0.git416.3.fc10
Comment 10 Fedora Update System 2009-01-07 16:52:36 EST
apt-0.5.15lorg3.95-0.git416.3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update apt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0304
Comment 11 Fedora Update System 2009-01-14 22:10:57 EST
apt-0.5.15lorg3.95-0.git416.3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.