Bug 469822 - Rdma plugin failure
Rdma plugin failure
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.0
All Linux
high Severity medium
: 1.1
: ---
Assigned To: Andrew Stitcher
Kim van der Riet
:
: 471228 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 04:58 EST by Gordon Sim
Modified: 2011-08-12 12:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 10:36:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache Bugzilla 1438 None None None Never

  None (edit)
Description Gordon Sim 2008-11-04 04:58:04 EST
Reported via IRC for qpidd-0.3.709187-1.el5/ Qpidd exits with segfault after printing error "CMA: unable to open /dev/infiniband/rdma_cm". Can't start the daemon as a service either, which is very likely the same thing.

We need to handle incorrect or unavailable rdma configuration more gracefully, particularly if the module is getting installed by default.
Comment 1 Andrew Stitcher 2008-11-07 11:22:29 EST
Fixed in qpid svn r712182
Comment 2 Andrew Stitcher 2008-11-12 10:46:21 EST
*** Bug 471228 has been marked as a duplicate of this bug. ***
Comment 4 Frantisek Reznicek 2008-11-21 03:41:16 EST
Validated that issue has been fixed on RHEL5.2 x86_64 on packages:
qpidd-0.3.709187-1.el5, qpidd-rdma-0.3.709187-1.el5, rhm-0.2.2694-1.el5
vs.
qpidd-0.3.714072-1.el5, qpidd-rdma-0.3.714072-1.el5, rhm-0.3.2804-1.el5
->VERIFIED
Comment 6 errata-xmlrpc 2009-02-04 10:36:00 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0035.html

Note You need to log in before you can comment on or make changes to this bug.