This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 469837 - RFE: Support usb tablet in graphical setup via qemu
RFE: Support usb tablet in graphical setup via qemu
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 06:10 EST by Till Maas
Modified: 2009-02-13 09:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 22:07:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from F10 Preview release using qemu-kvm with usb tablet (21.63 KB, text/plain)
2008-11-05 04:57 EST, Till Maas
no flags Details
lshal output from F10 guest (46.69 KB, text/plain)
2008-12-30 18:40 EST, Martin Ebourne
no flags Details

  None (edit)
Description Till Maas 2008-11-04 06:10:09 EST
Description of problem:
If qemu is started with -usbdevice tablet, it supports activating the window without using CTRL-ALT. This works in the text parts of the installer but stops working as soon as the graphical installer is started.

Version-Release number of selected component (if applicable):
11.4.1.50 from Snap3 i386 DVD
Comment 1 Till Maas 2008-11-04 10:47:43 EST
Additional Information:

F9 X11 works as expected, but it does also not work for the F10 Prerelease i686 Live image and probably did not work for the previous Live images. Therfore support in X11 is there already sometimes.
Comment 2 Matěj Cepl 2008-11-04 19:02:03 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Till Maas 2008-11-05 04:03:36 EST
I booted anaconda from the Preview release, switched to the second virtual console (ctrl-alt-f2) and noticed that the directories /etc/X11 and /var/log do not exist. Also a find / xorg.conf and find / Xorg.0.log did not print any results.

I also noticed that if the qemu window has focus, keyboard input is already redirected to the graphical anaconda, but not the movement from my mouse.
Comment 4 Till Maas 2008-11-05 04:57:01 EST
Created attachment 322558 [details]
Xorg.0.log from F10 Preview release using qemu-kvm with usb tablet

After the installation of F10 finished, there is still no /etc/X11/xorg.conf in the installed FS, but a /var/log/Xorg.0.log appeared, which I attach here. Also here it is now also only working for the keyboard, but not for the pointer in X11.  After I ran Xorg -configure and copied the xorg.conf to /etc/X11/xorg.conf, it did still not work. And when I ran the Xorg -configure without having the qemu window grabbed the mouse, the mouse did not work at all after I started the X server with the new config file.
Comment 5 Martin Ebourne 2008-12-30 18:39:11 EST
This is not a request for enhancement, it is a regression from F9 to F10. The QEMU tablet emulation worked fine on previous fedora releases, but is now broken. This is almost certainly due to the new xorg hotplug/hal integration.

lshal output attached which shows the QEMU USB Tablet device is missing the input.x11_driver key. This should get there by an fdi file in /usr/share/hal/fdi/policy matching the device and setting the driver. I'm not sure what driver it needs though, maybe it's wacom compatible? eg.
  /usr/share/hal/fdi/policy/20thirdparty/10-linuxwacom.fdi
Comment 6 Martin Ebourne 2008-12-30 18:40:48 EST
Created attachment 327982 [details]
lshal output from F10 guest
Comment 7 Peter Hutterer 2009-01-05 21:05:13 EST
Copy the input.mouse section in /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi into a new section with input.capabilities = input.joystick. This is what the tablet pretends to be, and it should make the evdev driver pick it up. Does that work then?
Comment 8 Till Maas 2009-01-06 02:46:32 EST
(In reply to comment #7)
> Copy the input.mouse section in
> /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi into a new section with
> input.capabilities = input.joystick. This is what the tablet pretends to be,
> and it should make the evdev driver pick it up. Does that work then?

Thanks, after this change and running "service haldaemon restart" it works here with the F10 live image. \o/
Comment 9 Peter Hutterer 2009-01-06 18:42:53 EST
Are you able to give the updated HAL package a test?
Basically the check for tablets was broken, leading to tablets being reported as joysticks (as in your case). This should be fixed with the package below:

https://admin.fedoraproject.org/updates/F10/FEDORA-2008-11732

Note that if you install this package, you don't need the input.joystick section anymore.
Comment 10 Martin Ebourne 2009-01-06 19:03:09 EST
I didn't get as far as testing the fdi change but just tested the hal package under virt-manager and the tablet device is fixed, now working as expected. I added karma in bodhi (or at least I tried to, seems a bit broken though).

yum --enablerepo=updates-testing install hal
Comment 11 Till Maas 2009-01-08 06:42:58 EST
The updated HAL packages fixes this bug for me, too. This bug should be added to the fixed bugs section of the update.
Comment 12 Fedora Update System 2009-01-14 22:07:36 EST
hal-0.5.12-14.20081027git.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.