Bug 469870 - Ktorrent crash when opening a torrent file in the list of firefox downloader
Ktorrent crash when opening a torrent file in the list of firefox downloader
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ktorrent (Show other bugs)
10
i386 Linux
high Severity high
: ---
: ---
Assigned To: Roland Wolters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 10:28 EST by Yolkfull Chow
Modified: 2008-12-06 23:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 20:24:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yolkfull Chow 2008-11-04 10:28:50 EST
Description of problem:
When double click on the torrent file downloaded in the list of firefox's downloader, ktorrent crash with following messages:
---------
This backtrace appears to be of no use.
This is probably because your packages are built in a way which prevents creation of proper backtraces, or the stack frame was seriously corrupted in the crash.

(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
....
(no debugging symbols found)
0x00110416 in __kernel_vsyscall ()
[Current thread is 0 (process 4184)]

---------
I will install the debuginfo package and attach the backtrace tomorrow.

Version-Release number of selected component (if applicable):
ktorrent-3.1.4-1.fc10.i386

How reproducible:
not always

Steps to Reproduce:
1. download a torrent file using firefox
2. double click on the torrent file in the list of firefox downloader
3. crash...
  
Actual results:


Expected results:


Additional info:
Comment 1 Rex Dieter 2008-11-04 10:41:49 EST
Can you provide a .torrent to reproduce this?
Either way, it would probably be a good idea to report this upstream @ bugs.kde.org.
Comment 2 Jacek Piskozub 2008-11-16 12:56:45 EST
This is what the newest news release dated November 15 on the ktorrent website says:

"Another bugfix release in the 3.1 series is out. This release fixes several minor issues and one nasty crash caused by a Qt bug. People experiencing sporadic crashes should upgrade to 3.1.5."

It may explain this bug.

BTW, I believe we should take that version as soon as possible.
Comment 3 Rex Dieter 2008-11-16 13:57:32 EST
Agreed, will do (in the meantime, need to find a better way of being informed of new releases).
Comment 4 Fedora Update System 2008-11-17 15:29:46 EST
ktorrent-3.1.5-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/ktorrent-3.1.5-1.fc9
Comment 5 Fedora Update System 2008-11-17 15:30:04 EST
ktorrent-3.1.5-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/ktorrent-3.1.5-1.fc10
Comment 6 Fedora Update System 2008-11-19 09:52:40 EST
ktorrent-3.1.5-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ktorrent'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9750
Comment 7 Fedora Update System 2008-11-22 11:46:49 EST
ktorrent-3.1.5-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ktorrent'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/f10/FEDORA-2008-9931
Comment 8 Jacek Piskozub 2008-11-24 10:28:00 EST
In comment #9, there is an error in the you command.

It should be:
su -c 'yum --enablerepo=updates-testing-newkey update ktorrent'
(the "-newkey" was missing)

I would have waited till doomsday or the f10 upgrade to get the package (whichever comes first), had I not double checked it.
Comment 9 Jacek Piskozub 2008-11-24 10:30:49 EST
Correction: I meant "comment #6" and the "yum command", not "comment #9" and "you command".

I should type a little slower, next time.
Comment 10 Bug Zapper 2008-11-25 23:44:38 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Fedora Update System 2008-12-02 20:24:02 EST
ktorrent-3.1.5-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2008-12-06 23:11:34 EST
ktorrent-3.1.5-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.