Bug 469881 - (luci) luci failed to start
luci failed to start
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.5
All Linux
urgent Severity urgent
: rc
: 5.6
Assigned To: Ryan McCabe
Cluster QE
luci failed to start
: Reopened
: 519406 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 11:14 EST by skrishna
Modified: 2016-04-26 10:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:55:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description skrishna 2008-11-04 11:14:08 EST
Description of problem: luci failed to start


Version-Release number of selected component (if applicable): 5.0


How reproducible:
Luci is failed to start.
No error messgaes in /var/log

when i installed for the first time with luci  : luci-0.8-30.el5.x86_64.rpm
and ricci : ricci-0.8-30.el5.x86_64.rpm
and service ricci start
luci_admin init and giving the password twice
and service luci start . IT IS STARTING FINE NOW.
But due to bugs if i update to any of the higher versions of luci : luci-0.12.0-7.el5.x86_64.rpm
and ricci : ricci-0.12.0-7.el5.x86_64.rpm

Then the luci is not working properly. What i mean is service is stopped automatically when upgrading luci. And afterwards When i tried to start the service, it is saying : 
service luci start
Starting luci:                                             [FAILED]

Steps to Reproduce:
1.
2.
3.
  
Actual results:
It should be started. But its not.

Expected results:
It should be started. But its not.

Additional info:
we are going to build RHEL5 Cluster for the first time in my environment.
I just like like get the possible resolution.

Thanks a lot.
Comment 1 skrishna 2008-11-04 11:17:28 EST
I tried almost 3 to 4 times repeated the same process. But the problem still the same
Comment 2 Ryan McCabe 2008-11-04 11:38:27 EST
Could you see if there are any error messages in /var/lib/luci/log/*?
Comment 3 skrishna 2008-11-04 11:42:37 EST
Thanks a lot. I am glad to hear from you.

 cat event.log
------
2008-11-04T11:33:02 INFO ZServer HTTP server started at Tue Nov  4 11:33:02 2008
        Hostname: localhost.localdomain
        Port: 25639
------
2008-11-04T11:33:02 INFO Zope Set effective user to "luci"
------
2008-11-04T11:33:02 ERROR PortalTransforms Problem importing module rest : No module named reStructuredText
------
2008-11-04T11:33:03 WARNING Init Class Products.CMFFormController.ControllerBase.ControllerBase has a security declaration for nonexistent method 'getPostRequired'
------
2008-11-04T11:33:03 INFO PlacelessTranslationService Applying patch
*** Patching ZPublisher.Publish with the get_request patch! ***
------
2008-11-04T11:33:03 INFO Plone Option
ExternalEditor not found. If you want the external edit functionality, please download it from http://plope.com/software/ExternalEditor
------
2008-11-04T11:33:03 INFO Plone Option
Kupu not found. If you want WYSIWYG capabilities in Plone, you can download it from http://kupu.oscom.org/
------
2008-11-04T11:33:03 ERROR Plone Dependency
ATContentTypes not found or too old. Please download it from http://plone.org/products/atcontenttypes
------
2008-11-04T11:33:03 ERROR Plone Dependency
ExtendedPathIndex not found. Please download it from http://plone.org/products/extendedpathindex
------
2008-11-04T11:33:03 WARNING Plone Deprecation Warning
CustomizationPolicies are deprecated and will be removed in Plone 3.0. Please use GenericSetup extension profiles instead.
------
2008-11-04T11:33:03 WARNING Plone Deprecation Warning
registerSetupWidget is deprecated and will be removed in Plone 3.0.
------
2008-11-04T11:33:03 WARNING Plone Deprecation Warning
registerSetupWidget is deprecated and will be removed in Plone 3.0.
------
2008-11-04T11:33:04 WARNING Plone Deprecation Warning
CustomizationPolicies are deprecated and will be removed in Plone 3.0. Please use GenericSetup extension profiles instead.
------
2008-11-04T11:33:14 INFO Zope Ready to handle requests
------
2008-11-04T11:35:41 WARNING Plone Deprecation Warning
isPloneOne is deprecated and will be removed in Plone 3.0.
------
2008-11-04T11:36:18 INFO Signals Caught signal SIGTERM
------
2008-11-04T11:36:18 INFO Z2 Shutting down fast
------
2008-11-04T11:36:18 INFO ZServer closing HTTP to new connections
Comment 4 skrishna 2008-11-04 11:47:17 EST
rpm -qa | grep luci : luci-0.12.0-7.el5
rpm -qa | grep ricci  :  ricci-0.12.0-7.el5
rpm -qa | grep modcl : modcluster-0.10.0-5.el5
rpm -qa | grep oddjob
  oddjob-libs-0.27-9.el5
  oddjob-libs-0.27-9.el5
  oddjob-devel-0.27-9.el5
  oddjob-0.27-9.el5
  oddjob-devel-0.27-9.el5
I didnt install cman or rgmanager or any thing. I just want to see this error. So i just installed luci and ricci only.

This is my 4th time.
Let me know if you need any other information.
Comment 5 Ryan McCabe 2008-11-04 13:24:22 EST
I'm not sure what's going wrong. The messages that show up for you are the same ones I see (except for the SIGTERM and the ones after that). Could you cd into /var/lib/luci/bin and execute ./runzope and see if anything interesting is printed to stdout/stderr?

Another thing to check is selinux. Is it enforcing? If so, could you try switching it to permissive and see if starting luci works after that?

If that fails, could you try the luci package from http://people.redhat.com/rmccabe/conga/rhel53/luci-0.12.1-7.el5.x86_64.rpm
Comment 6 skrishna 2008-11-04 14:10:22 EST
This is the output for ./runzope :

Traceback (most recent call last):
  File "/usr/lib64/luci/zope/lib/python/Zope2/Startup/run.py", line 56, in ?
    run()
  File "/usr/lib64/luci/zope/lib/python/Zope2/Startup/run.py", line 19, in run
    opts = _setconfig()
  File "/usr/lib64/luci/zope/lib/python/Zope2/Startup/run.py", line 50, in _setconfig
    handlers.handleConfig(opts.configroot, opts.confighandlers)
  File "/usr/lib64/luci/zope/lib/python/Zope2/Startup/handlers.py", line 208, in handleConfig
    return multihandler(handlers)
  File "/usr/lib64/luci/zope/lib/python/ZConfig/loader.py", line 289, in __call__
    f(value)
  File "/usr/lib64/luci/zope/lib/python/Zope2/Startup/handlers.py", line 191, in root_handler
    config.port_base)
  File "/usr/lib64/luci/zope/lib/python/ZServer/datatypes.py", line 38, in prepare
    self.ip = socket.gethostbyname(self.host)
socket.gaierror: (-2, 'Name or service not known')


And this is my selinux config file:

cat /etc/selinux/config
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
# enforcing - SELinux security policy is enforced.
# permissive - SELinux prints warnings instead of enforcing.
# disabled - SELinux is fully disabled.
SELINUX=disabled
# SELINUXTYPE= type of policy in use. Possible values are:
# targeted - Only targeted network daemons are protected.
# strict - Full SELinux protection.
SELINUXTYPE=targeted

And finally i am trying the luci package from your link.
service luci start
Starting luci:                                             [FAILED]
Its not working too.

Thanks again.
Let me know if you need any other information
Comment 7 skrishna 2008-11-04 15:09:02 EST
Hi Ryan McCabe,

I got this thing solved.
I have done these things .
My nodes are dhcp assigned ip address. 



After luci was started for the very first time. luci service was working initially. I edited every node with all the cluster node ip address. There is a line 127.0.01 (loopback address) which i was commented. And then i restarted my network service.

There after the luci service stopped working. 


Resolution (with the help of Ryan McCabe ):
When i see the log file (Which you asked to me and i commented earlier)

cat event.log
------
2008-11-04T11:33:02 INFO ZServer HTTP server started at Tue Nov  4 11:33:02
2008
        Hostname: localhost.localdomain
        Port: 25639
------

It was bounding to this line in the /etc/hosts file.
127.0.0.1               localhost.localdomain localhost

If i uncommented this line and restart my network service. Then the luci service working fine.
Hereby what i am guessing is this service is bounding to that ip 127.0.0.1 (loopback).

What if in reality, If i need to change ip address of the machine (which can be just alone luci service in a server or luci service + ricci service together in a server). What i need to do at that point of time. Since this luci service is bounding to a particular ip.

Thanks a lot Ryan.
Have a great time.
Comment 8 Ryan McCabe 2010-02-04 17:25:12 EST
I was able to reliably reproduce this when running luci on a VM where IO was fairly slow. The luci init script gives up if 10 seconds elapses before the zope startup completes. Bumping the timeout up to 20 seconds fixed the problem for me.
Comment 11 Brian Brock 2010-03-09 17:49:32 EST
luci starts under any conditions, I've been using VMs occasionally with it.  looks like the timeout of 20s is long enough.
Comment 12 Ryan McCabe 2010-03-09 18:09:25 EST
*** Bug 519406 has been marked as a duplicate of this bug. ***
Comment 14 errata-xmlrpc 2010-03-30 04:55:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0289.html

Note You need to log in before you can comment on or make changes to this bug.