Bug 469927 - cxgb3: allow LRO settings through ethtool
cxgb3: allow LRO settings through ethtool
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Andy Gospodarek
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 14:29 EST by Divy Le Ray
Modified: 2014-06-29 19:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 14:16:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Divy Le Ray 2008-11-04 14:29:47 EST
The cxgb3 driver supports LRO. It is however not controllable through ethtool.
The following patch allows ethtool to control LRO settings for cxgb3.

It has been committed to upstream kernel.org:
http://git.kernel.org/?p=linux/kernel/git/davem/net-next-2.6.git;a=commitdiff;h=04ecb07241d8731b16490f10bec6ccedf5cfc792

Cheers,
Divy
Comment 1 Andy Gospodarek 2008-11-05 16:59:11 EST
We don't have the kernel bits (set_flags and get_flags) to make this happen, so I'm not sure this patch offers much to us, right?
Comment 2 Divy Le Ray 2008-11-05 17:03:57 EST
You're right. This patch won't help without the updated ethtool code.
I guess we can close this.

Cheers,
Divy
Comment 3 Andy Gospodarek 2008-11-06 21:05:47 EST
My test kernels have been updated to include a patch for this bugzilla.

http://people.redhat.com/agospoda/#rhel5

Please test them and report back your results.
Comment 4 Andy Gospodarek 2008-11-07 14:16:30 EST
My scripts automagically added comment #3 since I had originally backported the fix to rhel5 and added to my git tree just in case.  It's really not needed for 5.3 however since it doesn't do anything.  Closing out.

Note You need to log in before you can comment on or make changes to this bug.