Bug 469945 - Thinkpad TrackPoint is not properly set
Thinkpad TrackPoint is not properly set
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 15:48 EST by Jaroslav Barton
Modified: 2009-01-27 17:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 17:19:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
testing .fdi file (1.22 KB, text/xml)
2008-11-04 19:27 EST, Matěj Cepl
no flags Details
Xorg.0.log (46.83 KB, text/plain)
2008-11-05 02:04 EST, Jaroslav Barton
no flags Details
modified fdi file (897 bytes, text/plain)
2008-11-05 04:26 EST, Jaroslav Barton
no flags Details
Xorg.0.log after changes in fdi file (45.26 KB, text/plain)
2008-11-05 04:27 EST, Jaroslav Barton
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 282387 None None None Never

  None (edit)
Description Jaroslav Barton 2008-11-04 15:48:02 EST
Description of problem:
Cannot use trackpoint for scrolling.
xorg-x11-drv-evdev-2.0.7-3.fc10.x86_64

maybe helps:
http://mvogt.wordpress.com/2008/08/15/xorg-evdev-and-emulatewheel/
https://bugs.launchpad.net/evdev/+bug/282387

but xinput in fedora 10 (xorg-x11-apps-7.3-5.fc10.x86_64) doesn't know set-int-prop.

Expected results:
Middle button + TrackPoint up scrolls page up
Middle button + TrackPoint down scrolls page down
Middle button + TrackPoint left scrolls page left
Middle button + TrackPoint right scrolls page right
Comment 1 Matěj Cepl 2008-11-04 19:14:19 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Matěj Cepl 2008-11-04 19:15:45 EST
The blog mentions this .fdi file as helping:

<match key="info.product" string="TPPS/2 IBM TrackPoint">
 <merge key="input.x11_options.EmulateWheel" type="string">true</merge>
 <merge key="input.x11_options.EmulateWheelButton" type="string">2</merge>
 <merge key="input.x11_options.ZAxsisMapping" type="string">4 5</merge>
 <merge key="input.x11_options.Emulate3Buttons" type="string">true</merge>
</match>

Reporter, did you try to use this? Of course, we have in Fedora Rawhide sufficiently new evdev driver, so .fdi files are supported.
Comment 3 Matěj Cepl 2008-11-04 19:27:35 EST
Created attachment 322511 [details]
testing .fdi file

Just adding the code from the blog to my current /etc/hal/fdi/policy/10-synaptics.fdi I got this file. Please, put this file into this location and try to restart Xorg. Does it help? (of course, backup your previous version of the file, if you have any).
Comment 4 Jaroslav Barton 2008-11-05 02:02:40 EST
Adding this fdi file doesn't work. I tried restart X, hal, whole system, but still no change.

I am using autoconfigurated X, so there is no /etc/X11/xorg.conf file.
Comment 5 Jaroslav Barton 2008-11-05 02:04:13 EST
Created attachment 322526 [details]
Xorg.0.log
Comment 6 Jaroslav Barton 2008-11-05 04:26:46 EST
Created attachment 322550 [details]
modified fdi file

After modify fdi file, output in Xorg.0.log changes to this:

(II) config/hal: Adding input device TPPS/2 IBM TrackPoint
(**) TPPS/2 IBM TrackPoint: always reports core events
(**) TPPS/2 IBM TrackPoint: Device: "/dev/input/event5"
(II) TPPS/2 IBM TrackPoint: Found x and y relative axes
(II) TPPS/2 IBM TrackPoint: Found mouse buttons
(II) TPPS/2 IBM TrackPoint: Configuring as mouse
(II) XINPUT: Adding extended input device "TPPS/2 IBM TrackPoint" (type: MOUSE)
(**) Option "Emulate3Buttons" "true"
(II) TPPS/2 IBM TrackPoint: Forcing middle mouse button emulation.
(**) Option "Emulate3Timeout" "50"

But ignores all other settings.
Comment 7 Jaroslav Barton 2008-11-05 04:27:53 EST
Created attachment 322551 [details]
Xorg.0.log after changes in fdi file
Comment 8 Peter Hutterer 2008-11-09 22:34:44 EST
Input property support in X isn't actually in any shipped server version as of yet, so the server, evdev driver and the xinput tool shipped with F10 don't have it.

Likewise, wheel emulation will be part of evdev 2.1 which hasn't been released yet. It'll be available as soon as it's stable in F10, but you can get the preliminary F11 packages from 
http://koji.fedoraproject.org/koji/taskinfo?taskID=916729
Comment 9 Jaroslav Barton 2008-11-10 04:52:16 EST
Yep, package from F11 with newer evdev works.
Comment 10 Bug Zapper 2008-11-25 23:46:54 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Jaroslav Barton 2009-01-27 11:00:07 EST
Seems evdev 2.1 is in F10. May be closed?

Note You need to log in before you can comment on or make changes to this bug.