Bug 469966 - (polish) no bullets on single item lists
(polish) no bullets on single item lists
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 17:22 EST by Máirín Duffy
Modified: 2008-12-08 08:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 12:46:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of single list item with bullet (79.10 KB, image/png)
2008-11-04 17:22 EST, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2008-11-04 17:22:30 EST
Created attachment 322494 [details]
screenshot of single list item with bullet

Description of problem:

(see attached screenshot)

when package kit is to install a single package (in this instance I had double-clicked a package on my local hard drive to install it with PK) it says it will install this package but it puts a list bullet in front of the package name. It would look a lot more polished if it didn't use a list bullet when there is only one item in the 'list'. 

This happens in the dialog in the attached screenshot as well as the dialog where PK asks you if it can copy a file to /tmp.

Version-Release number of selected component (if applicable):
PackageKit-0.3.9-3.fc10.x86_64

How reproducible:
Very
Comment 1 Richard Hughes 2008-11-05 03:04:51 EST
Do you think the file name should be bold or italic when not bulleted? What about when there is more than one and bulleted? Thanks, I appreciate your help with this.
Comment 2 Máirín Duffy 2008-11-05 12:28:03 EST
Hi Richard!

What I would recommend is if it's a single item, don't bold or italic it, and don't bullet it. If there are multiple items, bullet them, and don't bold or italic them. I think that should look good.
Comment 3 Richard Hughes 2008-11-05 12:46:48 EST
Cool:

commit 58a80eb73e2152e634ada66a218bc7b8920206fb
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Nov 5 17:43:18 2008 +0000

    bugfix: don't use bullets when there is only one item in the list. Fixes rh#469966

I've also removed the <i> tags for the items. Thanks for your help, I appreciate it. If any of the other UI's need fixing too, please file bugs and I'll fix them up for F10.

Say hi to Ray for me. Sending regards from London. :-)
Comment 4 Máirín Duffy 2008-11-05 12:54:47 EST
lol, sure thing; I'll keep 'em coming, then. I recently upgraded to rawhide so I've been trying to file things as I notice them (before I didn't bother because I was usually a release or two behind and I didn't want to create too much unhelpful noise)

Ray says hi :) Boston is very happy today re: the election :)
Comment 5 Fedora Update System 2008-11-18 04:43:01 EST
PackageKit-0.3.10-1.fc10,gnome-packagekit-0.3.10-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/PackageKit-0.3.10-1.fc10,gnome-packagekit-0.3.10-1.fc10
Comment 6 Fedora Update System 2008-11-28 06:59:29 EST
PackageKit-0.3.11-2.fc10,gnome-packagekit-0.3.11-2.fc10,kpackagekit-0.3.1-7.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/PackageKit-0.3.11-2.fc10,gnome-packagekit-0.3.11-2.fc10,kpackagekit-0.3.1-7.fc10
Comment 7 Fedora Update System 2008-12-07 13:03:05 EST
PackageKit-0.3.11-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/PackageKit-0.3.11-4.fc10
Comment 8 Fedora Update System 2008-12-08 08:07:48 EST
PackageKit-0.3.11-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-12-08 08:08:18 EST
kpackagekit-0.3.1-7.fc10, PackageKit-0.3.11-3.fc10, gnome-packagekit-0.3.11-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.