Bug 469994 - copying large file to an Acer Aspire One via wireless link locks up the router
copying large file to an Acer Aspire One via wireless link locks up the router
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 23:47 EST by Frank Cox
Modified: 2009-07-26 20:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-26 20:46:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Cox 2008-11-04 23:47:56 EST
Description of problem:
If I get a wireless connection going with my Acer Aspire One I can use it for
what appears to be an indefinite period of time as long as I'm doing
lower-speed stuff.  Log into it with SSH, browse the net, run "yum
install" and so on.  All appears to be well.

However, as soon as I try to copy a large file locally over the network, the
wireless connection locks up.  For example, this command to copy a file from
this desktop computer to the Acer:

scp MyFonts-1.0-1.noarch.rpm acer:/home/frankcox

Got this far and stalled:

MyFonts-1.0-1.noarch.rpm             56% 3088KB 361.5KB/s - stalled -

The only way to get the connection back is to go to the router's configuration
page and "reset router".

I have another generic Intel laptop, so I put both the Acer and my other laptop online wirelessly at the same time.

Copying a large file from my desktop computer to the Acer locks up the wireless
side of the router. The copy fails after  just over 3mb has been
transferred and you can't do anything with the wireless connections to either laptop after that.  While the connections still read as up (four bars) on both laptops, you can't communicate and you can't re-connect until the router has been reset.

Copying that exact same file (and a bunch more afterward for good measure) from
my desktop computer to my other laptop works perfectly.  The files transfer and
everything works just like it should both before and after the copy has been
sent.

If I don't copy large files from my desktop computer to the Acer when it's
connected wirelessly, then everything seems to work.  I can use the Acer to
browse the web and so on without any apparent problem that I've seen to date.

I suspect it's something to do with higher transfer speed that you get
with a local file copy versus something that's coming in over the internet.
The Acer is apparently sending something unexpected to the router that causes
the wireless functions of the router to lock up.  The wired connections to the
router continue to work normally.

The router is a "Belkin Wireless G".

I wonder if there is some kind of a "stop for a moment because I'm overloaded"
command that the Acer is sending to the router, and forgetting to tell the
router to start again afterward.


Version-Release number of selected component (if applicable):
0.7.0-0.11.svn4229.fc10

How reproducible:
every time

Steps to Reproduce:
1.Obtain a wireless connection to the router from an Acer Aspire One
2.Copy a large file (over 3mb) from a computer on a wired connection to the router onto the Acer Aspire One.  (I tried both the scp command and the rsync command with the same results.)
3.The wireless connection will lock up after just over 3mb of data has been transferred.  The connection will still be present (four bars on the little meter) but it no longer does anything.  If you attempt to re-connect all you get is the window saying that you must provide the password.
4. You will have to reset the router before you can connect anything wirelessly again.

Actual results:
Wireless lockup.  The wired connections to the router continue to work normally but no wireless connection is possible until the router has been reset.

Expected results:
The file should be transferred and the connection should not lock up.  This expected result is obtained when I do exactly the same thing with my Intel laptop instead of the Acer Aspire One.

Additional info:
Here is the relevant section of /var/log/messages when I try to connect again after the router has locked up.

Nov  4 17:50:08 acer NetworkManager: <WARN>  get_secrets_cb(): Couldn't get
connection secrets: applet-device-wifi.c.1522 (get_secrets_dialog_response_cb):
canceled.
Nov  4 17:50:08 acer NetworkManager: <info>  (wlan0): device state change: 6 ->
9
Nov  4 17:50:08 acer NetworkManager: <info>  Activation (wlan0) failed for
access point (melvilletheatre.net)
Nov  4 17:50:08 acer NetworkManager: <info>  Marking connection 'Auto
melvilletheatre.net' invalid.
Nov  4 17:50:08 acer NetworkManager: <info>  Activation (wlan0) failed.
Nov  4 17:50:08 acer NetworkManager: <info>  (wlan0): device state change: 9 ->
3
Nov  4 17:50:08 acer NetworkManager: <info>  (wlan0): deactivating device
(reason: 0).
Nov  4 17:50:13 acer NetworkManager: <info>  Activation (wlan0) starting
connection 'Auto melvilletheatre.net'
Nov  4 17:50:13 acer NetworkManager: <info>  (wlan0): device state change: 3 ->
4
Nov  4 17:50:13 acer NetworkManager: <info>  Activation (wlan0) Stage 1 of 5
(Device Prepare) scheduled...
Nov  4 17:50:13 acer NetworkManager: <info>  Activation (wlan0) Stage 1 of 5
(Device Prepare) started...
Nov  4 17:50:13 acer NetworkManager: <info>  Activation (wlan0) Stage 2 of 5
(Device Configure) scheduled...
Nov  4 17:50:13 acer NetworkManager: <info>  Activation (wlan0) Stage 1 of 5
(Device Prepare) complete.
Nov  4 17:50:13 acer NetworkManager: <info>  Activation (wlan0) Stage 2 of 5
(Device Configure) starting...
Nov  4 17:50:13 acer NetworkManager: <info>  (wlan0): device state change: 4 ->
5
Nov  4 17:50:13 acer NetworkManager: <info>  Activation (wlan0/wireless):
access point 'Auto melvilletheatre.net' has security, but secrets are required.
Nov  4 17:50:13 acer NetworkManager: <info>  (wlan0): device state change: 5 ->
6
Nov  4 17:50:13 acer NetworkManager: <info>  Activation (wlan0) Stage 2 of 5
(Device Configure) complete.
Nov  4 17:50:13 acer NetworkManager: <info>  Activation (wlan0) Stage 1 of 5
(Device Prepare) scheduled...
Nov  4 17:50:13 acer NetworkManager: <info>  Activation (wlan0) Stage 1 of 5
(Device Prepare) started...
Nov  4 17:50:13 acer NetworkManager: <info>  (wlan0): device state change: 6 ->
4
Nov  4 17:50:13 acer NetworkManager: <info>  Activation (wlan0) Stage 2 of 5
(Device Configure) scheduled...
Nov  4 17:50:13 acer NetworkManager: <info>  Activation (wlan0) Stage 1 of 5
(Device Prepare) complete.
Nov  4 17:50:13 acer NetworkManager: <info>  Activation (wlan0) Stage 2 of 5
(Device Configure) starting...
Nov  4 17:50:13 acer NetworkManager: <info>  (wlan0): device state change: 4 ->
5
Nov  4 17:50:13 acer NetworkManager: <info>  Activation (wlan0/wireless):
connection 'Auto melvilletheatre.net' has security, and secrets exist.  No new
secrets needed.
Nov  4 17:50:13 acer NetworkManager: <info>  Config: added 'ssid' value
'melvilletheatre.net'
Nov  4 17:50:13 acer NetworkManager: <info>  Config: added 'scan_ssid' value '1'
Nov  4 17:50:13 acer NetworkManager: <info>  Config: added 'key_mgmt' value
'WPA-PSK'
Nov  4 17:50:13 acer NetworkManager: <info>  Config: added 'psk' value
'<omitted>'
Nov  4 17:50:13 acer NetworkManager: <info>  Activation (wlan0) Stage 2 of 5
(Device Configure) complete.
Nov  4 17:50:13 acer NetworkManager: <info>  Config: set interface ap_scan to 1
Nov  4 17:50:13 acer NetworkManager: <info>  (wlan0): supplicant connection
state:  disconnected -> scanning
Nov  4 17:50:14 acer NetworkManager: <info>  (wlan0): supplicant connection
state:  scanning -> associating
Nov  4 17:50:34 acer NetworkManager: <info>  (wlan0): supplicant connection
state:  associating -> disconnected
Nov  4 17:50:34 acer NetworkManager: <info>  (wlan0): supplicant connection
state:  disconnected -> scanning
Nov  4 17:50:35 acer NetworkManager: <info>  (wlan0): supplicant connection
state:  scanning -> associating
Nov  4 17:50:38 acer NetworkManager: <info>  Activation (wlan0/wireless):
association took too long.
Nov  4 17:50:38 acer NetworkManager: <info>  (wlan0): device state change: 5 ->
6
Nov  4 17:50:38 acer NetworkManager: <info>  Activation (wlan0/wireless):
asking for new secrets
Nov  4 17:50:38 acer NetworkManager: <info>  (wlan0): supplicant connection
state:  associating -> disconnected
Nov  4 17:50:53 acer NetworkManager: <info>  wlan0: link timed out.
Nov  4 17:52:20 acer NetworkManager: <info>  (wlan0): supplicant connection
state:  disconnected -> scanning
Comment 1 Frank Cox 2008-11-05 00:33:24 EST
Upon further experimentation I discovered that if the Intel laptop (which runs Fedora 8) is online wirelessly when the router locks up as described above, it also won't go back online wirelessly until it has been rebooted.

So rebooting the router allows the Acer Aspire One to get back online wirelessly but the other laptop also has to be rebooted or it won't go back online wirelessly.  It just brings up the "enter your WPA2 password" window until you reboot it.

Therefore, this bug doesn't just lock up the wireless networking on the router.  It also locks up the wireless networking on the other laptop if it happens to be online at the same time.
Comment 2 Frank Cox 2008-11-05 17:05:23 EST
I just turned set the wireless security on my router to "disabled" and then
booted the Acer Aspire One and got it online wirelessly.  I then used scp to
copy the large file from my desktop computer to the Acer.  The first time I
tried it, all 5mb transferred just fine.  It would only get through about 3mb
of that before locking up with the WPA2 security enabled.

I then attempted to copy that file a second time, entering the exact same
command.  And after getting about halfway through the transfer (just short of
3mb) the connection was locked up just the same as it was before.

So the problem still exists with the wireless security turned off.  It seems to
transfer about twice as much data before locking up, though.
Comment 3 Frank Cox 2008-11-06 20:04:06 EST
I'm starting to suspect that this problem is related to the mtu size.  The connection defaults to 1500.  When I explicitly set it with Network Manger (under "edit connections") to a value of 1400, I could transfer about 3x more data than I could with the default setting before I got the lockup.

Setting the mtu value to 1350 allowed me to transfer about one-quarter of the data that I could with the default setting of 1500.

The default mtu works fine with the Intel laptop.

I don't know how one could fine out what the optimum working mtu is for the Acer (if there actually is one) without trying each possible value one-by-one, which would take a very long time due to the fact that both the Acer and the router have to be rebooted between each attempt.

I did use the Acer this afternoon for about three hours of web browsing via the wireless network (using the default mtu of 1500) without any problem.  I also downloaded and the latest "yum update", which included new "kernel firmware".  Wondering if that would make a difference I rebooted the Acer with the new updates and tried a file copy again and it locked up just the same as before.

It's something to do with the higher speeds achieved with a local file copy versus a download from the Internet.
Comment 4 Charles R. Anderson 2008-11-13 17:29:37 EST
This is almost certainly a bug in the kernel driver, rather than a bug in NetworkManager.  Moving there.  You should probably attach dmesg output and details about the wireless card you have and driver you are using.
Comment 5 Frank Cox 2008-11-13 22:26:10 EST
Here is what appears to be the relevant portion of the dmesg output on my Acer Aspire One.

QUOTE:
r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
r8169 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
r8169 0000:02:00.0: setting latency timer to 64
r8169 0000:02:00.0: no MSI. Back to INTx.
eth0: RTL8102e at 0xf88ee000, 00:1e:68:f4:39:fc, XID 24a00000 IRQ 17
ath5k_pci 0000:03:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
ath5k_pci 0000:03:00.0: setting latency timer to 64
ath5k_pci 0000:03:00.0: registered as 'phy0'
ath5k phy0: Support for RF2425 is under development.
phy0: Selected rate control algorithm 'pid'
uvcvideo: Found UVC 1.00 device USB 2.0 Camera (0c45:62c0)
input: USB 2.0 Camera as /devices/pci0000:00/0000:00:1d.7/usb1/1-5/1-5:1.0/input
/input9
usbcore: registered new interface driver uvcvideo
USB Video Class driver (v0.1.0)
ath5k phy0: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)
END OF QUOTE

The last few lines of dmesg output also appear relevant:

QUOTE:
wlan0: authenticate with AP 00:17:3f:e8:f3:ff
wlan0: authenticated
wlan0: associate with AP 00:17:3f:e8:f3:ff
wlan0: RX AssocResp from 00:17:3f:e8:f3:ff (capab=0x431 status=0 aid=2)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
padlock: VIA PadLock not detected.
wlan0: no IPv6 routers present
END OF QUOTE

[frankcox@acer ~]$ uname -a
Linux acer.melvilletheatre.net 2.6.27.5-94.fc10.i686 #1 SMP Mon Nov 10 15:51:55 EST 2008 i686 i686 i386 GNU/Linux

[frankcox@acer ~]$ locate ath5k
/lib/modules/2.6.27.4-68.fc10.i686/kernel/drivers/net/wireless/ath5k
/lib/modules/2.6.27.4-68.fc10.i686/kernel/drivers/net/wireless/ath5k/ath5k.ko
/lib/modules/2.6.27.4-79.fc10.i686/kernel/drivers/net/wireless/ath5k
/lib/modules/2.6.27.4-79.fc10.i686/kernel/drivers/net/wireless/ath5k/ath5k.ko
/lib/modules/2.6.27.5-94.fc10.i686/kernel/drivers/net/wireless/ath5k
/lib/modules/2.6.27.5-94.fc10.i686/kernel/drivers/net/wireless/ath5k/ath5k.ko
Comment 6 Frank Cox 2008-11-18 17:13:44 EST
I was just setting up a Trendnet wireless G router for another purpose and decided to take advantage of the opportunity to put the Acer Aspire One on it and copy some large files.

Doing exactly the same thing in exactly the same way (with the same files) through the Trendnet router works perfectly.  There is no lockup.

Therefore, the problem lies somewhere in the interaction of the Acer Aspire One and the Belkin Wireless G router.
Comment 7 Bug Zapper 2008-11-25 23:47:58 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Frank Cox 2009-07-26 20:46:03 EDT
This problem has gone away with Fedora 11.

Note You need to log in before you can comment on or make changes to this bug.