Bug 470051 - Closing bug as duplicate should move blocking of the third bugs to the open bug
Closing bug as duplicate should move blocking of the third bugs to the open bug
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
devel
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-05 09:25 EST by Matěj Cepl
Modified: 2014-10-12 18:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.2.4-6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-14 22:53:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2008-11-05 09:25:05 EST
Description of problem:
closing bug A which blocks bug Q as a duplicate of bug B. Given that I am saying that bug is still alive (except for organizational and other purposes I want to have only one bug instead of two) there should be that blocking around.
Comment 1 Jeff Fearn 2012-05-30 00:42:13 EDT
As part of the recent Bugzilla 2.4 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.
Comment 2 Jeff Fearn 2012-07-19 01:28:43 EDT
As noted previously, the Bugzilla Team is cleaning up a large number of outstanding issues that have bit rotted. This bug is being closed as there has been no response to that notification.

If you believe this bug is still important please reopen this bug in the NEW status and PM will consider it.
Comment 3 Simon Green 2012-09-04 21:05:08 EDT
(In reply to comment #0)
> there should be that blocking around.

Just so I understand what you are requesting, when Bug A with a blocking of Bug Q is marked as a duplicate of bug B, you want bug B to also be a blocker of Bug Q?

  -- simon
Comment 4 Matěj Cepl 2012-09-05 10:41:58 EDT
(In reply to comment #3)
> Just so I understand what you are requesting, when Bug A with a blocking of
> Bug Q is marked as a duplicate of bug B, you want bug B to also be a blocker
> of Bug Q?

Exactly. Thank you
Comment 7 Simon Green 2012-09-07 07:09:07 EDT
(In reply to comment #3)
> Just so I understand what you are requesting, when Bug A with a blocking of
> Bug Q is marked as a duplicate of bug B, you want bug B to also be a blocker
> of Bug Q?

There will be two cases where this will not happen:

1) The user does not have permission to EDIT the duplicate bug (Bug B)
2) The user does not have permission to VIEW the blocked bug (Bug Q)

In the second case, if there are other blockers that the user can view, they will be copied over.

This is mainly a non issue as I imagine Red Hat users (who have permission to edit most bugs) will be marking duplicates.

Another point to make is the blocker bug will receive up to two e-mails (depending on users preferences). One will be for the new blocker, and the second will be for the bug status change of bug A. It doesn't seem possible to combine this into one e-mail.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.