Bug 470107 - Errors in chapter 2
Errors in chapter 2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Management_Console_Installation_Guide (Show other bugs)
1.1
All Linux
medium Severity medium
: 1.1
: ---
Assigned To: Lana Brindley
Jeff Needle
http://documentation-stage.bne.redhat...
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-05 14:45 EST by Jeff Needle
Modified: 2013-10-23 19:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-07 20:48:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Needle 2008-11-05 14:45:25 EST
Chapter 2. Start Console

Steps 2, 3, and 4 need to precede step 1.

Step 2 asks you to "su ~ postgres".  That needs to be a hyphen, not a tilde "su - postgres".

After step 3 (edit pg_hba.conf), we should probably tell the reader to type "exit" to get back to the root shell since you have to be root to start/stop the postgresql service.

Step 5 doesn't work because the cumin user now has a shell of "nologin". The cumin-admin command should probably be run as root.  Need to verify that.
Comment 1 Lana Brindley 2008-11-18 00:27:17 EST

(In reply to comment #0)
> Chapter 2. Start Console
> 
> Steps 2, 3, and 4 need to precede step 1.

For the steps ordering, see https://bugzilla.redhat.com/show_bug.cgi?id=451198 and please advise further.
> 
> Step 2 asks you to "su ~ postgres".  That needs to be a hyphen, not a tilde "su
> - postgres".

Changed

> 
> After step 3 (edit pg_hba.conf), we should probably tell the reader to type
> "exit" to get back to the root shell since you have to be root to start/stop
> the postgresql service.
> 

Added "ensure you are running as the root user" to the step about restarting the postgresql service

> Step 5 doesn't work because the cumin user now has a shell of "nologin". The
> cumin-admin command should probably be run as root.  Need to verify that.

Can you please confirm how this step should look?

Thanks,
LKB
Comment 2 Jeff Needle 2008-12-02 12:24:16 EST
I added Justin as a CC and moved the NEEDINFO action over to him as he's the one with the latest information on how this should work.
Comment 3 Justin Ross 2008-12-02 13:04:25 EST
As to step 5, cumin-admin can indeed be (and should be) run as root.
Comment 4 Jan Sarenik 2008-12-04 10:02:52 EST
Here is what I've found as of today while reading mgmt install man at
http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_MRG/1.1/html-single/Management_Console_Installation_Guide/

Please correct me if I am not using the latest upstream development
version of these docs.


The first issue I see is connected with the wrong ordering but I
understand it that Lana is about to fix it in next release as bug
number 451198 --> NEXT RELEASE.


The second thing is, that the only error left in this bug is the
importance of being root to execute 'cumin-admin'. As Justin alredy
wrote, one really needs root for that so if there is not anything
else, please fix it and triage further. Thanks.
Comment 5 Lana Brindley 2008-12-05 01:23:08 EST
(In reply to comment #4)
> Here is what I've found as of today while reading mgmt install man at
> http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_MRG/1.1/html-single/Management_Console_Installation_Guide/
> 
> Please correct me if I am not using the latest upstream development
> version of these docs.
> 

The stage version is correct.

> 
> The first issue I see is connected with the wrong ordering but I
> understand it that Lana is about to fix it in next release as bug
> number 451198 --> NEXT RELEASE.
> 

451198 has been completed, and that version is what is up on the stage (link you gave above). In the book due for release, the steps are (in short):

1. Initialise cumin database and prepare schema
2. Change to the postgres user
3. Edit the config file
...

If this is _not_ correct, please advise immediately.

> 
> The second thing is, that the only error left in this bug is the
> importance of being root to execute 'cumin-admin'. As Justin alredy
> wrote, one really needs root for that so if there is not anything
> else, please fix it and triage further. Thanks.

<listitem>
	<para>
		A username and password is required to log on to the &CONSOLE;. Run the <command>cumin-admin add-user</command> command as the root user:
	</para>
			
<screen>
# cumin-admin add-user <replaceable>testuser</replaceable>Set password: *****
Retype password: *****
User &#39;testuser&#39; is added
</screen>
</listitem>

LKB
Comment 6 Jan Sarenik 2008-12-05 03:19:19 EST
Hello Lana!

(In reply to comment #5 by LKB)
> 451198 has been completed, and that version is what is up on the stage (link
> you gave above). In the book due for release, the steps are (in short):
> 
> 1. Initialise cumin database and prepare schema
> 2. Change to the postgres user
> 3. Edit the config file
> ...
> 
> If this is _not_ correct, please advise immediately.

This is definitely not correct is I was installing it yesterday.
The correct order looks like this:

  1. Change to the postgres user (WAS: 2)
  2. Edit the config file (WAS: 3)
  3. Run PostgeSQL (WAS: 4)
  4. Initialise cumin database (WAS: 1)
  5. cumin-admin as root (see below)


> > The second thing is, that the only error left in this bug is the
> > importance of being root to execute 'cumin-admin'. As Justin alredy
> > wrote, one really needs root for that so if there is not anything
> > else, please fix it and triage further. Thanks.
> 
> <listitem>
>  <para>
>   A username and password is required to log on to the &CONSOLE;. Run the
> <command>cumin-admin add-user</command> command as the root user:
>  </para>
> 
> <screen>
> # cumin-admin add-user <replaceable>testuser</replaceable>Set password: *****
> Retype password: *****
> User &#39;testuser&#39; is added
> </screen>
> </listitem>

The pasted code is right, I just can not see it at doc-stage, maybe
there was not any rebuild yet (does the docs rebuild happen every night?).

   Thank you, best regards Jasan
Comment 7 Justin Ross 2008-12-05 10:11:57 EST
Lana, regarding the steps and their order.  We do indeed need to revert to the previous order.  We discovered in testing that the new order won't work.

That leaves the issue of whether the /var/lib/pgsql/data dir is initialized and thus the pg_hba.conf file is present to edit.

Here's what I propose:

 - Revert to the 1.0.1 order of steps.
 - Insert a step at the very beginning to
   a. Check if /var/lib/pgsql/data/pg_hba.conf
   b. If not, run "service postgresql start; service postgresql stop" to create it
Comment 8 Lana Brindley 2008-12-07 20:07:20 EST
OK, it's all in. I'll rebuild the docs for review now.

Cheers,
LKB
Comment 9 Lana Brindley 2008-12-07 20:48:11 EST
Package:
Red_Hat_Enterprise_MRG-Management_Console_Installation_Guide-1.1-web-en-US-1-4
Tag: docs-5E
Status: complete
Built by: lbrindle
ID: 78555
Started: Sun, 07 Dec 2008 20:24:10 EST
Finished: Sun, 07 Dec 2008 20:31:18 EST

LKB

Note You need to log in before you can comment on or make changes to this bug.