Bug 470169 - thunderbird opens PDF with evince, should be using acroread
thunderbird opens PDF with evince, should be using acroread
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-05 23:20 EST by Jonathan Kamens
Modified: 2018-04-11 07:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-10 18:18:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mimeTypes.rdf file (5.75 KB, text/plain)
2008-11-10 13:46 EST, Jonathan Kamens
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 470169 None None None Never

  None (edit)
Description Jonathan Kamens 2008-11-05 23:20:56 EST
Both firefox and my GNOME desktop are configured to open PDF files with an external acroread process.

Nevertheless, thunderbird-2.0.0.17-1.fc10 opens PDF attachments with evince.  It does not ask me if that's what I want it to do, and it's not listed in Edit > Preferences > Attachments.

I'm not 100% certain that this used to work properly, but I believe it did, so I think there's a bug here.  Although, for the life of me, I can't figure out what the bug is, because I simply can't figure out where the evince thing is coming from.
Comment 1 Matěj Cepl 2008-11-07 19:07:05 EST
TB settings are stored in the mimeType.rdf files, so this would be a good start to find out where the information is coming from:

find /usr/lib*/thunderbird-2.*/ ~/.thunderbird/ -name mime\*.rdf \
    -exec grep -i 'pdf' '{}' \;

and these are the Gnome settings

find /usr/share/mime ~/.local/share/mime -name \*pdf\*

Could I get outputs of these two commands, please?
Comment 2 Matěj Cepl 2008-11-07 19:07:42 EST
... and attached any file found by this search, which seems to be relevant.
Comment 3 Jonathan Kamens 2008-11-10 13:46:29 EST
/usr/share/mime/application/pdf.xml doesn't show anything useful.
I have /home/jik/.thunderbird/pvb1vszn.default/mimeTypes.rdf, which I will attach, which seems to show that thunderbird is supposed to be opening PDF files with acroread.
Comment 4 Jonathan Kamens 2008-11-10 13:46:56 EST
Created attachment 323102 [details]
mimeTypes.rdf file
Comment 5 Jonathan Kamens 2008-11-10 13:50:37 EST
I removed mimeTypes.rdf, and the next time I tried to open a PDF attachment it asked me what to do with it.  I said to use /usr/bin/acroread, and it worked.

It claimed that I could subsequently edit the action in the Content tab of the Preferences dialog (it really should say Attachments, not Content), but in fact the just-added action does not appear there (in fact, nothing appears there).

So although deleting mimeTypes.rdf seems to have solved my immediate problem, things clearly still are not functioning properly.
Comment 6 Christopher Aillon 2008-11-10 17:28:34 EST
  <RDF:Description RDF:about="urn:mimetype:handler:application/pdf"
                   NC:saveToDisk="false"
                   NC:handleInternal="false"
                   NC:alwaysAsk="false"
                   NC:useSystemDefault="true">
    <NC:externalApplication RDF:resource="urn:mimetype:externalApplication:application/pdf"/>
  </RDF:Description>


Note that your mimeTypes.rdf was set to use the system default.  That may not be the same as what GNOME is using though it ought to be.  Bottom line is that thunderbird is/was asking the system what to use and then used the reported application.  Another note is that firefox 3.0 and thunderbird 2.0 use a different bit of code here, and that may be causing some difference in behavior, but this won't be fixed in TB 2.0.  Thunderbird 3.0 pre-release versions are out and will be appearing in rawhide post-F10 at some point, which may help this out.

The other issue with it not showing up in the list is an upstream bug.  Since things are working now, I recommend closing the bug since there's not really much that can be done given that the TB 2.0 branch is essentially in security-only mode at this point.
Comment 7 Matěj Cepl 2008-11-10 18:18:02 EST
Closing as suggested.

Note You need to log in before you can comment on or make changes to this bug.