Bug 47020 - logrotate restarts syslog several times
Summary: logrotate restarts syslog several times
Status: CLOSED DUPLICATE of bug 39423
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sysklogd   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-02 18:38 UTC by Need Real Name
Modified: 2014-03-17 02:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-02 18:38:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-07-02 18:38:08 UTC
The /etc/logrotate.d/syslog causes sysklogd-1.3.33-8 being restarted
several times
Jun 24 04:02:03 cmpq syslogd 1.3-3: restart.
 Jun 24 04:02:03 cmpq syslogd 1.3-3: restart.
 Jun 24 04:02:04 cmpq syslogd 1.3-3: restart.
 Jun 24 04:02:04 cmpq syslogd 1.3-3: restart.
 Jun 24 04:02:05 cmpq syslogd 1.3-3: restart.
 Jun 24 04:02:05 cmpq syslogd 1.3-3: restart.
 Jun 24 04:02:06 cmpq syslogd 1.3-3: restart.
 Jun 24 04:02:07 cmpq syslogd 1.3-3: restart.
 Jun 24 04:02:08 cmpq syslogd 1.3-3: restart.
 Jun 24 04:02:11 cmpq syslogd 1.3-3: restart.
 Jun 24 04:02:12 cmpq syslogd 1.3-3: restart.
 Jun 24 04:02:13 cmpq syslogd 1.3-3: restart.

This is 
1) wrong. 
2) may cause a race to restart sysklog several times.

The right solution will be to use sharedscripts
/var/log/messages /var/log/secure /var/log/maillog /var/log/spooler
/var/log/boot.log /var/log/cron {
missingok
  notifempty
  sharedscripts
  postrotate
/bin/kill -HUP `cat /var/run/syslogd.pid 2>/dev/null` 2>/dev/null || true
    endscript
}

Most of packages (samba, exim and others already do this
for log rotation to avoid multiple -HUP)

Comment 1 Bill Nottingham 2001-07-06 03:15:00 UTC

*** This bug has been marked as a duplicate of 39423 ***


Note You need to log in before you can comment on or make changes to this bug.