Bug 470203 - system-control-network crashes at start-up when a wireless device is configured
system-control-network crashes at start-up when a wireless device is configured
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
10
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 477823 518780 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 04:17 EST by Joachim Frieben
Modified: 2009-08-25 18:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-13 19:49:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace of system-control-network when a wireless device has been configured (1.40 KB, text/plain)
2008-11-06 04:17 EST, Joachim Frieben
no flags Details
Section of /var/log/messages related to creation of connection wlan0 (2.05 KB, text/plain)
2008-11-06 06:52 EST, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2008-11-06 04:17:36 EST
Created attachment 322677 [details]
Backtrace of system-control-network when a wireless device has been configured

Description of problem:
After installing F10 PR x86_64 on a new system, system-control-network does not start up when launched from the menu. After executing the command from the shell, it crashes instantaneously returning the attached backtrace.

Version-Release number of selected component (if applicable):
system-config-network-1.5.94-1.fc10.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Launch system-control-network from the shell.
  
Actual results:
Application crashes immediately.

Expected results:
Application starts as expected.

Additional info:
- After removing all wlan0 entries in etc/sysconfig/.. created by anaconda,
  system-control-network behaves correctly.
- Interestingly, the wireless device cannot be removed from within
  system-config-network: it is greyed out.
Comment 1 Jiri Moskovcak 2008-11-06 04:56:31 EST
Hm, that's weird, aren't there any selinux denials?
Can you send me output of ls -l /etc/sysconfig/networking/devices/ifcfg-wlan0.

Thanks,
Jirka
Comment 2 Joachim Frieben 2008-11-06 06:52:54 EST
Created attachment 322698 [details]
Section of /var/log/messages related to creation of connection wlan0
Comment 3 Joachim Frieben 2008-11-06 06:56:32 EST
When system-control-network is executed a root, then the GUI will actually come up. However, the wlan0 connection is missing now, whereas it is shown by system-config-network.
Comment 4 Joachim Frieben 2008-11-06 06:58:48 EST
The output of 'ls -l /etc/sysconfig/networking/devices/ifcfg-wlan0' reads:

-rw-r--r-- 3 root root 300 2008-11-06 12:54 /etc/sysconfig/networking/devices/ifcfg-wlan0

The issue is not related to SELinux since I have set SELINUX=permissive.
Comment 5 Harald Hoyer 2008-11-06 07:57:20 EST
it needs the checkbox 
[x] Allow all users to enable and disable the device

otherwise only root can activate it

in the config file:
USERCTL=yes
Comment 6 Joachim Frieben 2008-11-06 10:30:36 EST
(In reply to comment #5)
> it needs the checkbox 
> [x] Allow all users to enable and disable the device
> 
> otherwise only root can activate it
> 
> in the config file:
> USERCTL=yes

Sure, but that does not explain why system-control-network would crash when there is a configured wlan0 connection. Only ppp0 is allowed to be enabled and disabled by ordinary users here, but not so eth0 or eth1. Likewise wlan0 is not supposed to be controlled by a non-root user on my system.
Moreover, I had actually launched system-control-network as root when the wlan0 connection did still not show up, although the necessary rights where granted. An ordinary would never see the GUI because the applications crashes before.
Comment 7 Harald Hoyer 2008-11-06 11:04:25 EST
hmpf, yes, it should not crash.

ifcfg-wlan0 is supposed to be readable. key-wlan0 only for root.
Comment 8 Bug Zapper 2008-11-25 23:51:33 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Jiri Moskovcak 2008-11-28 07:52:23 EST
Hm, I could reproduce this, but once I wrote smth to ifcfg-wlan0 it suddenly started to work - maybe there is smth wrong with ACLs of the file, can you send me output of $ getfacl ifcfg-wlan0 ?

Thanks,
Jirka
Comment 10 Joachim Frieben 2008-11-29 02:17:46 EST
No change for system-config-network-1.5.94-2.fc10.
Comment 11 Joachim Frieben 2008-11-29 02:19:50 EST
(In reply to comment #9)
$ getfacl ifcfg-wlan0
# file: ifcfg-wlan0
# owner: root
# group: root
user::rw-
group::r--
other::r--
Comment 12 Nicola Soranzo 2008-12-02 16:23:55 EST
This is a regression from F9. 
I have exactly the same problem, but with wireless device eth1.
From the backtrace it looks like that system-control-network is trying to open the file /etc/sysconfig/networking/devices/ifcfg-eth1 in write mode, that's why it works only if started by root.
Comment 13 Jiri Moskovcak 2008-12-08 10:18:41 EST
Yes, you're right, it tries to write to the file. I've removed this unnecessary write and this should be fixed with the next version.

Thanks,
Jirka
Comment 14 Nicola Soranzo 2008-12-12 07:08:34 EST
I'd like to test the fix, which version should I try?

Thanks!
Comment 17 Nicola Soranzo 2008-12-14 06:38:57 EST
Can you please release official updated packages?
Thanks again
Comment 18 Fedora Update System 2008-12-17 07:58:03 EST
system-config-network-1.5.95-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/system-config-network-1.5.95-1.fc10
Comment 19 Jiri Moskovcak 2008-12-24 05:57:56 EST
*** Bug 477823 has been marked as a duplicate of this bug. ***
Comment 20 Fedora Update System 2009-01-07 04:06:21 EST
system-config-network-1.5.95-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Christoph Wickert 2009-08-25 18:35:35 EDT
*** Bug 518780 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.