Bug 470235 - no network using iwl3945
no network using iwl3945
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 07:52 EST by David Nielsen
Modified: 2008-11-17 17:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 17:03:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (1.23 KB, text/plain)
2008-11-06 18:44 EST, David Nielsen
no flags Details
iwconfig (652 bytes, text/plain)
2008-11-06 18:45 EST, David Nielsen
no flags Details
lspci (751 bytes, text/plain)
2008-11-06 18:45 EST, David Nielsen
no flags Details

  None (edit)
Description David Nielsen 2008-11-06 07:52:57 EST
Description of problem:
Whenever trying to connect to my unsecured AP (same issue on WPA2-PSK), Network Manager will appear to succesfully connect then sit there for a while followed by a message saying it could not connect. The killswitch is not engaged on my Lenovo 3000 N100.

The following can be seen in dmesg starting with first attempt to connect untill after the failure is announced.

wlan0: authenticate with AP 00:0e:2e:d5:9e:89
wlan0: authenticate with AP 00:0e:2e:d5:9e:89
wlan0: authenticated
wlan0: associate with AP 00:0e:2e:d5:9e:89
wlan0: RX ReassocResp from 00:0e:2e:d5:9e:89 (capab=0x421 status=0 aid=2)
wlan0: associated
wlan0: disassociating by local choice (reason=3)
wlan0: authenticate with AP 00:0e:2e:d5:9e:89
wlan0: authenticated
wlan0: associate with AP 00:0e:2e:d5:9e:89
wlan0: RX AssocResp from 00:0e:2e:d5:9e:89 (capab=0x421 status=0 aid=2)
wlan0: associated
wlan0: disassociating by local choice (reason=3)

Version-Release number of selected component (if applicable):
kernel-2.6.27.4-68.fc10.x86_64
NetworkManager-0.7.0-0.11.svn4229.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Attempt connection
  
Actual results:
connection failure

Expected results:
glorious internet

Additional info:
da_DK.UTF-8, x86_64
Comment 1 David Nielsen 2008-11-06 07:56:28 EST
upsie, block on F10Kernelblocker, not F10Blocker
Comment 2 John W. Linville 2008-11-06 14:43:45 EST
 
Since you said it is an unsecured connection, perhaps you can try it w/o NetworkManager?

   service NetworkManager stop
   ifconfig wlan0 up
   iwconfig wlan0 essid <YOUR_SSID>
   dhclient wlan0

Do you then get a working connection?  If not, can we see the output of 'iwconfig', 'lspci -n', and 'dmesg'?
Comment 3 David Nielsen 2008-11-06 18:44:51 EST
Created attachment 322800 [details]
dmesg

no network, attaching requested output
Comment 4 David Nielsen 2008-11-06 18:45:19 EST
Created attachment 322801 [details]
iwconfig
Comment 5 David Nielsen 2008-11-06 18:45:51 EST
Created attachment 322802 [details]
lspci
Comment 6 John W. Linville 2008-11-07 11:22:25 EST
Thanks for the information, but I'm not sure I understand "no network" in comment 3.  Both dmesg and iwconfig indicate a valid association, and the iwconfig indicates a strong signal.  What is the problem when using this configuration?
Comment 7 David Nielsen 2008-11-07 14:01:53 EST
I can't ping anything, nor connect to any websites using Firefox. All I get is the polite message that no network is reachable.

I have tested the wifi chip in Windows Vista a few days ago and that worked just fine so I am pretty sure it's not broken.
Comment 8 John W. Linville 2008-11-07 14:24:14 EST
Did it get an IP address from dhclient?

If you put the interface into monitor mode, can you see frames with wireshark and/or tcpdump?

   ifconfig wlan0 down
   iwconfig wlan0 mode monitor
   ifconfig wlan0 up
Comment 9 David Nielsen 2008-11-07 16:43:30 EST
Strangely now when following the manual approach from #2 I now get an ip and have full connection to the network. So I assume this is a NM bug?
Comment 10 David Nielsen 2008-11-07 16:50:49 EST
I think I figured it out, it might be my router (Edimax BR-6215SRg). It seems to be causing the issue. While it works with my rt61 card in my desktop as well as the Belkin USB dongle I use as a backup on my laptop, the iwl3945 seems to be causing it problems. I have seen other routers have issues with the Intel cards before, most notably the Fonera.
Comment 11 John W. Linville 2008-11-07 17:01:28 EST
Regarding your router, I suppose it is possible.  It would probably be useful to get (using another device) some wireshark traces that show the interaction between the router and the iwl3945.

As far as comment 9, I've been seeing a lot of problems lately where NM fails to connect but manual connections succeed.  It is possible that some driver wierdness is angering NM in these issues, but I need an NM person to give me a clue as to what that might be.
Comment 12 Dan Williams 2008-11-17 14:11:46 EST
Does absolute latest kernel help?  There have been reports that this kernel makes NM and wpa_supplicant happier.

2.6.27-5.109.fc10
Comment 13 David Nielsen 2008-11-17 15:00:52 EST
seems ok
Comment 14 Dan Williams 2008-11-17 17:03:34 EST
ok, -> kernel and closing as fixed then.  thanks!

Note You need to log in before you can comment on or make changes to this bug.