Bug 470261 - Update cluster replication for changes to DeliveryRecord.
Update cluster replication for changes to DeliveryRecord.
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.0
All Linux
urgent Severity urgent
: 1.1
: ---
Assigned To: Alan Conway
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 09:22 EST by Alan Conway
Modified: 2009-02-04 10:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 10:34:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2008-11-06 09:22:28 EST
Description of problem:

gsim added a credit member to DeliveryRecord, need to update corresponding cluster.xml method and cluster code.

See bug 470260 for a long term solution to this type of problem.
Comment 1 Alan Conway 2008-11-11 16:10:05 EST
Added the credit to cluster replication SVN r713171. 
Not sure how best to test this, will discuss with gsim.
Comment 3 Frantisek Reznicek 2008-11-25 08:38:48 EST
Putting NEEDINFO flag because it is not clear how to approach the test.
Comment 4 Gordon Sim 2008-11-25 09:16:17 EST
For clustering I think the test would be:

(1) publish 2 messages to queue
(2) subscribe to queue with message window of 1 and receive first message
(3) accept it (but don't complete it)
(4) start new cluster member (which would then need to get the unacked list replicated to it, including that delivery record which has ended and thus has no payload, but does have an amount of credit associated with it)
(5) send completion from client which should allow the second message to be delivered
(6) accept (and complete) that
(7) check that both members dequeued the second message ok
Comment 5 Alan Conway 2008-11-25 15:12:18 EST
SVN r720585: Added unit test that does the steps of #c4 above.
src/tests/cluster_test.cpp: see testUnacked comments mentioning "empty credit"
Comment 6 Frantisek Reznicek 2008-11-26 09:44:46 EST
Complete cluster test ran without failures.
Validated on RHEL 5.2 i386 / x86_64 in 3 node openais cluster. (rev:720810)

->VERIFIED
Comment 8 errata-xmlrpc 2009-02-04 10:34:54 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0035.html

Note You need to log in before you can comment on or make changes to this bug.