Bug 470268 - (ATT_Mercury_BB_Modem) AT&T USBConnect "Mercury" BB Modem not recognized
AT&T USBConnect "Mercury" BB Modem not recognized
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hal-info (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 09:37 EST by Christopher A. Williams
Modified: 2009-10-19 10:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-19 10:03:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from lshal (146.66 KB, text/plain)
2008-11-06 09:38 EST, Christopher A. Williams
no flags Details
Sample modems.fdi file (631 bytes, application/octet-stream)
2008-11-06 09:40 EST, Christopher A. Williams
no flags Details
Output of /var/log/messages from time of the aircard plugged in to connection failure (5.44 KB, text/plain)
2009-02-02 14:07 EST, Adam Miller
no flags Details

  None (edit)
Description Christopher A. Williams 2008-11-06 09:37:44 EST
Description of problem:
AT&T USBConnect Broadband Card (Sierra Wireless) not properly recognized

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1.Insert SW Mercury Card into USB slot
2.Attempt to set up Mobile Broadband connection in NetworkManager
3.Card not available to set up
  
Actual results:
The card is being recognized when plugged in, but not as a USB broadband card. Intead it's recognized as some sort of USB storage device.

Expected results:
Card should be recognized as a USB Broadband Modem.

Additional info:
Per request on Fedora-Test-List, lshal output has been attached to this bug report.

Work-Around has been found for now:
Create the file /etc/hal/fdi/information/modems.fdi (sample attached) with the following content:

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- xml -*- -->
<deviceinfo version="0.2">
<device>

<!-- Sierra Modems -->
<match key="@info.parent:usb.vendor_id" int="0x1199">
<!-- GSM/EDGE/UMTS/HSDPA/HSUPA modems
In left-to-right order of product ID:
C885 0x6880
-->
<match key="@info.parent:usb.product_id" int_outof="0x6880">
<match key="@info.parent:usb.interface.number" int="4">
<append key="info.capabilities" type="strlist">modem</append>
<append key="modem.command_sets" type="strlist">GSM-07.07</append>
<append key="modem.command_sets" type="strlist">GSM-07.05</append>
</match>
</match>
</match>

</device>
</deviceinfo>

Reboot the system. He card is then correctly recognized and can be configured in NetworkManager.
Comment 1 Christopher A. Williams 2008-11-06 09:38:54 EST
Created attachment 322725 [details]
Output from lshal

lshal output from affected machine (Lenovo ThinkPad T400)
Comment 2 Christopher A. Williams 2008-11-06 09:40:19 EST
Created attachment 322727 [details]
Sample modems.fdi file

Sample modems.fdi file referred to in bug description work-around.
Comment 3 Chris Van Hoof 2008-11-19 23:24:50 EST
Just tested the fix in comment #2 on Fedora 10 Rawhide and I'm able to connect without any problems via NetworkManager
Comment 4 Bug Zapper 2008-11-25 23:53:10 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Adam Miller 2009-02-02 13:54:37 EST
I can confirm this bug using my Sierra Wireless AirCard 875U
Comment 6 Adam Miller 2009-02-02 13:57:17 EST
(In reply to comment #5)
> I can confirm this bug using my Sierra Wireless AirCard 875U

Sorry, I wasn't clear. I am still having an issue connecting via NetworkManager in Fedora 10 2.6.27.12 kernel.
Comment 7 Adam Miller 2009-02-02 14:07:13 EST
Created attachment 330665 [details]
Output of /var/log/messages from time of the aircard plugged in to connection failure
Comment 8 Adam Miller 2009-02-02 14:09:17 EST
I really wish bugzilla had an "edit post" function because I hate to keep adding replies as I find more information but the Ubuntu world appears to have the same issue so its highly possible that this is an upstream problem.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/322879
Comment 9 Christopher A. Williams 2009-07-11 09:02:57 EDT
I have since upgraded to F11 and this card now works as it should. Updates on F10 also seem to have fixed - but I can not say with certainty when. Suggest closing once the appropriate patch level is found...
Comment 10 Adam Miller 2009-10-19 10:03:13 EDT
This also works for me as well, I'll go ahead and close it and someone can re-open it if they are continuing to experience issues.

Note You need to log in before you can comment on or make changes to this bug.