This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 470277 - Sound stopped working after opening a video in totem
Sound stopped working after opening a video in totem
Status: CLOSED DUPLICATE of bug 475131
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 10:08 EST by Espen Stefansen
Modified: 2008-12-08 13:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 13:45:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from running pulseaudio -v (14.78 KB, text/plain)
2008-11-06 10:08 EST, Espen Stefansen
no flags Details

  None (edit)
Description Espen Stefansen 2008-11-06 10:08:30 EST
Created attachment 322736 [details]
Log from running pulseaudio -v

Description of problem:
I opened a video from nautilus in totem, but the program just stopped. Nothing happened. I killed the program and opened the video again. This time the video played, but no sound. It seems that totem killed pulseaudio.

I got this in messages:
pulseaudio[29473]: module-alsa-sink.c: Error opening PCM device front:0: Enheten eller ressursen opptatt
pulseaudio[29473]: sink-input.c: Assertion 'i->thread_info.rewrite_nbytes == 0' failed at pulsecore/sink-input.c:1150, function pa_sink_input_request_rewind(). Aborting.


I started pulseaudio and tried the video again, but still no sound. Pavucontroll says it sends all audio to null output.

I had started with verbose and found this: 
I: (alsa-lib)pcm_hw.c: open /dev/snd/pcmC0D0p failed
I: alsa-util.c: Couldn't open PCM device front:0: Enheten eller ressursen opptatt
I: (alsa-lib)pcm_hw.c: open /dev/snd/pcmC0D0p failed
I: alsa-util.c: Couldn't open PCM device surround40:0: Enheten eller ressursen opptatt
I: (alsa-lib)pcm_hw.c: open /dev/snd/pcmC0D0p failed
I: alsa-util.c: Couldn't open PCM device surround41:0: Enheten eller ressursen opptatt
I: (alsa-lib)pcm_hw.c: open /dev/snd/pcmC0D0p failed
I: alsa-util.c: Couldn't open PCM device surround50:0: Enheten eller ressursen opptatt
I: (alsa-lib)pcm_hw.c: open /dev/snd/pcmC0D0p failed
I: alsa-util.c: Couldn't open PCM device surround51:0: Enheten eller ressursen opptatt
I: (alsa-lib)confmisc.c: Unable to find definition 'cards.ICH4.pcm.surround71.0:CARD=0'
I: (alsa-lib)conf.c: function snd_func_refer returned error: Ingen slik fil eller filkatalog
I: (alsa-lib)conf.c: Evaluate error: Ingen slik fil eller filkatalog
I: (alsa-lib)pcm.c: Unknown PCM surround71:0
I: alsa-util.c: Couldn't open PCM device surround71:0: Ingen slik fil eller filkatalog
I: (alsa-lib)pcm_hw.c: open /dev/snd/pcmC0D0p failed
E: alsa-util.c: Error opening PCM device hw:0: Enheten eller ressursen opptatt
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_8086_27de_sound_card_0_alsa_playback_0 tsched=1"): initialization failed.

"Enheten eller ressursen opptatt" = resource busy

Another warning i often get is this:
W: module-alsa-source.c: Your kernel driver is broken: it reports a volume range from 18,00 dB to 18,00 dB which makes no sense.

lspci -v:
00:1e.2 Multimedia audio controller: Intel Corporation 82801G (ICH7 Family) AC'97 Audio Controller (rev 01)
	Subsystem: Dell OptiPlex GX620
	Flags: bus master, medium devsel, latency 0, IRQ 23
	I/O ports at ec00 [size=256]
	I/O ports at e8c0 [size=64]
	Memory at febffa00 (32-bit, non-prefetchable) [size=512]
	Memory at febff900 (32-bit, non-prefetchable) [size=256]
	Capabilities: [50] Power Management version 2
	Kernel driver in use: Intel ICH
	Kernel modules: snd-intel8x0


Version-Release number of selected component (if applicable):
alsa-plugins-pulseaudio-1.0.18-1.rc3.fc10.i386
pulseaudio-0.9.13-6.fc10.i386
pulseaudio-core-libs-0.9.13-6.fc10.i386
pulseaudio-esound-compat-0.9.13-6.fc10.i386
pulseaudio-libs-0.9.13-6.fc10.i386
pulseaudio-libs-glib2-0.9.13-6.fc10.i386
pulseaudio-libs-zeroconf-0.9.13-6.fc10.i386
pulseaudio-module-gconf-0.9.13-6.fc10.i386
pulseaudio-module-x11-0.9.13-6.fc10.i386
pulseaudio-utils-0.9.13-6.fc10.i386


How reproducible:
A couple of times a day.

Steps to Reproduce:
1. Open video in nautilus
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bug Zapper 2008-11-25 23:53:23 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Lennart Poettering 2008-12-08 13:45:15 EST
Some other application is blocking access to the sound card, and hence PA cannot open it. This will cause PA to load the null output driver instead which unfortunately is not well tested and is documented in bug 475131.

Finally, as PA mentions your audio driver is broken. The mixer information exposed to userspace by ALSA driver is bogus. That should be reported as seperate bug to the audio drivers.

Closing as duplicate.

*** This bug has been marked as a duplicate of bug 475131 ***

Note You need to log in before you can comment on or make changes to this bug.