Bug 470285 - Only Broker publishes System information
Only Broker publishes System information
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: cumin (Show other bugs)
1.0
All Linux
urgent Severity urgent
: 1.1
: ---
Assigned To: Justin Ross
Frantisek Reznicek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 10:33 EST by Matthew Farrellee
Modified: 2015-11-15 19:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 10:35:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Farrellee 2008-11-06 10:33:44 EST
(for pre 1.1 grid and cumin)

Each Slot in a pool advertises a "System" name with which it is associated. The System itself is advertised by another entity, at the moment that's the broker. If there is only one broker in a pool there is only one system and the System - Slot connection is broken because many Slots reference non-existent Systems.

This should be fixed by having a system agent on each machine in a pool, or so it would seem. This likely also ties into how RT will show up in the Console.

Right now all slots appear to be associated with the only System in the pool, the one published by the only broker in the pool.
Comment 1 Justin Ross 2008-12-05 09:58:40 EST
With sesame and the SysImage data, this has been fixed.  Big thanks to Ernie for helping me on this, too.
Comment 3 Justin Ross 2008-12-15 09:48:37 EST
In order to test this, do the following on a machine without a broker:

  * Install sesame
  * Configure it (/etc/sesame/sesame.conf) by setting the host attr to the hostname of a broker on a non-local host
  * service start sesame

You should then be able to see info about the machine where you installed sesame, and since it has no broker on it, we know that the info is not coming from the old System object.
Comment 4 Jan Sarenik 2008-12-15 10:25:22 EST
This is definitely working. Tested on clearly initialized
cumin-0.1.2997-1.el5, while connected only to north-15 as
a broker, and seeing my local machine which adertises itself
to north-15 via sesame.
Comment 6 errata-xmlrpc 2009-02-04 10:35:38 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0035.html

Note You need to log in before you can comment on or make changes to this bug.