Bug 470343 - [radeon.modeset] plasma crash during FolderView widget removal
[radeon.modeset] plasma crash during FolderView widget removal
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 14:39 EST by Artem
Modified: 2009-01-12 13:17 EST (History)
8 users (show)

See Also:
Fixed In Version: ???
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 13:17:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash backtrace (6.79 KB, text/plain)
2008-11-06 14:39 EST, Artem
no flags Details
another backtrace (5.36 KB, text/plain)
2008-11-07 14:55 EST, Artem
no flags Details
xorg.log (59.29 KB, text/plain)
2009-01-12 12:47 EST, Artem
no flags Details

  None (edit)
Description Artem 2008-11-06 14:39:41 EST
Created attachment 322776 [details]
crash backtrace

Description of problem:
Plasma crash while removing FolderView widget

Version-Release number of selected component (if applicable):
kdebase-workspace-4.1.2-11
kernel-2.6.27.4-79.fc10
qt-4.4.3-1.fc10
xorg-x11-drv-ati-6.9.0-38.fc10
xorg-x11-server-common-1.5.2-12.fc10

How reproducible:
when nomodeset kernel option is NOT set

Steps to Reproduce:
1. Add FolderView widget
2. Try remove it using widget icon
  
Actual results:
crash

Expected results:


Additional info:
Might be problem of kms, as passing nomodeset option to kernel (having ATI card RS485) error is not reproducible
Comment 1 Rex Dieter 2008-11-06 14:46:50 EST
kms/ati-driver interaction likely.

If possible, please do
yum install yum-utils
debuginfo-install kdebase-workspace

to see a better backtrace.
Comment 2 Artem 2008-11-07 14:55:33 EST
Created attachment 322893 [details]
another backtrace
Comment 3 Artem 2008-11-07 14:56:08 EST
however backtrace met not always, from time to time it's plasma crash, sometimes screen becomes just white and system freezes
Comment 4 Artem 2008-11-15 09:52:37 EST
oops, have this now even with nomodeset option passed.
kernel-2.6.27.5-109.fc10.x86_64
kdebase-workspace-4.1.2-14.fc10.x86_64
Comment 5 Bug Zapper 2008-11-25 23:54:29 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Steven M. Parrish 2009-01-09 16:15:10 EST
Thank you for the bug report.  This issue needs to be addressed by the upstream developers.  Please submit a report at http://bugs.kde.org. You are requested to add the bugzilla link here for tracking purposes. Please make sure the bug isn't already in the upstream bug tracker before filing it.
Comment 7 Kevin Kofler 2009-01-09 16:24:15 EST
Uh, no, that's an X11 or kernel bug, not a KDE bug. Reassigning, I'll leave it to the X11 triagers to decide whether to close this as a duplicate of the generic "nomodeset" bug or keep it separate.
Comment 8 Matěj Cepl 2009-01-10 19:27:08 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 9 Artem 2009-01-12 12:47:27 EST
Created attachment 328767 [details]
xorg.log
Comment 10 Artem 2009-01-12 12:52:58 EST
current packages versions:
kernel-2.6.27.10-167.fc10.x86_64
xorg-x11-drv-ati-6.9.0-63.fc10.x86_64

For some time I can't reproduce bug. Probably it had been fixed in between versions.

Note You need to log in before you can comment on or make changes to this bug.