Bug 470396 - gtk2 print dialog ignores/bypasses CUPS cover page options
gtk2 print dialog ignores/bypasses CUPS cover page options
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk2 (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Denise Dumas
desktop-bugs@redhat.com
https://bugzilla.redhat.com/show_bug....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 18:32 EST by Jack Perdue
Modified: 2015-01-01 10:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:08:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Perdue 2008-11-06 18:32:51 EST
Description of problem:

evince seems to totally disregard CUPS's cover page
settings when printing .ps files to network-shared
printer.


Version-Release number of selected component (if applicable):

cups-1.2.4-11.18.el5_2.2
evince-0.6.0-8.el5


How reproducible:

Very.


Steps to Reproduce:
1. Install cups on a system and set up CUPs printer using system-config-printer.  While setting up, under the Policies tab, select a style for  Starting Banner.  Also turn on sharing.
2. On another system on the same subnet, install cups and evince.  Load a Postscript (.ps) document and start Print dialog.  Do NOT select a style for Add a Cover Page (under the Job tab).  Press Print to start printing

  
Actual results:

No cover page appears.


Expected results:

The cover page/Starting Banner specified in system-config-printer should be printed before the .ps document.


Additional info:

This _may_ be related to RHB #439937 (evince attempts to do N-copies work itself (etc) resulting in N*N copies being printed at least when using CUPS).

I haven't determined if this affects other formats (e.g. .pdf) or if does the same thing when printing to a local (vs. network) printer.
Comment 1 Jack Perdue 2008-12-04 17:17:45 EST
This problem is not limited to evince and actually belongs to gtk2.

It appears that anything using the print dialog provided in libgtk-x11 ignores the print servers cover page settings (e.g. firefox 3, OpenOffice, etc.).
Comment 2 Jack Perdue 2008-12-04 17:33:09 EST
Ignore previous comment on RHB #439937.  I don't think it is applicable.

This may be (most likely is?) a duplicate of RHB #459491

It's a bit annoying in an office environment as:

1) people aren't always sure which is theirs.

2) people don't always pick up their printouts which leaves a bunch of unlabeled printouts at the printer (and no way to determine who they belong to).

It should probably be assigned to Matthias Clasen (mclasen@redhat.com) since he appears to get most the gtk2 bugs (I originally filed against evince before changing it to gtk2).
Comment 3 Eelko Berkenpies 2009-06-15 04:18:39 EDT
I'm having the same problem with F11/FF3.5b4/cups-1.4-0.b2.18.fc11.i586. Upstream is also fiddling with it since 2002-05-27 11:37:34 PDT (!): https://bugzilla.mozilla.org/show_bug.cgi?id=147419

Perhaps we could send a few votes their way? :)
Comment 7 RHEL Product and Program Management 2014-03-07 07:45:18 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 8 RHEL Product and Program Management 2014-06-02 09:08:39 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 9 Jack Perdue 2015-01-01 10:50:07 EST
this bug has been closed WONTFIX... why does it keep emailing me for MOREINFO?  I've long since given up on it.

Note You need to log in before you can comment on or make changes to this bug.