Bug 470437 - iscsiadm auto-starting iscsid does not always work
iscsiadm auto-starting iscsid does not always work
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: iscsi-initiator-utils (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Christie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 02:15 EST by Hans de Goede
Modified: 2012-06-26 12:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 01:22:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PATCH: fix iscsiadm auto-starting iscsid does not always work (3.29 KB, patch)
2008-11-07 02:15 EST, Hans de Goede
no flags Details | Diff

  None (edit)
Description Hans de Goede 2008-11-07 02:15:16 EST
Created attachment 322818 [details]
PATCH: fix iscsiadm auto-starting iscsid does not always work

iscsiadm will call "service iscsid start" if iscsid is not running and it needs it, however /etc/rc.d/init.d/iscsid will only start iscsid if disks are configured, so if no disks are configured this does not work.

I've attached a patch (to the package / cvsextras) which fixes this by adding a force-start to the initscript, and by making the autostart patch use "service iscsid force-start" instead of "service iscsid start", note this patch thus patches the patch for the latter.

Mike, all I need from you is an ack that it is ok to move forward with this change and I'll commit and build.

Mike, one question, should this go to F-10 final, or in an update? Since it doesn't affect iscsi using installs I personally think it is ok to do it as an update.
Comment 1 Mike Christie 2008-11-07 11:28:53 EST
Looks ok. Thanks.

For the F-10 final vs update:

If someone is installing this for the first time there will be no disks, so how can they get this started? Is there a workaround? Maybe we would want to release note it or note that a fix is going to be released right away in a update.

For existing installations with disks there is no regression right?
Comment 2 Hans de Goede 2008-11-08 07:52:32 EST
(In reply to comment #1)
> Looks ok. Thanks.
> 

Ok new version with the fix for this and for bug 470438 now building:
http://koji.fedoraproject.org/koji/buildinfo?buildID=68835

> For the F-10 final vs update:
> 
> If someone is installing this for the first time there will be no disks, so how
> can they get this started? Is there a workaround?
Not really.

> Maybe we would want to
> release note it or note that a fix is going to be released right away in a
> update.
We can release this as a 0 day update and then hope people who hit troubles try yum update first before looking any further, we can also try to get a release note in about this, hoping people actually read this.

Or we can request rel-eng to tag this build into F10-final, then we are sure no F-10 users will get bitten by this.

This is your call, I'll happily mail rel-eng or do a 0 day update.
Note that if people install iscsi-initiator-utils after installation using yum, they will get the new fixed version no matter which path we choose, and a default install does not include iscsi-initiator-utils.


> For existing installations with disks there is no regression right?
right.
Comment 3 Fedora Update System 2008-11-24 04:24:06 EST
iscsi-initiator-utils-6.2.0.870-0.2.rc1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/iscsi-initiator-utils-6.2.0.870-0.2.rc1.fc10
Comment 4 Bug Zapper 2008-11-25 23:56:37 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Fedora Update System 2008-11-26 01:22:19 EST
iscsi-initiator-utils-6.2.0.870-0.2.rc1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.