Bug 470447 - Pulseaudio crashes - Hard CPU time limit exhausted, terminating forcibly.
Pulseaudio crashes - Hard CPU time limit exhausted, terminating forcibly.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 03:54 EST by bug
Modified: 2008-12-18 06:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-18 06:45:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pulseaudio log (8.56 KB, text/plain)
2008-11-07 03:56 EST, bug
no flags Details

  None (edit)
Description bug 2008-11-07 03:54:35 EST
Description of problem:

Pulseaudio crashes while playing music (I'm using audacious). It occurs only when switching between windows in gnome using alt-tab. When using mouse to switch between windows it doesn't occur. It also doesn't occur during every window switching but considering one hundred attempts I have almost 100% probability of crash. Verbose output (pulseaudio -vvvvv) doesn't show anything significant until the crash when the two lines appear:

Soft CPU time limit exhausted, terminating.
Hard CPU time limit exhausted, terminating forcibly.

I'm using LENOVO R61 notebook and fully updated FC9.

How reproducible:

Log into gnome. Run music player (for example Audacious). Switch between windows using alt-tab till pulseaudio crashes.

Additional info:

I'm attaching pulseaudio log (pulseaudio -vvvvv) and the results of the following commands:

uname -a
Linux localhost.localdomain 2.6.26.6-79.fc9.x86_64 #1 SMP Fri Oct 17 14:20:33 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

rpm -qa | grep pulse
pulseaudio-libs-0.9.10-2.fc9.x86_64
pulseaudio-utils-0.9.10-2.fc9.x86_64
pulseaudio-libs-0.9.10-2.fc9.i386
pulseaudio-core-libs-0.9.10-2.fc9.x86_64
pulseaudio-esound-compat-0.9.10-2.fc9.x86_64
pulseaudio-module-gconf-0.9.10-2.fc9.x86_64
pulseaudio-libs-glib2-0.9.10-2.fc9.x86_64
gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.x86_64
pulseaudio-0.9.10-2.fc9.x86_64
pulseaudio-module-jack-0.9.10-2.fc9.x86_64
pulseaudio-module-x11-0.9.10-2.fc9.x86_64
alsa-plugins-pulseaudio-1.0.16-4.fc9.x86_64

rpm -qa | grep audacious
audacious-libs-1.4.6-1.fc9.i386
audacious-plugins-esd-1.4.5-1.fc9.x86_64
audacious-libs-1.4.6-1.fc9.x86_64
audacious-plugins-nonfree-mms-1.4.5-1.lvn9.x86_64
audacity-nonfree-1.3.4-0.7.20080123cvs.lvn9.x86_64
audacious-plugins-wavpack-1.4.5-1.fc9.x86_64
audacious-plugins-nonfree-aac-1.4.5-1.lvn9.x86_64
audacious-plugins-nonfree-mp3-1.4.5-1.lvn9.x86_64
audacious-devel-1.4.6-1.fc9.x86_64
audacious-plugins-jack-1.4.5-1.fc9.x86_64
audacious-plugins-nonfree-wma-1.4.5-1.lvn9.x86_64
audacious-plugins-nonfree-alac-1.4.5-1.lvn9.x86_64
audacious-1.4.6-1.fc9.x86_64
audacious-plugins-vortex-1.4.5-1.fc9.x86_64
audacious-plugins-arts-1.4.5-1.fc9.x86_64
audacious-devel-1.4.6-1.fc9.i386
audacious-plugins-nonfree-tta-1.4.5-1.lvn9.x86_64
audacious-plugin-fc-0.2-6.x86_64
audacious-plugins-metronome-1.4.5-1.fc9.x86_64
audacious-plugins-amidi-1.4.5-1.fc9.x86_64
audacious-plugins-1.4.5-1.fc9.x86_64
kadu-audacious_mediaplayer-0.6.0.1-1.fc9.x86_64

rpm -qa | grep compiz
libcompizconfig-0.7.6-1.fc9.x86_64
gnome-compiz-manager-0.10.4-4.fc9.i386
compiz-fusion-gnome-0.7.6-1.fc9.x86_64
gnome-compiz-manager-0.10.4-4.fc9.x86_64
compiz-gnome-0.7.6-3.fc9.1.x86_64
compizconfig-python-0.7.6-1.fc9.x86_64
compiz-fusion-extras-0.7.6-1.fc9.x86_64
compiz-0.7.6-3.fc9.1.x86_64
compiz-fusion-0.7.6-1.fc9.x86_64
compiz-fusion-extras-gnome-0.7.6-1.fc9.x86_64

lspci:
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 0c)
00:19.0 Ethernet controller: Intel Corporation 82566MC Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 140M (rev a1)
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)
15:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
15:00.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
15:00.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
15:00.3 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev ff)
15:00.4 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 11)
15:00.5 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 11)
Comment 1 bug 2008-11-07 03:56:45 EST
Created attachment 322826 [details]
Pulseaudio log
Comment 2 Lennart Poettering 2008-12-17 17:12:02 EST
Could you get me a profiling output for this please? Use opreport for that.

Something like "opreport -cl --demangle=smart `which pulseaudio` " should be perfect.
Comment 3 bug 2008-12-17 17:53:15 EST
Thank you for your response! Unfortunately that bug no longer occurs to me. Several updates have passed since 2008-11-07. I think one of them solved my problem. If I'll encounter it again I'll attach profiling output as you suggested.
Comment 4 Lennart Poettering 2008-12-18 06:45:47 EST
I guess trhat isn't that unfortunate... ;-)

Closing then.

Note You need to log in before you can comment on or make changes to this bug.