Bug 470467 - Ethernet does not start at boot time
Ethernet does not start at boot time
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
10
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 06:06 EST by Jean Francois Martinez
Modified: 2014-03-16 23:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 17:43:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean Francois Martinez 2008-11-07 06:06:13 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Ever

Steps to Reproduce:
1.  Install
2.  Boot 
3.
  
Actual results:
Ethernet does not start at boot time

Expected results:
Ethernet starting

Additional info:
Computer has two ethernet cards.  It does not use DHCP.   I don't use NetworkManager.
It is possible I made a mistake at install time since I found 192.168.0.2
(ie the adress of my DNS) as the mask value in the config file.  Anyway
after fixing it in the system-config-network the ethernet still does not start at boot time or when I do a /etc/init.d/network restart.  I checked the config
file with an aditor and the onboot flag was to yes.  Tried by disabling the NetworkManager service still does not work.  

Bug is critical at just two weeks of release.
Comment 1 Bill Nottingham 2008-11-07 11:42:00 EST
What happens when you do /etc/init.d/network restart?

Note that you'll have to specifically enable the network service with chkconfig to have it start on boot.
Comment 2 Jean Francois Martinez 2008-11-07 16:45:35 EST
When I submitted the bug it did nothing.  In fact it stopped the ethernet I had started manually and didn't restart it.   After today's updates and the enabling of networking the problem has disappeared.

It is a bizarre decison after 14 years of enabling networking by default that RedHat/Fedora has dedided to no longer do it.  In fact from a usability viewpoint it is a bug since many users will be surprised by the new behavior.
Comment 3 Bill Nottingham 2008-11-10 12:29:16 EST
Do you have NetworkManager installed?
Comment 4 Jean Francois Martinez 2008-11-10 14:02:45 EST
Yes  it is

I did a default install.
Comment 5 Bug Zapper 2008-11-25 23:57:36 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bill Nottingham 2008-12-01 10:51:18 EST
Please attach your ifcfg files, and the output of:

chkconfig --list network
chkconfig --list NetworkManager

This looks like a duplicate of 467946.
Comment 7 lexual 2009-03-03 20:00:21 EST
Is this still an issue for the reporter?
If so, can you please provide the info Bill has requested.
Comment 8 Jean Francois Martinez 2009-03-11 16:03:27 EDT
Problem is not present in the definitive release.  You may close the bug.

Note You need to log in before you can comment on or make changes to this bug.