Bug 470490 - Gnome picks US keybaord instead of national keyboard.
Gnome picks US keybaord instead of national keyboard.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
10
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 07:15 EST by Jean Francois Martinez
Modified: 2008-12-12 22:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-12 22:17:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean Francois Martinez 2008-11-07 07:15:25 EST
Description of problem:
Gnome "decides" to be in US keyboard instead of the configured one

Version-Release number of selected component (if applicable):


How reproducible:
Ever

Steps to Reproduce:
1.  Use system-config-keyboard (or at install time to pick a non US keyboard)
2.   Gnome starts to use thgat national keyboard.  Log out
3.  Ensure that the Non-US keyboard is the one selected in GDM.  Login.  Gnome is again in US mode.
  
Actual results:
Gnome uses US keyboard.

Expected results:
Gnome using my national keyboard

Additional info:
I use English as language but French as keyboard.  When I noticed the problem
I tried to reconfigure X... and found taht it used a builtin config.  After installing system-config-display (aI will fill a bug about this not being part
of ths standard installation) and ensuring that config has the right value for keyboard I was baffled that gnome still was using US keyboard.  I thought it could be GDM but was displaying "French latin 9"

I ended finding teh Gnome keybord preferences tool (in the preferences menu)
and found that the only layout listed was the US keyboard one.  I added the French one, selected it as default and that fixed the problem.

But I still consider this bug as criical enough to be a relase-stoppe.
Comment 1 Jean Francois Martinez 2008-11-07 16:35:49 EST
The updates I did tonight (could do them earlier since I hit a network bug) seem to have fixed the problem
Comment 2 Bug Zapper 2008-11-25 23:57:56 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matthias Clasen 2008-12-12 22:17:32 EST
Closing according to Comment 1

Note You need to log in before you can comment on or make changes to this bug.