Bug 470518 - Missing Dependency: kernel(rhel5_dlm_u3) = ... for kmod-gfs packages
Missing Dependency: kernel(rhel5_dlm_u3) = ... for kmod-gfs packages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-kmod (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Chris Feist
Alexander Todorov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 09:47 EST by Alexander Todorov
Modified: 2010-01-11 22:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:18:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-11-07 09:47:30 EST
Description of problem:
Yum upgrades from 5.2 to 5.3 snap #2 fail due to unsatisfied dependencies:

Error: Missing Dependency: kernel(rhel5_dlm_u3) =
ee96246055c25aab6ed0e0038b4214900df5dc6f is needed by package kmod-gfs-PAE
Error: Missing Dependency: kernel(rhel5_dlm_u3) =
0d6933577ef00e4c10daecba8524ad518e783b0c is needed by package kmod-gfs-xen
Error: Missing Dependency: kernel(rhel5_dlm_u3) =
c6d2cf4749f5a3407c6b1dd475e776fa779f43cd is needed by package kmod-gfs


Version-Release number of selected component (if applicable):
kmod-gfs-0.1.28-1.el5

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL 5.2 Server, @everything
2. try to upgrade to 5.3 with yum update
3.
  
Actual results:
yum transaction fails due to dependencies

Expected results:
transaction succeeds

Additional info:
This seems related to bug #466677. More precisely https://bugzilla.redhat.com/show_bug.cgi?id=466677#c13 which indicates the same dependency error.
Comment 2 Chris Feist 2008-11-07 17:11:40 EST
Which kernel are you trying to install this package on?
Comment 3 Chris Feist 2008-11-07 17:17:20 EST
This issue should be resolved by using the latest gfs kernel module:


kmod-gfs-0.1.29-1.el5

The problem was caused because the kernel(rhel5_dlm_u3) changed between kernel-2.6.18-122.el5 & -121.el5.  The snapshot picked up the -122 kernel, but not the new kmod-gfs.  (The new kmod-gfs may not have been built in time for Snap 2).
Comment 4 Chris Feist 2008-11-07 17:18:41 EST
I'm not sure what status to set this bug to, but it will be resolved when the latest kmod-gfs makes it into the next snapshot.
Comment 9 errata-xmlrpc 2009-01-20 16:18:26 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0132.html

Note You need to log in before you can comment on or make changes to this bug.