Bug 470556 - mplayer from atrpms is x86_64, unlike rpmfusion, and has an epoch ... and updates fail
mplayer from atrpms is x86_64, unlike rpmfusion, and has an epoch ... and upd...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 12:16 EST by Kurt Driver
Modified: 2014-01-21 18:06 EST (History)
6 users (show)

See Also:
Fixed In Version: yum-3.2.19-fc9.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 15:19:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Illustration of 'skip-broken' not bypassing broken packages (14.91 KB, text/plain)
2009-02-09 14:58 EST, Bob Agel
no flags Details

  None (edit)
Description Kurt Driver 2008-11-07 12:16:42 EST
Description of problem:

sudo yum --skip-broken upgrade

Downloading packages
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libxvidcore.so.4 is needed by mplayer-1.0-0.97.20080903svn.fc9.1.i386
liblzo2.so.2 is needed by mplayer-1.0-0.97.20080903svn.fc9.1.i386
Please report this error in bugzilla

yum whatprovides liblzo2.so.2

sudo yum install lzo

Downloading packages
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
liblzo2.so.2 is needed by mplayer-1.0-0.97.20080903svn.fc9.1.i386
Complete!
(1, [u'Please report this error in bugzilla'])





sudo yum --exclude-mplayer --skip-broken update

Downloading packages
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libxvidcore.so.4 is needed by mplayer-1.0-0.97.20080903svn.fc9.1.i386
liblzo2.so.2 is needed by mplayer-1.0-0.97.20080903svn.fc9.1.i386
Complete!
(1, [u'Please report this error in bugzilla'])

 rpm-4.4.2.3-2.fcp.src.rpm


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kurt Driver 2008-11-07 12:19:57 EST
Sorry, Seth, I missed this part
Reproducibility: 100%
Comment 2 Kurt Driver 2008-11-07 12:23:12 EST
And same as, with different packages,470291
Comment 3 seth vidal 2008-11-07 15:20:12 EST
what version of yum?
Comment 4 Kurt Driver 2008-11-08 19:49:32 EST
Its' yum-3.2.19-3.fc9.noarch
Comment 5 Tim Lauridsen 2008-11-09 01:08:46 EST
Please, test yum-3.2.20 from rawhide

yum --enablerepo=rawhide update yum

i should work with without problems in F9 and solve these --skip-broken issues.

if there is any problems with yum 3.2.20, then please attach the output from

'yum -d5 --skip-broken update'
Comment 6 Kurt Driver 2008-11-09 15:43:53 EST
Tim's suggest did not work. I must say this; I don't know how the version rawhide got in this bug report, It should be fedora 9. I have changed that above. Here's the error messages:

Installing the latest Yum:

[kurt@Jupiter ~]$ sudo yum --enablerepo=rawhide update yum
Loaded plugins: priorities, refresh-packagekit
http://mirrors.usc.edu/pub/linux/distributions/fedora/linux/development/x86_64/os/repodata/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
rawhide                                                 | 2.8 kB     00:00     
9bbd90c405701263181795870822b2e0b69bf9d1-primary.sqlite | 8.1 MB     12:26     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package yum.noarch 0:3.2.20-3.fc10 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package       Arch             Version                 Repository        Size 
================================================================================
Updating:
 yum           noarch           3.2.20-3.fc10           rawhide           811 k

Transaction Summary
================================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 811 k
Downloading Packages:
yum-3.2.20-3.fc10.noarch.rpm                            | 811 kB     01:53     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : yum                                               [1/2] 
  Cleanup        : yum                                               [2/2] 

Updated: yum.noarch 0:3.2.20-3.fc10
Complete!








Without --skip-broke:

[kurt@Jupiter ~]$ sudo yum update mplayer-*
[sudo] password for kurt: 
Loaded plugins: priorities, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package mplayer.x86_64 4:1.0-63.01_rc2.fc9 set to be updated
--> Processing Dependency: mplayer-fonts for package: mplayer
---> Package mplayer-skins.noarch 4:1.0-pre3_13.at set to be updated
--> Running transaction check
---> Package mplayer-fonts.noarch 4:1.0-7.at set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================
 Package             Arch         Version                   Repository    Size
===============================================================================
Installing:
 mplayer             x86_64       4:1.0-63.01_rc2.fc9       atrpms        13 M
     replacing  mplayer-gui.x86_64 1.0-0.97.20080903svn.fc9.1

Updating:
 mplayer-skins       noarch       4:1.0-pre3_13.at          atrpms        11 M
Installing for dependencies:
 mplayer-fonts       noarch       4:1.0-7.at                atrpms       1.0 M

Transaction Summary
===============================================================================
Install      2 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total size: 25 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /etc/mplayer/mplayer.conf from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/doc/mplayer-1.0/AUTHORS from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/doc/mplayer-1.0/Changelog from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/cs/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/de/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/es/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/fr/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/hu/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/it/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/pl/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/ru/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386

Error Summary
-------------

with --skip-broken:


[kurt@Jupiter ~]$ sudo yum update --skip-broken mplayer-*
Loaded plugins: priorities, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package mplayer.x86_64 4:1.0-63.01_rc2.fc9 set to be updated
--> Processing Dependency: mplayer-fonts for package: mplayer
---> Package mplayer-skins.noarch 4:1.0-pre3_13.at set to be updated
--> Running transaction check
---> Package mplayer-fonts.noarch 4:1.0-7.at set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================
 Package             Arch         Version                   Repository    Size
===============================================================================
Installing:
 mplayer             x86_64       4:1.0-63.01_rc2.fc9       atrpms        13 M
     replacing  mplayer-gui.x86_64 1.0-0.97.20080903svn.fc9.1

Updating:
 mplayer-skins       noarch       4:1.0-pre3_13.at          atrpms        11 M
Installing for dependencies:
 mplayer-fonts       noarch       4:1.0-7.at                atrpms       1.0 M

Transaction Summary
===============================================================================
Install      2 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total size: 25 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /etc/mplayer/mplayer.conf from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/doc/mplayer-1.0/AUTHORS from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/doc/mplayer-1.0/Changelog from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/cs/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/de/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/es/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/fr/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/hu/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/it/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/pl/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386
  file /usr/share/man/ru/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386

Error Summary
-------------

Thanks, Kurt
Comment 7 James Antill 2008-11-10 01:14:49 EST
 Ok, this might be another instance of a bug we've just fixed with install and obsoletes. Can you show the output for:

yum list mplayer\*

...also, can you see if this fixes the problem:

yum update mplayer-gui
Comment 8 Kurt Driver 2008-11-10 10:56:32 EST
[kurt@Jupiter ~]$ yum list mplayer\*
Loaded plugins: priorities, refresh-packagekit
Installed Packages
mplayer.i386                1.0-0.97.20080903svn.fc9.1    installed             
mplayer.x86_64              1.0-0.97.20080903svn.fc9.1    installed             
mplayer-docs.x86_64         1.0-0.44.rc2.fc9              installed             
mplayer-gui.x86_64          1.0-0.97.20080903svn.fc9.1    installed             
mplayer-skins.noarch        1.8-1                         installed             
Available Packages
mplayer.x86_64              4:1.0-63.01_rc2.fc9           atrpms                
mplayer-doc.x86_64          1.0-0.97.20080903svn.fc9.1    rpmfusion-free-updates
mplayer-fonts.noarch        4:1.0-7.at                    atrpms                
mplayer-skin-mini.noarch    4:0.1-11.2.at                 atrpms                
mplayer-skins.noarch        4:1.0-pre3_13.at              atrpms                
mplayerplug-in.x86_64       3.55-35.fc9                   atrpms   


And yum update mplayer-gui 
gets the same results as above
 file /usr/share/man/pl/man1/mplayer.1.gz from install of mplayer-1.0-63.01_rc2.fc9.x86_64 conflicts with file from package mplayer-1.0-0.97.20080903svn.fc9.1.i386

etc.
Comment 9 Kurt Driver 2008-11-10 11:09:56 EST
Somewhat belated, this is the last bit of sudo yum -d5 --skip-broken update
There are several hundred more lines, I couldn't figure out how to cut and paste them all from an xterm.


looking for (u'libdl.so.2(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libdirect-1.0_0.x86_64 0-1.0.1-15.fc9 - u
looking for (u'libz.so.1()(64bit)', None, (None, None, None)) as a requirement of libdirect-1.0_0.x86_64 0-1.0.1-15.fc9 - u
looking for (u'libc.so.6()(64bit)', None, (None, None, None)) as a requirement of libdirect-1.0_0.x86_64 0-1.0.1-15.fc9 - u
looking for (u'libpthread.so.0()(64bit)', None, (None, None, None)) as a requirement of libdirect-1.0_0.x86_64 0-1.0.1-15.fc9 - u
looking for (u'libgcc_s.so.1()(64bit)', None, (None, None, None)) as a requirement of libdirect-1.0_0.x86_64 0-1.0.1-15.fc9 - u
looking for (u'libdl.so.2()(64bit)', None, (None, None, None)) as a requirement of libdirect-1.0_0.x86_64 0-1.0.1-15.fc9 - u
---> Package libmp4v2_0.x86_64 0:1.26-3.fc9 set to be updated
Checking deps for libmp4v2_0.x86_64 0-1.26-3.fc9 - u
looking for (u'libc.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libmp4v2_0.x86_64 0-1.26-3.fc9 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libmp4v2_0.x86_64 0-1.26-3.fc9 - u
looking for (u'libstdc++.so.6(GLIBCXX_3.4)(64bit)', None, (None, None, None)) as a requirement of libmp4v2_0.x86_64 0-1.26-3.fc9 - u
looking for (u'libstdc++.so.6(CXXABI_1.3)(64bit)', None, (None, None, None)) as a requirement of libmp4v2_0.x86_64 0-1.26-3.fc9 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libmp4v2_0.x86_64 0-1.26-3.fc9 - u
looking for (u'libc.so.6(GLIBC_2.3.4)(64bit)', None, (None, None, None)) as a requirement of libmp4v2_0.x86_64 0-1.26-3.fc9 - u
looking for (u'libgcc_s.so.1(GCC_3.0)(64bit)', None, (None, None, None)) as a requirement of libmp4v2_0.x86_64 0-1.26-3.fc9 - u
looking for (u'libc.so.6(GLIBC_2.4)(64bit)', None, (None, None, None)) as a requirement of libmp4v2_0.x86_64 0-1.26-3.fc9 - u
looking for (u'libm.so.6()(64bit)', None, (None, None, None)) as a requirement of libmp4v2_0.x86_64 0-1.26-3.fc9 - u
looking for (u'libc.so.6()(64bit)', None, (None, None, None)) as a requirement of libmp4v2_0.x86_64 0-1.26-3.fc9 - u
looking for (u'libstdc++.so.6()(64bit)', None, (None, None, None)) as a requirement of libmp4v2_0.x86_64 0-1.26-3.fc9 - u
looking for (u'libgcc_s.so.1()(64bit)', None, (None, None, None)) as a requirement of libmp4v2_0.x86_64 0-1.26-3.fc9 - u
---> Package libdca0.x86_64 0:0.0.5-4.fc9 set to be updated
Checking deps for libdca0.x86_64 0-0.0.5-4.fc9 - u
looking for (u'libc.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libdca0.x86_64 0-0.0.5-4.fc9 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libdca0.x86_64 0-0.0.5-4.fc9 - u
looking for (u'libm.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libdca0.x86_64 0-0.0.5-4.fc9 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libdca0.x86_64 0-0.0.5-4.fc9 - u
looking for (u'libc.so.6(GLIBC_2.3.4)(64bit)', None, (None, None, None)) as a requirement of libdca0.x86_64 0-0.0.5-4.fc9 - u
looking for (u'libm.so.6()(64bit)', None, (None, None, None)) as a requirement of libdca0.x86_64 0-0.0.5-4.fc9 - u
looking for (u'libc.so.6()(64bit)', None, (None, None, None)) as a requirement of libdca0.x86_64 0-0.0.5-4.fc9 - u
---> Package libspf2_2.x86_64 0:1.2.5-5.fc9 set to be updated
Checking deps for libspf2_2.x86_64 0-1.2.5-5.fc9 - u
looking for (u'libc.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libspf2_2.x86_64 0-1.2.5-5.fc9 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libspf2_2.x86_64 0-1.2.5-5.fc9 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libspf2_2.x86_64 0-1.2.5-5.fc9 - u
looking for (u'libpthread.so.0(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libspf2_2.x86_64 0-1.2.5-5.fc9 - u
looking for (u'libresolv.so.2(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libspf2_2.x86_64 0-1.2.5-5.fc9 - u
looking for (u'libc.so.6(GLIBC_2.3.4)(64bit)', None, (None, None, None)) as a requirement of libspf2_2.x86_64 0-1.2.5-5.fc9 - u
looking for (u'libc.so.6(GLIBC_2.4)(64bit)', None, (None, None, None)) as a requirement of libspf2_2.x86_64 0-1.2.5-5.fc9 - u
looking for (u'libc.so.6(GLIBC_2.3)(64bit)', None, (None, None, None)) as a requirement of libspf2_2.x86_64 0-1.2.5-5.fc9 - u
looking for (u'libc.so.6()(64bit)', None, (None, None, None)) as a requirement of libspf2_2.x86_64 0-1.2.5-5.fc9 - u
looking for (u'libnsl.so.1()(64bit)', None, (None, None, None)) as a requirement of libspf2_2.x86_64 0-1.2.5-5.fc9 - u
looking for (u'libresolv.so.2()(64bit)', None, (None, None, None)) as a requirement of libspf2_2.x86_64 0-1.2.5-5.fc9 - u
looking for (u'libpthread.so.0()(64bit)', None, (None, None, None)) as a requirement of libspf2_2.x86_64 0-1.2.5-5.fc9 - u
---> Package libgoom2.x86_64 0:0-2.fc9 set to be updated
Checking deps for libgoom2.x86_64 0-0-2.fc9 - u
looking for (u'libc.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libgoom2.x86_64 0-0-2.fc9 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libgoom2.x86_64 0-0-2.fc9 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libgoom2.x86_64 0-0-2.fc9 - u
looking for (u'libc.so.6(GLIBC_2.3.4)(64bit)', None, (None, None, None)) as a requirement of libgoom2.x86_64 0-0-2.fc9 - u
looking for (u'libc.so.6(GLIBC_2.4)(64bit)', None, (None, None, None)) as a requirement of libgoom2.x86_64 0-0-2.fc9 - u
looking for (u'libc.so.6()(64bit)', None, (None, None, None)) as a requirement of libgoom2.x86_64 0-0-2.fc9 - u
---> Package libFLAC8.x86_64 2:1.2.1-1_14.fc8_90 set to be updated
Checking deps for libFLAC8.x86_64 2-1.2.1-1_14.fc8_90 - u
looking for (u'libc.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libFLAC8.x86_64 2-1.2.1-1_14.fc8_90 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libFLAC8.x86_64 2-1.2.1-1_14.fc8_90 - u
looking for (u'libm.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libFLAC8.x86_64 2-1.2.1-1_14.fc8_90 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libFLAC8.x86_64 2-1.2.1-1_14.fc8_90 - u
looking for (u'libc.so.6(GLIBC_2.3.4)(64bit)', None, (None, None, None)) as a requirement of libFLAC8.x86_64 2-1.2.1-1_14.fc8_90 - u
looking for (u'libc.so.6(GLIBC_2.7)(64bit)', None, (None, None, None)) as a requirement of libFLAC8.x86_64 2-1.2.1-1_14.fc8_90 - u
looking for (u'libc.so.6(GLIBC_2.4)(64bit)', None, (None, None, None)) as a requirement of libFLAC8.x86_64 2-1.2.1-1_14.fc8_90 - u
looking for (u'libm.so.6()(64bit)', None, (None, None, None)) as a requirement of libFLAC8.x86_64 2-1.2.1-1_14.fc8_90 - u
looking for (u'libc.so.6()(64bit)', None, (None, None, None)) as a requirement of libFLAC8.x86_64 2-1.2.1-1_14.fc8_90 - u
looking for (u'libogg.so.0()(64bit)', None, (None, None, None)) as a requirement of libFLAC8.x86_64 2-1.2.1-1_14.fc8_90 - u
---> Package libdc1394_22.x86_64 0:2.0.2-11.fc9 set to be updated
Checking deps for libdc1394_22.x86_64 0-2.0.2-11.fc9 - u
looking for (u'libc.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libdc1394_22.x86_64 0-2.0.2-11.fc9 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libdc1394_22.x86_64 0-2.0.2-11.fc9 - u
looking for (u'libm.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libdc1394_22.x86_64 0-2.0.2-11.fc9 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libdc1394_22.x86_64 0-2.0.2-11.fc9 - u
looking for (u'libc.so.6(GLIBC_2.3.4)(64bit)', None, (None, None, None)) as a requirement of libdc1394_22.x86_64 0-2.0.2-11.fc9 - u
looking for (u'libc.so.6(GLIBC_2.4)(64bit)', None, (None, None, None)) as a requirement of libdc1394_22.x86_64 0-2.0.2-11.fc9 - u
looking for (u'libm.so.6()(64bit)', None, (None, None, None)) as a requirement of libdc1394_22.x86_64 0-2.0.2-11.fc9 - u
looking for (u'libc.so.6()(64bit)', None, (None, None, None)) as a requirement of libdc1394_22.x86_64 0-2.0.2-11.fc9 - u
looking for (u'libraw1394.so.8()(64bit)', None, (None, None, None)) as a requirement of libdc1394_22.x86_64 0-2.0.2-11.fc9 - u
---> Package libraw1394_8.x86_64 0:1.3.0-8_11.fc9 set to be updated
Checking deps for libraw1394_8.x86_64 0-1.3.0-8_11.fc9 - u
looking for (u'libc.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libraw1394_8.x86_64 0-1.3.0-8_11.fc9 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libraw1394_8.x86_64 0-1.3.0-8_11.fc9 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libraw1394_8.x86_64 0-1.3.0-8_11.fc9 - u
looking for (u'libc.so.6()(64bit)', None, (None, None, None)) as a requirement of libraw1394_8.x86_64 0-1.3.0-8_11.fc9 - u
---> Package libavformat52.x86_64 0:0.4.9-26_r12135.fc9 set to be updated
Checking deps for libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'libc.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'libpthread.so.0(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'libm.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'libc.so.6(GLIBC_2.4)(64bit)', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'libc.so.6(GLIBC_2.3.4)(64bit)', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'libc.so.6(GLIBC_2.7)(64bit)', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'libc.so.6(GLIBC_2.3)(64bit)', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'libdl.so.2(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'libz.so.1()(64bit)', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'libdl.so.2()(64bit)', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'libc.so.6()(64bit)', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'libpthread.so.0()(64bit)', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'libavutil.so.49()(64bit)', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'libm.so.6()(64bit)', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
looking for (u'libavcodec.so.51()(64bit)', None, (None, None, None)) as a requirement of libavformat52.x86_64 0-0.4.9-26_r12135.fc9 - u
--> Running transaction check
Checking deps for lirc-libs.i386 0-0.8.4a-1.fc9 - None
mplayer-1.0-0.97.20080903svn.fc9.1.i386 requires: liblirc_client.so.0
--> Processing Dependency: liblirc_client.so.0 for package: mplayer
Needed Require is not a package name. Looking up: liblirc_client.so.0
Potential Provider: lirc-libs.i386 0:0.8.4a-1.fc9
Mode is u for provider of liblirc_client.so.0: lirc-libs.i386 0:0.8.4a-1.fc9
Mode for pkg providing liblirc_client.so.0: u
Cannot find an update path for dep for: liblirc_client.so.0
Searching pkgSack for dep: liblirc_client.so.0
Potential match for liblirc_client.so.0 from lirc-libs-0.8.4a-1.fc9.i386
Matched lirc-libs-0.8.4a-1.fc9.i386 to require for liblirc_client.so.0
Potential match for liblirc_client.so.0 from lirc-libs-0.8.3-0.3.pre2.fc9.i386
Matched lirc-libs-0.8.3-0.3.pre2.fc9.i386 to require for liblirc_client.so.0
lirc-libs-0.8.4a-1.fc9.i386 is in providing packages but it is already installed, removing.
Potential resolving package lirc-libs-0.8.3-0.3.pre2.fc9.i386 has newer instance in ts.
Potential resolving package lirc-libs-0.8.3-0.3.pre2.fc9.i386 has newer instance installed.
---> Package libx264_58.x86_64 0:svn20080225_2245-5.fc9 set to be updated
Checking deps for libx264_58.x86_64 0-svn20080225_2245-5.fc9 - u
looking for (u'libc.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libx264_58.x86_64 0-svn20080225_2245-5.fc9 - u
looking for (u'libpthread.so.0(GLIBC_2.3.2)(64bit)', None, (None, None, None)) as a requirement of libx264_58.x86_64 0-svn20080225_2245-5.fc9 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libx264_58.x86_64 0-svn20080225_2245-5.fc9 - u
looking for (u'libpthread.so.0(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libx264_58.x86_64 0-svn20080225_2245-5.fc9 - u
looking for (u'libm.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of libx264_58.x86_64 0-svn20080225_2245-5.fc9 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libx264_58.x86_64 0-svn20080225_2245-5.fc9 - u
looking for (u'libc.so.6(GLIBC_2.3.4)(64bit)', None, (None, None, None)) as a requirement of libx264_58.x86_64 0-svn20080225_2245-5.fc9 - u
looking for (u'libc.so.6(GLIBC_2.7)(64bit)', None, (None, None, None)) as a requirement of libx264_58.x86_64 0-svn20080225_2245-5.fc9 - u
looking for (u'libc.so.6(GLIBC_2.4)(64bit)', None, (None, None, None)) as a requirement of libx264_58.x86_64 0-svn20080225_2245-5.fc9 - u
looking for (u'libm.so.6()(64bit)', None, (None, None, None)) as a requirement of libx264_58.x86_64 0-svn20080225_2245-5.fc9 - u
looking for (u'libc.so.6()(64bit)', None, (None, None, None)) as a requirement of libx264_58.x86_64 0-svn20080225_2245-5.fc9 - u
looking for (u'libpthread.so.0()(64bit)', None, (None, None, None)) as a requirement of libx264_58.x86_64 0-svn20080225_2245-5.fc9 - u
looking for (u'libX11.so.6()(64bit)', None, (None, None, None)) as a requirement of libx264_58.x86_64 0-svn20080225_2245-5.fc9 - u
--> Finished Dependency Resolution
Dependency Process ending
mplayer-1.0-0.97.20080903svn.fc9.1.i386 from installed has depsolving problems
  --> Missing Dependency: liblirc_client.so.0 is needed by package mplayer-1.0-0.97.20080903svn.fc9.1.i386 (installed)
Skip-broken round 1
SKIPBROKEN: removing lirc-0.8.4a-81.fc9.x86_64 from pkgSack & updates
SKIPBROKEN: removing lirc-libs-0.8.4a-1.fc9.x86_64 from transaction
SKIPBROKEN: removing lirc-libs-0.8.4a-1.fc9.i386 from transaction
SKIPBROKEN: removing lirc-0.8.4a-81.fc9.x86_64 from transaction
--> Running transaction check
Checking deps for lirc-libs.i386 0-0.8.4a-1.fc9 - None
looking for ('/sbin/ldconfig', None, (None, None, None)) as a requirement of lirc-libs.i386 0-0.8.4a-1.fc9 - None
looking for ('/sbin/ldconfig', None, (None, None, None)) as a requirement of lirc-libs.i386 0-0.8.4a-1.fc9 - None
looking for ('libc.so.6', None, (None, None, None)) as a requirement of lirc-libs.i386 0-0.8.4a-1.fc9 - None
looking for ('libc.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement of lirc-libs.i386 0-0.8.4a-1.fc9 - None
looking for ('libc.so.6(GLIBC_2.1)', None, (None, None, None)) as a requirement of lirc-libs.i386 0-0.8.4a-1.fc9 - None
looking for ('libc.so.6(GLIBC_2.1.3)', None, (None, None, None)) as a requirement of lirc-libs.i386 0-0.8.4a-1.fc9 - None
looking for ('libc.so.6(GLIBC_2.3.4)', None, (None, None, None)) as a requirement of lirc-libs.i386 0-0.8.4a-1.fc9 - None
looking for ('libc.so.6(GLIBC_2.4)', None, (None, None, None)) as a requirement of lirc-libs.i386 0-0.8.4a-1.fc9 - None
looking for ('rtld(GNU_HASH)', None, (None, None, None)) as a requirement of lirc-libs.i386 0-0.8.4a-1.fc9 - None
Checking deps for lirc-libs.x86_64 0-0.8.4a-1.fc9 - None
looking for ('/sbin/ldconfig', None, (None, None, None)) as a requirement of lirc-libs.x86_64 0-0.8.4a-1.fc9 - None
looking for ('/sbin/ldconfig', None, (None, None, None)) as a requirement of lirc-libs.x86_64 0-0.8.4a-1.fc9 - None
looking for ('libc.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of lirc-libs.x86_64 0-0.8.4a-1.fc9 - None
looking for ('libc.so.6(GLIBC_2.3.4)(64bit)', None, (None, None, None)) as a requirement of lirc-libs.x86_64 0-0.8.4a-1.fc9 - None
looking for ('libc.so.6(GLIBC_2.4)(64bit)', None, (None, None, None)) as a requirement of lirc-libs.x86_64 0-0.8.4a-1.fc9 - None
looking for ('rtld(GNU_HASH)', None, (None, None, None)) as a requirement of lirc-libs.x86_64 0-0.8.4a-1.fc9 - None
looking for ('libc.so.6()(64bit)', None, (None, None, None)) as a requirement of lirc-libs.x86_64 0-0.8.4a-1.fc9 - None
---> Package lirc.x86_64 0:0.8.4a-81.fc9 set to be updated
Checking deps for lirc.x86_64 0-0.8.4a-81.fc9 - u
--> Finished Dependency Resolution
Dependency Process ending
Skip-broken took 1 rounds 

Packages skipped because of dependency problems:
    lirc-0.8.4a-81.fc9.x86_64 from atrpms
Depsolve time: 5.323

Dependencies Resolved

================================================================================
 Package                   Arch   Version                  Repository      Size
================================================================================
Installing:
 clamav                    x86_64 0.94.1-40.fc9            atrpms          19 M
     replacing  clamav-data.x86_64 0.93.3-1.fc9

 faac                      x86_64 1.26-3.fc9               atrpms          66 k
     replacing  libmp4v2.x86_64 1.5.0.1-6.fc9

 mplayer                   x86_64 4:1.0-63.01_rc2.fc9      atrpms          13 M
     replacing  mencoder.x86_64 1.0-0.97.20080903svn.fc9.1

 nessus                    x86_64 1:2.2.11-27.fc9          atrpms         267 k
     replacing  nessus-libraries.x86_64 2.2.10-3.fc9

Updating:
 VLGothic-fonts            noarch 20081029-1.fc9           updates-newkey 2.3 M
 directfb                  x86_64 1.0.1-15.fc9             atrpms         2.8 M
 dovecot                   x86_64 1:1.1.6-0_83.fc9         atrpms         3.0 M
 exim                      x86_64 4.69-34.fc9              atrpms         1.3 M
 ffmpeg                    x86_64 0.4.9-26_r12135.fc9      atrpms         196 k
 fftw                      x86_64 3.1.2-11.fc9             atrpms         1.3 M
 flac                      x86_64 2:1.2.1-1_14.fc8_90      atrpms         956 k
 fuse                      x86_64 2.7.4-8_10.fc9           atrpms          84 k
 fuse-libs                 x86_64 2.7.4-8_10.fc9           atrpms          72 k
 gnome-mplayer             x86_64 0.8.0-2.fc9              atrpms         265 k
 ipw2200-firmware          noarch 3.0-9.0.1                atrpms         270 k
 lame                      x86_64 3.98.2-18.fc9            atrpms         315 k
 libdc1394                 x86_64 2.0.2-11.fc9             atrpms         346 k
 libdca                    x86_64 0.0.5-4.fc9              atrpms          35 k
 libquicktime              x86_64 1.0.3-23.fc9             atrpms         167 k
 libraw1394                x86_64 1.3.0-8_11.fc9           atrpms          29 k
 logwatch                  noarch 7.3.6-26.fc9             updates-newkey 320 k
 lzo                       x86_64 2.03-6.fc9               atrpms          18 k
 mjpegtools                x86_64 1:1.9.0-16_rc3.fc8_90    atrpms         873 k
 mplayer-skins             noarch 4:1.0-pre3_13.at         atrpms          11 M
 nessus-server             x86_64 1:2.2.11-27.fc9          atrpms         1.2 M
 vlc                       x86_64 0.9.5-32.fc9             atrpms         8.8 M
 xvidcore                  x86_64 1.1.3-11.fc9             atrpms         151 k
Installing for dependencies:
 bitstream-vera-fonts      noarch 1.10-8                   fedora         345 k
 fuse-kmdl-2.6.26.6-79.fc9 x86_64 2.7.4-8_10.fc9           atrpms          27 k
 libFLAC++6                x86_64 2:1.2.1-1_14.fc8_90      atrpms          32 k
 libFLAC8                  x86_64 2:1.2.1-1_14.fc8_90      atrpms         143 k
 libavcodec51              x86_64 0.4.9-26_r12135.fc9      atrpms         1.7 M
 libavdevice52             x86_64 0.4.9-26_r12135.fc9      atrpms          20 k
 libavformat52             x86_64 0.4.9-26_r12135.fc9      atrpms         293 k
 libavutil49               x86_64 0.4.9-26_r12135.fc9      atrpms          25 k
 libdc1394_22              x86_64 2.0.2-11.fc9             atrpms          81 k
 libdca0                   x86_64 0.0.5-4.fc9              atrpms          98 k
 libdirect-1.0_0           x86_64 1.0.1-15.fc9             atrpms          40 k
 libdirectfb-1.0_0         x86_64 1.0.1-15.fc9             atrpms         186 k
 libfaac0                  x86_64 1.26-3.fc9               atrpms          38 k
 libfusion-1.0_0           x86_64 1.0.1-15.fc9             atrpms          18 k
 libgoom2                  x86_64 0-2.fc9                  atrpms          87 k
 libhosts_gatherer2        x86_64 1:2.2.11-27.fc9          atrpms          18 k
 liblirc_client0           x86_64 0.8.4a-81.fc9            atrpms          18 k
 liblzo2_2                 x86_64 2.03-6.fc9               atrpms          50 k
 libmp3lame0               x86_64 3.98.2-18.fc9            atrpms         139 k
 libmp4v2_0                x86_64 1.26-3.fc9               atrpms         239 k
 libnasl2                  x86_64 1:2.2.11-27.fc9          atrpms         110 k
 libnessus2                x86_64 1:2.2.11-27.fc9          atrpms          67 k
 libpcap-nessus2           x86_64 1:2.2.11-27.fc9          atrpms          50 k
 libpostproc51             x86_64 0.4.9-26_r12135.fc9      atrpms          24 k
 libquicktime0             x86_64 1.0.3-23.fc9             atrpms         223 k
 libraw1394_8              x86_64 1.3.0-8_11.fc9           atrpms          13 k
 libspf2_2                 x86_64 1.2.5-5.fc9              atrpms          49 k
 libsrs_alt1               x86_64 1.0-3_rc1.fc9            atrpms          13 k
 libswscale0               x86_64 0.4.9-26_r12135.fc9      atrpms          66 k
 libx264_58                x86_64 svn20080225_2245-5.fc9   atrpms         207 k
 libxvidcore4              x86_64 1.1.3-11.fc9             atrpms         448 k
 mplayer-fonts             noarch 4:1.0-7.at               atrpms         1.0 M
Skipped (dependency problems):
 lirc                      x86_64 0.8.4a-81.fc9            atrpms         630 k

Transaction Summary
================================================================================
Install     36 Package(s)         
Update      23 Package(s)         
Remove       0 Package(s)         

Total size: 74 M
Total download size: 2.6 M
Downloading Packages:
using local copy of libgoom2-0-2.fc9.x86_64
using local copy of libfusion-1.0_0-1.0.1-15.fc9.x86_64
using local copy of libx264_58-svn20080225_2245-5.fc9.x86_64
using local copy of 2:libFLAC++6-1.2.1-1_14.fc8_90.x86_64
using local copy of libxvidcore4-1.1.3-11.fc9.x86_64
using local copy of faac-1.26-3.fc9.x86_64
using local copy of libpostproc51-0.4.9-26_r12135.fc9.x86_64
using local copy of libquicktime0-1.0.3-23.fc9.x86_64
using local copy of libavutil49-0.4.9-26_r12135.fc9.x86_64
using local copy of fftw-3.1.2-11.fc9.x86_64
using local copy of libmp3lame0-3.98.2-18.fc9.x86_64
using local copy of libraw1394_8-1.3.0-8_11.fc9.x86_64
using local copy of libavdevice52-0.4.9-26_r12135.fc9.x86_64
using local copy of libquicktime-1.0.3-23.fc9.x86_64
using local copy of fuse-kmdl-2.6.26.6-79.fc9-2.7.4-8_10.fc9.x86_64
using local copy of 1:libhosts_gatherer2-2.2.11-27.fc9.x86_64
using local copy of xvidcore-1.1.3-11.fc9.x86_64
using local copy of 1:libnessus2-2.2.11-27.fc9.x86_64
using local copy of clamav-0.94.1-40.fc9.x86_64
using local copy of 1:dovecot-1.1.6-0_83.fc9.x86_64
using local copy of libswscale0-0.4.9-26_r12135.fc9.x86_64
using local copy of 1:libpcap-nessus2-2.2.11-27.fc9.x86_64
using local copy of fuse-2.7.4-8_10.fc9.x86_64
using local copy of libavcodec51-0.4.9-26_r12135.fc9.x86_64
using local copy of fuse-libs-2.7.4-8_10.fc9.x86_64
using local copy of directfb-1.0.1-15.fc9.x86_64
using local copy of gnome-mplayer-0.8.0-2.fc9.x86_64
using local copy of libdc1394-2.0.2-11.fc9.x86_64
using local copy of 4:mplayer-fonts-1.0-7.at.noarch
using local copy of libdc1394_22-2.0.2-11.fc9.x86_64
using local copy of 1:mjpegtools-1.9.0-16_rc3.fc8_90.x86_64
using local copy of bitstream-vera-fonts-1.10-8.noarch
using local copy of 1:nessus-server-2.2.11-27.fc9.x86_64
using local copy of libspf2_2-1.2.5-5.fc9.x86_64
using local copy of 4:mplayer-1.0-63.01_rc2.fc9.x86_64
using local copy of 2:libFLAC8-1.2.1-1_14.fc8_90.x86_64
using local copy of lame-3.98.2-18.fc9.x86_64
using local copy of exim-4.69-34.fc9.x86_64
using local copy of liblzo2_2-2.03-6.fc9.x86_64
using local copy of libdirect-1.0_0-1.0.1-15.fc9.x86_64
using local copy of 1:nessus-2.2.11-27.fc9.x86_64
using local copy of ffmpeg-0.4.9-26_r12135.fc9.x86_64
using local copy of libraw1394-1.3.0-8_11.fc9.x86_64
using local copy of vlc-0.9.5-32.fc9.x86_64
using local copy of 2:flac-1.2.1-1_14.fc8_90.x86_64
using local copy of libdca-0.0.5-4.fc9.x86_64
using local copy of libsrs_alt1-1.0-3_rc1.fc9.x86_64
using local copy of libdca0-0.0.5-4.fc9.x86_64
using local copy of libfaac0-1.26-3.fc9.x86_64
using local copy of 4:mplayer-skins-1.0-pre3_13.at.noarch
using local copy of 1:libnasl2-2.2.11-27.fc9.x86_64
using local copy of libavformat52-0.4.9-26_r12135.fc9.x86_64
using local copy of lzo-2.03-6.fc9.x86_64
using local copy of libdirectfb-1.0_0-1.0.1-15.fc9.x86_64
using local copy of ipw2200-firmware-3.0-9.0.1.noarch
using local copy of libmp4v2_0-1.26-3.fc9.x86_64
(1/3): liblirc_client0-0.8.4a-81.fc9.x86_64.rpm          |  18 kB     00:00     
(2/3): logwatch-7.3.6-26.fc9.noarch.rpm                  | 320 kB     00:03     
(3/3): VLGothic-fonts-20081029-1.fc9.noarch.rpm          | 2.3 MB     00:16     
--------------------------------------------------------------------------------
Total                                            95 kB/s | 2.6 MB     00:28     
Running rpm_check_debug
Adding Package libgoom2-0-2.fc9.x86_64 in mode u
Adding Package libfusion-1.0_0-1.0.1-15.fc9.x86_64 in mode u
Adding Package libx264_58-svn20080225_2245-5.fc9.x86_64 in mode u
Adding Package 2:libFLAC++6-1.2.1-1_14.fc8_90.x86_64 in mode u
Adding Package libxvidcore4-1.1.3-11.fc9.x86_64 in mode u
Adding Package faac-1.26-3.fc9.x86_64 in mode u
Adding Package libpostproc51-0.4.9-26_r12135.fc9.x86_64 in mode u
Adding Package libquicktime0-1.0.3-23.fc9.x86_64 in mode u
Adding Package libavutil49-0.4.9-26_r12135.fc9.x86_64 in mode u
Adding Package fftw-3.1.2-11.fc9.x86_64 in mode u
Adding Package libmp3lame0-3.98.2-18.fc9.x86_64 in mode u
Adding Package libraw1394_8-1.3.0-8_11.fc9.x86_64 in mode u
Adding Package libavdevice52-0.4.9-26_r12135.fc9.x86_64 in mode u
Adding Package VLGothic-fonts-20081029-1.fc9.noarch in mode u
Adding Package libquicktime-1.0.3-23.fc9.x86_64 in mode u
Adding Package fuse-kmdl-2.6.26.6-79.fc9-2.7.4-8_10.fc9.x86_64 in mode u
Adding Package 1:libhosts_gatherer2-2.2.11-27.fc9.x86_64 in mode u
Adding Package xvidcore-1.1.3-11.fc9.x86_64 in mode u
Adding Package 1:libnessus2-2.2.11-27.fc9.x86_64 in mode u
Adding Package clamav-0.94.1-40.fc9.x86_64 in mode u
Adding Package 1:dovecot-1.1.6-0_83.fc9.x86_64 in mode u
Adding Package libswscale0-0.4.9-26_r12135.fc9.x86_64 in mode u
Adding Package 1:libpcap-nessus2-2.2.11-27.fc9.x86_64 in mode u
Adding Package fuse-2.7.4-8_10.fc9.x86_64 in mode u
Adding Package libavcodec51-0.4.9-26_r12135.fc9.x86_64 in mode u
Adding Package fuse-libs-2.7.4-8_10.fc9.x86_64 in mode u
Adding Package directfb-1.0.1-15.fc9.x86_64 in mode u
Adding Package gnome-mplayer-0.8.0-2.fc9.x86_64 in mode u
Adding Package libdc1394-2.0.2-11.fc9.x86_64 in mode u
Adding Package 4:mplayer-fonts-1.0-7.at.noarch in mode u
Adding Package libdc1394_22-2.0.2-11.fc9.x86_64 in mode u
Adding Package 1:mjpegtools-1.9.0-16_rc3.fc8_90.x86_64 in mode u
Adding Package logwatch-7.3.6-26.fc9.noarch in mode u
Adding Package bitstream-vera-fonts-1.10-8.noarch in mode u
Adding Package 1:nessus-server-2.2.11-27.fc9.x86_64 in mode u
Adding Package libspf2_2-1.2.5-5.fc9.x86_64 in mode u
Adding Package 4:mplayer-1.0-63.01_rc2.fc9.x86_64 in mode u
Adding Package 2:libFLAC8-1.2.1-1_14.fc8_90.x86_64 in mode u
Adding Package liblirc_client0-0.8.4a-81.fc9.x86_64 in mode u
Adding Package lame-3.98.2-18.fc9.x86_64 in mode u
Adding Package exim-4.69-34.fc9.x86_64 in mode u
Adding Package liblzo2_2-2.03-6.fc9.x86_64 in mode u
Adding Package libdirect-1.0_0-1.0.1-15.fc9.x86_64 in mode u
Adding Package 1:nessus-2.2.11-27.fc9.x86_64 in mode u
Adding Package ffmpeg-0.4.9-26_r12135.fc9.x86_64 in mode u
Adding Package libraw1394-1.3.0-8_11.fc9.x86_64 in mode u
Adding Package vlc-0.9.5-32.fc9.x86_64 in mode u
Adding Package 2:flac-1.2.1-1_14.fc8_90.x86_64 in mode u
Adding Package libdca-0.0.5-4.fc9.x86_64 in mode u
Adding Package libsrs_alt1-1.0-3_rc1.fc9.x86_64 in mode u
Adding Package libdca0-0.0.5-4.fc9.x86_64 in mode u
Adding Package libfaac0-1.26-3.fc9.x86_64 in mode u
Adding Package 4:mplayer-skins-1.0-pre3_13.at.noarch in mode u
Adding Package 1:libnasl2-2.2.11-27.fc9.x86_64 in mode u
Adding Package libavformat52-0.4.9-26_r12135.fc9.x86_64 in mode u
Adding Package lzo-2.03-6.fc9.x86_64 in mode u
Adding Package libdirectfb-1.0_0-1.0.1-15.fc9.x86_64 in mode u
Adding Package ipw2200-firmware-3.0-9.0.1.noarch in mode u
Adding Package libmp4v2_0-1.26-3.fc9.x86_64 in mode u
ERROR with rpm_check_debug vs depsolve:
libxvidcore.so.4 is needed by (installed) mplayer-1.0-0.97.20080903svn.fc9.1.i386
liblzo2.so.2 is needed by (installed) mplayer-1.0-0.97.20080903svn.fc9.1.i386
Complete!
(1, [u'Please report this error in bugzilla'])
Comment 10 Bob Agel 2009-02-09 14:58:03 EST
Created attachment 331352 [details]
Illustration of 'skip-broken' not bypassing broken packages

Though not the same dep error, I've attached this to show that 'skip-broken' will not bypass broken packages 100% of the time.  Rahul's 'sh yum.sh' method, while slower and a bit ancient by comparison does handle the issues properly.

Since this is Rawhide, I'm not overly concerned with the actual updates as much as trying to get 'skip-broken' to work perfectly.
Comment 11 James Antill 2009-03-06 15:19:10 EST
Note that this appears to be fixed with current HEAD:

% sudo yum --enablerepo=atrpms up mplayer
No Packages marked for Update
% sudo yum ls mplayer
Installed Packages
mplayer.i386           1.0-0.104.20090204svn.fc10       installed             
Available Packages
mplayer.x86_64         1.0-0.104.20090204svn.fc10       rpmfusion-free-updates
% sudo yum ls mplayer --enablerepo=atrpms
Installed Packages
mplayer.i386                 1.0-0.104.20090204svn.fc10              installed
Available Packages
mplayer.x86_64               4:1.0-64_snap20081116.fc9               atrpms

Note You need to log in before you can comment on or make changes to this bug.