Bug 470591 - [REG] Warning and FATAL messsages spew during kmod installation
[REG] Warning and FATAL messsages spew during kmod installation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: redhat-rpm-config (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jon Masters
BaseOS QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 15:37 EST by Keiichiro Tokunaga
Modified: 2011-02-10 08:14 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:04:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (500 bytes, patch)
2008-12-09 09:51 EST, Olivier Fourdan
no flags Details | Diff

  None (edit)
Description Keiichiro Tokunaga 2008-11-07 15:37:55 EST
Description of problem:
The following messages are output during kmod installation.

[root@dhcp47-139 dup]# rpm -ihv kmod-dup_cert_pass-1.0-0.ia64.rpm 
Preparing...                ########################################### [100%]
   1:kmod-dup_cert_pass     ########################################### [100%]
modinfo: could not open /lib/modules/2.6.18-121.el5/extra/dup_cert_pass: Is a directory
FATAL: /lib/modules/2.6.18-121.el5/extra/dup_cert_pass: Is a directory
Warning: Module dup_cert_pass from kernel  has no modversions, so it cannot be reused for kernel 2.6.18-120.el5
modinfo: could not open /lib/modules/2.6.18-121.el5/extra/dup_cert_pass: Is a directory
FATAL: /lib/modules/2.6.18-121.el5/extra/dup_cert_pass: Is a directory
Warning: Module dup_cert_pass from kernel  has no modversions, so it cannot be reused for kernel 2.6.18-122.el5

Version-Release number of selected component (if applicable):
redhat-rpm-config-8.0.45-27.el5

How reproducible:
Always.

Steps to Reproduce:
1. Install two or more kernels in the system.
2. Install your kmod RPM that was built on 5.3 environment.
  
Actual results:
The messages are output.

Expected results:
No messages are output.

Additional info:
- Seems the changes to the logic to obtain the paths of modules in kmodtool are the cause of the problem.
    Old: modules=( \$(rpm -ql kmod-${kmod_name}${dashvariant} | grep '\.ko$') )
    New: modules=( \$(find /lib/modules/${verrel}${variant}/extra/${kmod_name}) )
  find returns directories as well, making modinfo complain.
- Because of above, an installation of kmod that was built on 5.2 environment completes without the messages.  (The kmod contains the old logic in itself.)
Comment 1 Olivier Fourdan 2008-12-09 09:51:40 EST
Created attachment 326321 [details]
Proposed patch
Comment 4 RHEL Product and Program Management 2008-12-09 10:49:14 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 8 Jon Masters 2008-12-10 15:23:42 EST
Rebuild this package with a fix similar to that posted. Thanks!
Comment 17 errata-xmlrpc 2009-01-20 17:04:36 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0224.html

Note You need to log in before you can comment on or make changes to this bug.